LINUX.ORG.RU

debian squeeze не запускается DE после обновления ядра


0

1

стояло ядро 2.6.32-5-686. Поставил 3.2.0-0.bpo.4-686-pae. Загрузил ядро 3.2.0-0.bpo.4-686-pae иксы не запустились, авторизовался через терминал, пишу

startx
выскакивает только курсор мыши. С ядром 2.6.32-5-686 -аналогично (хотя до установки нового ядра все работало). В чем причина и как это исправить?


если это имеет значение, то подключал репозитории и делал upgrade когда был на ядре 2.6.32-5-686

moriz ()
Ответ на: комментарий от AITap

gdm не запускается? - да

А он установлен? - работал

/etc/init.d/gdm* restart что скажет? - gdm3 ничего не выдал

все что связанно с Xorg (Xorg.0.log Xorg.0.log.odl) то файлы нулевого размера

moriz ()
Ответ на: комментарий от moriz

А он установлен? - работал

А сейчас установлен? dpkg -l gdm*

/etc/init.d/gdm* restart что скажет? - gdm3 ничего не выдал

Вообще ничего не напечатал?

Покажите /var/log/{dpkg,apt*}.log.

AITap ★★★★★ ()
Ответ на: комментарий от AITap

А сейчас установлен? dpkg -l gdm*

rc  gdm3                                 2.30.5-6squeeze4               i386         Next generation GNOME Display Manager

Могу ошибиться, но rc не означает ли что gdm3 удален и остались конфиги?

moriz ()
Ответ на: комментарий от moriz

Именно, gdm3 удалён. А логи APT и dpkg могут помочь понять, почему, и какие части GNOME ещё установлены в системе.

весь вывод кидать?

Да, на pastebin. Достаточно первого несжатого файла, а *.1.log, *.2.log.gz и т.п. уже старые и описывают более ранние действия с пакетами.

AITap ★★★★★ ()
Ответ на: комментарий от moriz

если это имеет значение, то подключал репозитории и делал upgrade когда был на ядре 2.6.32-5-686

Сам чуть не попал, после релиза - проверь настройки, возможно у тебя testing по-умолчанию стоит.

ziemin ★★ ()
Ответ на: комментарий от ziemin

вот мой sources.list с которого обновлялся

# 

# deb cdrom:[Debian GNU/Linux 6.0.7 _Squeeze_ - Official i386 CD Binary-1 20130223-13:15]/ squeeze main

#deb cdrom:[Debian GNU/Linux 6.0.7 _Squeeze_ - Official i386 CD Binary-1 20130223-13:15]/ squeeze main

# Line commented out by installer because it failed to verify:
#deb http://security.debian.org/ squeeze/updates main
deb http://ftp.by.debian.org/debian/ stable main non-free contrib
deb http://ftp.by.debian.org/debian-security squeeze/updates main non-free contrib
deb http://ftp.by.debian.org/debian-backports squeeze-backports main contrib
# Line commented out by installer because it failed to verify:
#deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
# deb http://ftp.debian.org/debian/ squeeze-updates main
# deb-src http://ftp.debian.org/debian/ squeeze-updates main

moriz ()
Ответ на: комментарий от moriz

Я не про sources, а про текущую версию (которую apt считает текущей). В смысле у меня была «testing», так что после релиза мне предложили обновить пакетики вроде libreoffice :)

Файл: /etc/apt/apt.conf.d/00local Строка: APT::Default-Release «wheezy»;

(было teting)

ziemin ★★ ()
Ответ на: комментарий от moriz

что то нет там такого файла /etc/apt/apt.conf.d/00local

А файл типа /etc/apt/apt.conf?

ziemin ★★ ()
Ответ на: комментарий от moriz

Remove: gnome-power-manager:i386 (2.32.0-2), gedit:i386 (2.30.4-1squeeze1), python-gtksourceview2:i386 (2.10.1-1), gnome-control-center:i386 (2.30.1-2), python-apt:i386 (0.7.100.1+squeeze1), libpanel-applet2-0:i386 (2.30.2-2), libpolkit-gtk-1-0:i386 (0.96-3), gnome-about:i386 (2.30.2-2), gdm3:i386 (2.30.5-6squeeze4), gnome-core:i386 (2.30+7), gnome-applets:i386 (2.30.0-3), gnome-panel:i386 (2.30.2-2), apt-listchanges:i386 (2.85.11), gnome-session:i386 (2.30.2-3), python-gobject:i386 (2.21.4+is.2.21.3-1), libmetacity-private0:i386 (2.30.1-3)
End-Date: 2013-05-05 21:31:02

Вот и ответ. Надо было смотреть, что удаляете. Ставьте теперь метапакет gnome, он подтянет всё, что нужно.

AITap ★★★★★ ()
Ответ на: комментарий от AITap

конкретно не писал удалить gnome. Видно с зависимостями подтянулся.

Надо было смотреть, что удаляете

Теперь буду смотреть. Спасибо

moriz ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.