LINUX.ORG.RU

Нужна помощь ... perl-dbd-mysql


0

0

Доброго времени суток. Помогите советом. (В Линуксе я полный 0, так что не обессудьте).

Стоит. Linux 2.4.18-5asp (Где диск, самому богу известно.) Скачал Linux ASP 9.2 кажысь посвежее чем стоит. взял рпм-ку, пытаюсь поставить... # rpm -ivh perl-dbd-mysql-2.9002-1.i386.rpm error: failed dependencies: libc.so.6(GLIBC_2.3) is needed by perl-DBD-MySQL-2.9002-1 libmysqlclient.so.10 is needed by perl-DBD-MySQL-2.9002-1

# locate libc.so /usr/lib/libc.so /var/ftp/lib/libc.so.6 /lib/i686/libc.so.6 /lib/libc.so.6

# locate libmysqlclient /usr/local/mysql/lib/mysql/libmysqlclient.so.12.0.0 /usr/local/mysql/lib/mysql/libmysqlclient.so.12 /usr/local/mysql/lib/mysql/libmysqlclient.so /usr/local/mysql/lib/mysql/libmysqlclient.la /usr/local/mysql/lib/mysql/libmysqlclient.a

типа более свежая версия стоит? на сколько я понимаю, libmysqlclient находится в libdbi-dbd-mysql-0.6.5-7.i386.rpm ? посмотрел в rpm -qa, ничего похожего нема...

Подскажите какую версию ставить perl-dbd-mysql, или как выкрутится ?

Re: Нужна помощь ... perl-dbd-mysql

Если у тебя все devel либы стоят просто скачать модуль с CPAN и поставить вручную.

roller ★★★ ()

Re: Нужна помощь ... perl-dbd-mysql

>посмотрел в rpm -qa, ничего похожего нема...

А что же ты хотел, если у теюя mysql нуками поставлен :)

В общем - организована помойка.

выхода - два. Либо полностью обновить дистр(чревато), либо установить руками соответствующий модуль с CPAN(как советовал предыдущий оратор)

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.