LINUX.ORG.RU

Ответ на: комментарий от riki

Если бы он не сделал sudo, то получил бы «You need to be root to perform this command». yum в /usr/bin лежит.

kernelpanic ★★★★★ ()
Ответ на: комментарий от riki

rpm -i 'http://mirror.yandex.ru/centos/5.8/os/i386/CentOS/yum-3.2.22-39.el5.centos.no...

warning: /var/tmp/rpm-xfer.D4e14J: Header V3 DSA signature: NOKEY, key ID e8562897 error: Failed dependencies: python-elementtree is needed by yum-3.2.22-39.el5.centos.noarch python-iniparse is needed by yum-3.2.22-39.el5.centos.noarch python-sqlite is needed by yum-3.2.22-39.el5.centos.noarch rpm-python is needed by yum-3.2.22-39.el5.centos.noarch urlgrabber >= 3.1.0 is needed by yum-3.2.22-39.el5.centos.noarch yum-fastestmirror is needed by yum-3.2.22-39.el5.centos.noarch yum-metadata-parser >= 1.1.0 is needed by yum-3.2.22-39.el5.centos.noarch

jei ()
Ответ на: комментарий от jei

Скачивайте все, что просят в отдельный каталог, а потом делайте там

rpm -Uvh *.rpm

только стоит скачивать rpm от centos 5.7, а то есть шанс обноить всю систему вручную

anonymous ()
Ответ на: комментарий от anonymous

установил следующие пакеты в cd /usr/local/src/yum

+ python-elementtree is needed by yum-3.2.22-39.el5.centos.noarch + python-iniparse is needed by yum-3.2.22-39.el5.centos.noarch + python-sqlite is needed by yum-3.2.22-39.el5.centos.noarch - rpm-python is needed by yum-3.2.22-39.el5.centos.noarch - urlgrabber >= 3.1.0 is needed by yum-3.2.22-39.el5.centos.noarch - yum-fastestmirror is needed by yum-3.2.22-39.el5.centos.noarch + yum-metadata-parser >= 1.1.0 is needed by yum-3.2.22-39.el5.centos.noarc

при попытке установить rpm -Uhv rpm-python-4.4.2.3-27.el5.x86_64.rpm выходит следующие

warning: rpm-python-4.4.2.3-27.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID e8562897 error: Failed dependencies: popt = 1.10.2.3-27.el5 is needed by rpm-python-4.4.2.3-27.el5.x86_64 rpm = 4.4.2.3-27.el5 is needed by rpm-python-4.4.2.3-27.el5.x86_64 rpm-libs = 4.4.2.3-27.el5 is needed by rpm-python-4.4.2.3-27.el5.x86_64

перевёл дословно,понимаю что ему что то не хватает но вопрос что.

jei ()
Ответ на: комментарий от jei

1. НЕ БЕРИТЕ пакеты от новых версий centos, ваши пакеты лежат здесь - http://vault.centos.org/5.7/os/x86_64/CentOS/, обновления здесь - http://vault.centos.org/5.7/updates/x86_64/RPMS/

2. все от centos5.8, что установили - снесите

3. Вам нужны как минимум следующие пакеты (версии, ясное дело, другие)

python.i686 2.7.3-7.2.fc17
pygpgme.i686 0.2-2.fc17
python-iniparse.noarch 0.4-6.fc17
python-urlgrabber.noarch 3.9.1-16.fc17
rpm-python.i686 4.9.1.3-7.fc17
yum-metadata-parser.i686 1.1.4-6.fc17

Все остальное, что от вас требует rpm уже установлено

4. после скачивания этих пакетов в каталоге с ними выполняем

rpm -Uvh *.prm

Все ошибки сюда, оформив их тегом [pre]

anonymous ()
Ответ на: комментарий от jei

1. sudo в centos не используется. Кроме того команды [sudo] нет, есть sudo. Так что от root набираем

rpm -e python-elementtree
Обратите внимание, rpm для удаление требуется название пакета (можно с версией и архитектурой: python-elementtree-1.2.6-5 или python-elementtree-1.2.6-5.x86_64), а не имя файла, как у вас

anonymous ()
Ответ на: комментарий от jei

Х*й занимаетесь - у вас какой-то в ср*ку поломанный дистрибутив, вы ничерта в Линуксе не шарите, google'ить не умеете, английский не знаете.

На хрена вы этим занялись?

И перестаньте слушать дебилов с их sudo - это фишка из Ubuntu, в RH дистрах просто `su -` и вперёд.

juk4windows ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.