LINUX.ORG.RU

Gentoo: не работает интернет, не компилируется ядро.

 , , ,


0

1

Доброго времени суток.

Собственно после очередного обновления, возникло ряд проблем в работе с Gentoo.

1. не компилируется часть модулей fglrx*

2. не работает интернет ( ppp / wvidlal )

конфиг ядрра [ .config] ( x86_64 / 3.6.6 ):

# http://pastebin.com/tx5fbLxv

вывод при выполнении $ make modules_install:


WARNING: /lib/modules/3.6.6-gentoo/video/fglrx.ko needs unknown symbol __list_add
WARNING: /lib/modules/3.6.6-gentoo/video/fglrx.ko needs unknown symbol list_del
WARNING: /lib/modules/3.6.6-gentoo/video/fglrx.ko needs unknown symbol amd_iommu_bind_pasid
WARNING: /lib/modules/3.6.6-gentoo/video/fglrx.ko needs unknown symbol pv_irq_ops
WARNING: /lib/modules/3.6.6-gentoo/video/fglrx.ko needs unknown symbol amd_iommu_set_invalid_ppr_cb
WARNING: /lib/modules/3.6.6-gentoo/video/fglrx.ko needs unknown symbol __stack_chk_fail
WARNING: /lib/modules/3.6.6-gentoo/video/fglrx.ko needs unknown symbol amd_iommu_set_invalidate_ctx_cb
WARNING: /lib/modules/3.6.6-gentoo/video/fglrx.ko needs unknown symbol mcount
WARNING: /lib/modules/3.6.6-gentoo/video/fglrx.ko needs unknown symbol pv_cpu_ops
WARNING: /lib/modules/3.6.6-gentoo/video/fglrx.ko needs unknown symbol amd_iommu_unbind_pasid
WARNING: /lib/modules/3.6.6-gentoo/video/fglrx.ko needs unknown symbol amd_iommu_init_device
WARNING: /lib/modules/3.6.6-gentoo/video/fglrx.ko needs unknown symbol amd_iommu_free_device
WARNING: /lib/modules/3.6.6-gentoo/video/fglrx.ko needs unknown symbol pv_mmu_ops

# по вебу даже не знаю что показать, буквально до обновления все работало. В качестве вебки ppp + wvdial + usb_modeswitch. Само собой, после обновления делал dispatch-conf , revdep-rebuild и etc-update. =)

Спасибо!

В заголовке

не компилируется ядро

Логи? Ошибки? И может в этом причина след. вопроса?

1. не компилируется часть модулей fglrx*

Логи? Версии? Пробовал cd /usr/src/linux; make mrproper и внимательно сделать все по вике… ? Да и WARNING это вовсе не «не компилируется».

не работает интернет

Логи?

init_6 ★★★★★
()
Последнее исправление: init_6 (всего исправлений: 1)
Ответ на: комментарий от init_6

..

Да и WARNING это вовсе не «не компилируется».

возможно. Но дальше встает на одном месте, а ядро то с модулями мне нужны. =)))

cd /usr/src/linux; make mrproper

спасибо. =\ теперь это:

make: *** Нет правила для сборки цели `include/config/auto.conf', требуемой для `include/config/kernel.release'. Останов.

Логи?

скажите пожалуйста какие мне логи показать именно. =)

bluehat
() автор топика
Ответ на: .. от bluehat

make: *** Нет правила для сборки цели `include/config/auto.conf', требуемой для `include/config/kernel.release'. Останов.

а ЧОРТ, мне заново конфиг подбирать теперь нужно.

bluehat
() автор топика
Ответ на: комментарий от bluehat

достань из работающего ядра
если ты не криворучка, то лежит в /proc/config.gz

megabaks ★★★★
()
Ответ на: .. от bluehat

возможно. Но дальше встает на одном месте, а ядро то с модулями мне нужны. =)))

Потому я и спрашивал логи. Без них отвечать не на что.

скажите пожалуйста какие мне логи показать именно. =)

… в любом случае emerge --info

1. не компилируется часть модулей fglrx*

Не только кусок с WARNING… а желательно все

2. не работает интернет ( ppp / wvidlal )

из консольки ручками пустил wvdial… дальше если сам не понял забил ерундой свои пароли и выхлоп вместе с файлами настроек…

а без этого мне libastral.so подсказывает для тебя ответ «42»

init_6 ★★★★★
()
Ответ на: комментарий от init_6

традиционный ответ для генты, это
revdep-rebuild
при необходимости повторить данное заклинание =)

Atlant ★★★★★
()

по поводу ядра - ты его криво собрал, поздравляю. Доставай конфиг, делай mrproper и собирай заново. Проблема с fglrx скорее всего тоже из-за этого. Но вообще, логов просто море, да....

Pinkbyte ★★★★★
()

При установке у меня не было wvdial, воспользовался pon/poff, скрипты перенабрал отсюда. Но вот проблема: после запуска chroot там интернет не работал. А в stage3 не было pon/poff. Поэтому я скачивал все файлы вне chroot, набирая ссылку вручную. А потом мне сказали что нужно было просто создать файл /mnt/gentoo/etc/resolv.conf с адресом DNS-сервера.

По ядру никак не могу помошь. Создавай баг в багзилле.

ZenitharChampion ★★★★★
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.