LINUX.ORG.RU

Кириллические символы в консоли

 


1

1

Как в Арче сделать, что-бы в консоли отображались русские символы?

Раньше всё работало, но вот сейчас заменил инитскрипты на СистемД.

Написал в /etc/vconsole.conf:

KEYMAP=ru-utf8
FONT=ter-v12n

Шрифты ставятся, а символы кириллические не отображаются и раскладки русской нет. Может кто стыкался с такой проблемой.

И да, система у меня не локализированная и делать этого я не хочу.

Речь идёт именно об tty консоли?

$ cat /etc/vconsole.conf 
KEYMAP="ruwin_ct_sh-UTF-8"
FONT="cyr-sun16"
Хотя, кое-где был нужен
unicode_start

Hokum_new ()
Ответ на: комментарий от Hokum_new

Русские символы перестали отображаться что в tty, что в обычном эмуляторе терминала. А ещё Вим ругается:

E474: Invalid argument: listchars=eol:¬,tab:>-,nbsp:�~F~T,trail:·

sphericalhorse ★★★★★ ()
#!/bin/sh
for i in {1..12}  
  do  
  	setfont ter-v12n  -C /dev/tty$i 
	kbd_mode -u -C /dev/tty$i 
  done 
loadkeys -q windowkeys -u ru
kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)

Эти кретины не могут ко второй звезде научится зайти на арчвики, епть...

anonymous ()

У меня вот так:

# cat /etc/vconsole.conf 
KEYP="ruwin_cplk-UTF-8"
FONT="ruscii_8x16"
FONT_MAP="ruwin_cplk-UTF-8"
Все отображается, раскладка переключается по Caps Lock.

Deleted ()
Ответ на: комментарий от Deleted

А учитывая, что у меня в конфиге KEYMAP внезапно написан с опечаткой, теперь он вообще не нужен и все делается через FONT_MAP.

Deleted ()
Ответ на: комментарий от kostik87

Покажите лучше вывод:

locale

Сейчас в locale.conf прописал:

$ cat /etc/locale.conf 
LANG=en_US.utf8

locale, соответственно, выводит:

LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=

Ещё vconsole.conf:

KEYMAP="ruwin_cplk-UTF-8"
FONT="ter-v12n"
FONT_MAP="ruwin_cplk-UTF-8"

Консоль подружилась с кириллицей.

В результате всех этих манипуляций в Гноме пропала переключалка раскладки, и при попытке её настроить, падает gnome-control-center.

Вы выполняли?

echo "en_US.UTF-8" > /etc/locale.gen
locale-gen

Да. Вот так у меня:

$ cat /etc/locale.gen  | sed -e /#/d
en_US.UTF-8 UTF-8  
en_US ISO-8859-1  
ru_RU.UTF-8 UTF-8  
ru_RU ISO-8859-5  
uk_UA.UTF-8 UTF-8

sphericalhorse ★★★★★ ()
Ответ на: комментарий от sphericalhorse

А гном какой версии? Там сейчас всё очень сложно с раскладками стало, и с наутилусом тоже...

Hokum_new ()

Только недавно такая тема была, где я срал кирпичами на арчеразработчиков, которые ложили большой болт на своих пользователей.

Настройку локали из rc.conf убрали, поэтому надо ее пихать в /etc/locale.conf и /etc/vconsole.conf.

У меня они такие:

cat /etc/locale.conf 
LOCALE="ru_RU.koi8-r"
LANG="ru_RU.koi8-r"
LC_NUMERIC=C

cat /etc/vconsole.conf 
KEYMAP="ruwin_alt-KOI8-R"
FONT="ter-k16n"
CONSOLETRANSLATION="koi2alt"
CONSOLEMAP="koi8-r_to_uni"
FONT_MAP="koi8-r_to_uni"
Но на «всякий пожарный» я еще и в ~/.bashrc держу
if [ "$DISPLAY" = "" ]; then
	mapscrn koi2alt
	loadkeys ruwin_alt-KOI8-R
	setfont Cyr_a8x16
fi

Блин, только сейчас заметил, что по CAPS раскладка в консоли не переключается.

Eddy_Em ☆☆☆☆☆ ()
Последнее исправление: Eddy_Em (всего исправлений: 1)
Ответ на: комментарий от sphericalhorse

А переключалку раскладки в иксах я настроил так:

cat /etc/X11/xinit/fixkeyboard
#!/bin/sh
sleep 1
export DISPLAY=:0.0
export XAUTHORITY=/home/eddy/.Xauthority
setxkbmap 'us,ru' -option 'grp:ctrl_shift_toggle,grp_led:scroll,compose:menu'
xmodmap -e "keycode 10 = 0x31 exclam"
xmodmap -e "keycode 49 = grave asciitilde apostrophe asciitilde"
/usr/lib/udev/keymap input/event2 /usr/lib/udev/keymaps/microsoft-ergonomic-keyboard
Запускается этот скрипт из xinit.

Можно просто зафутболить

setxkbmap 'us,ru' -option 'grp:ctrl_shift_toggle,grp_led:scroll,compose:menu'
себе в ~/.bashrc

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от X10Dead

Ничуть. У меня везде КОИ8. На кой хрен мне сдался ваш юникод? Я кроме русского и английского языков не знаю.

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от anonymous

Кретины — как раз те, кто этот арчевики пишет (точнее, кто ломает арч). Было все уютно и, главное, работало! Нет, приперся какой-то козлина, и все сломал, говнюк! А потом для отмазки в арчевики написал, как побить в бубен, чтобы вернуть систему в рабочее состояние...

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от Eddy_Em

Блин, либо я инвалид, либо Гном. Писал настройки раскладки в /etc/X11/xinit/xinitrc, в /etc/X11/xorg.conf.d/00-keyboard.conf, в bashrc, и ничего не работает. По ходу, Гном, когда запускается, устанавливает свои правила. Прописал через gnome-session-properties и заработало.

Вот, собсноговоря:

setxkbmap 'us,ua' -option 'grp:caps_toggle,grp_led:caps,compose:lwin'

Да, а как правильно прописать xmodmap дабы при Compose + S писалась Ы?

sphericalhorse ★★★★★ ()
Ответ на: комментарий от Eddy_Em

Оно не знает, кто такой Multi_key.

$ xmodmap -e 'keysym <Multi_key> <s> = ы Ы'
xmodmap:  commandline:1:  bad keysym target key symbol '<Multi_key>'
xmodmap:  1 error encountered, aborting.
Как правильно ему это объяснить с учетом compose:lwin?

sphericalhorse ★★★★★ ()
Последнее исправление: sphericalhorse (всего исправлений: 4)
Ответ на: комментарий от sphericalhorse

Тьфу ты, я это для ~/.XCompose написал.

А xmodmap'у надо без угловых скобок

Eddy_Em ☆☆☆☆☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.