LINUX.ORG.RU

Помогите настроить Samba

 , ,


0

1

Собственно такая ситуация: купил диск Seagate там стоит самба со следующим конфигом. При заходе на диск спрашивает пароль и после авторизации, можно лазить по всем папкам. Это то что есть на данный момент.

А хочется: 1) При заходе на диск пароль не спрашивался вообще а показывал все папки 2) При заходе в папку Personal спрашивал пароль, если пароль неверен, то не пускал 3) При заходе в папку Public не спрашивал пароль и собственно заходил

Много чего пробовал приводить код не буду, но в результате как надо не работает помогите пожалуйста

# This file was generated from a template. To make local modifications, # copy the template from /etc/oe-admin/templates/system to # /etc/oe-admin/templates/local , modify it, # then make some change on the Windows Networking page.

[global]

netbios name = motoroller workgroup = HOME server string = GoFlex Home

security = user encrypt passwords = yes smb passwd file = /etc/samba/smbpasswd use sendfile = yes

guest account = lp

printcap name = cups load printers = yes printing = cups

socket options = TCP_NODELAY SO_RCVBUF=65536 SO_SNDBUF=65536 dns proxy = no

browseable = yes map to guest = never

domain master = no local master = yes preferred master = yes os level = 2 unix charset = UTF8 unix extensions = no mangled names = no veto files = /.swapfile/.tmp/.users/.timemachine/ delete veto files = yes

# We need this here to prevent errors from appearing in WinXP # https://listman.redhat.com/archives/redhat-list/2003-January/msg00939.html use client driver = yes

log level = 0

[GoFlex Home Public] comment = GoFlex Home (GoFlex Home Public) path=/home/%U/GoFlex Home Public browseable = yes writeable = yes guest ok = no #guest only = no #public = yes create mode = 0664 directory mode = 0775 force create mode = 0664 force directory mode = 0775 force security mode = 0775 force directory security mode = 0775 force group = users valid users = %U

[GoFlex Home Personal] comment = GoFlex Home (GoFlex Home Personal) path=/home/%U/GoFlex Home Personal browseable = yes writeable = yes guest ok = no #guest only = no #public = yes create mode = 0664 directory mode = 0775 force create mode = 0664 force directory mode = 0775 force security mode = 0775 force directory security mode = 0775 force group = users valid users = %U

Читать простыню влом, вот тебе рабочий конфиг:

[global]
        dos charset = CP866
        unix charset = KOI8-R
        server string = Storage
        security = SHARE
        log file = /var/log/samba/log.%m
        max log size = 50
        unix extensions = No
        dns proxy = No
        idmap config * : range =
        idmap config * : backend = tdb
        wide links = Yes

[Storage]
        path = /storage/0/
        guest ok = Yes

[Torrents]
        path = /storage/0/torrents/
        read only = No
        guest ok = Yes

Ресурс storage для чтения всем, ресурс torrents для записи всем. Fat32, Samba 3.6, FreeBSD 9.0-p4. Будут вопросы, - спрашивай.

IPR ★★★★★ ()
Ответ на: комментарий от Deleted

Пускай курит ман и дорабатывает.

А вообще, ТС, man swat. Это веб-интерфейс для конфига самбы.

IPR ★★★★★ ()
Ответ на: комментарий от IPR

Попробовал

Я честно не гуру в этих делах просто обыватель, пользователь диска Seagate. Так что не судите строго.

Сдеал как вы сказали. Результат: на дик захожу без проблем. В папку public не могу попасть - пишет не найден сетевой путь В папку Personal тоже, пишет что не верное имя пользователя или пароль (хотя ввожу все корректно)

motoroller ()
Ответ на: комментарий от IPR

Что еще попробовал ...


[global]

netbios name = seagate
workgroup = HOME
server string = GoFlex Home

security = user # сделал это
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
use sendfile = yes

map to guest = Bad Password # сделал это
guest account = nobody # сделал это
 

при доступе к Public гвоорит что сетеовй путь не найден При доступе к Personal? если пароль неверен, ругается на пароль, tсли пароль верен. что сетевой путь не найден, не могу это победить ((

motoroller ()
Ответ на: Что еще попробовал ... от motoroller

0) man testparm (на предмет testparm -v |less)
1) пользователи в /etc/samba/smbpasswd есть?

Deleted ()
Ответ на: комментарий от IPR

KOI8-R стал фактически стандартом для русской кириллицы в 1990-х годах...

kerneliq ★★★★★ ()
Ответ на: комментарий от IPR

вот что получилось ... привожу не весь конфиг а то что относится к делу


[global]

netbios name = seagate
workgroup = home
server string = GoFlex Home

security = user

encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
use sendfile = yes

guest account = nobody # сделал это

printcap name = cups 
load printers = yes
printing = cups 

socket options = TCP_NODELAY SO_RCVBUF=65536 SO_SNDBUF=65536
dns proxy = no 

browseable = yes
map to guest = Bad Password # сделал это


# ничего не делал и так все отлично работает

[GoFlex Home Personal]
comment = GoFlex Home (GoFlex Home Personal)
browseable = yes
writable = yes
valid users = %U
create mode = 0664
directory mode = 0775
force create mode = 0664
force directory mode = 0775
force security mode = 0775
force directory security mode = 0775
force group = users
path = /home/%U/GoFlex Home Personal
guest ok = no

[GoFlex Home Public]
comment = GoFlex Home (GoFlex Home Public)
path=/home/motoroller/GoFlex Home Public
browseable = yes
writeable = yes
guest ok = yes # сделал это
public = yes # сделал это
create mode = 0664
directory mode = 0775
force create mode = 0664
force directory mode = 0775
force security mode = 0775
force directory security mode = 0775

Какой у меня результат на данный момент 1) В корень пускает отлично т.е вопрос решен 2) В папку Personal пускает по паролю, что тоже отлично т.е вопрос решен 3) В папку public не пускает говорит что путь неверен, но странная ситация после захода в папку Personal (т.е.) после авторизации пускает в папку Public

motoroller ()
Ответ на: комментарий от motoroller

возможно дело в правах на папку?? пытался меня но после перезагрузки ус-ва права становятся по умолчанию

Возможно, попробуй повторить ситуацию, но сначала (перед тем как входить) выставь права на директорию chmod 0777

IPR ★★★★★ ()
Ответ на: комментарий от IPR

дейсивтельно если выставляю права на папку GoFlex Home Public - 0777, то все ок, но после перезагрузки права становятся 0775 как это можно решить хотя в самбе у меня стоит 0777

[GoFlex Home Public]
comment = GoFlex Home (GoFlex Home Public)
path = /home/%U/GoFlex Home Public
browseable = yes
writeable = yes
guest ok = yes
public = yes
create mode = 0777
directory mode = 0777
force create mode = 0777
force directory mode = 0777
force security mode = 0777
force directory security mode = 0777
motoroller ()
Ответ на: комментарий от motoroller

Так, я не знаю как в linuxe, но во freebsd есть файлик /etc/rc.local, в него можно записывать команды, которые ты хочешь чтобы выполнялись при загрузке. Можно прописать что-то типа:

[ -d /path/to/dir ] && chmod 0777 /path/to/dir

Как временное решение пойдёт.

И дай uname -a и ls /etc

IPR ★★★★★ ()
Ответ на: комментарий от motoroller

Стоп!

Пробелы надо экранировать, либо брать в кавычки.

[ -d "/home/motoroller/GoFlex Home Public" ] && chmod 0777 "/home/motoroller/GoFlex Home Public"

Пробуй.

IPR ★★★★★ ()
Ответ на: комментарий от motoroller

И вообще, возьми за правило брать пути в кавычки.

IPR ★★★★★ ()
Ответ на: комментарий от motoroller

прописал в фале

[ -d "/home/motoroller/GoFlex Home Public" ] && chmod 0777 "/home/motoroller/GoFlex Home Public"
motoroller -a и ls /etc

не помогает((( права на папку все ранво 0775

motoroller ()
Ответ на: комментарий от motoroller

motoroller -a и ls /etc

Это чё за херня? :)

Набери эту строку в консоли и посмотри изменятся ли права^

[ -d "/home/motoroller/GoFlex Home Public" ] && chmod 0777 "/home/motoroller/GoFlex Home Public"

Набери:

uname -a

и скопируй вывод сюда.

IPR ★★★★★ ()
Ответ на: комментарий от motoroller

Решил так: force user = motoroller

Отлично, рад за тебя ;)

IPR ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.