LINUX.ORG.RU

Как облегчить gnome?

 ,


0

1

Когда-то установил гнома через метапакет gnome (вроде так). Так вот. Зачастую мой комп тратит время на компиляцию (при обновлении) не нужных мне прог. Например epiphany, evolution, yelp и еще нескольких прог. Посоветуйте, как лучше это осуществить не нарушая зависимостей метапакета. Может, переписать ебилд? Или лучше сделать это по-другому?


Снести метапакет, нужные пакеты занести в world, emerge -av --depclean

tis ★★ ()

установил гнома через метапакет

буратина, чо

минимальный гном, без yelp'ов и прочих xulruner'ов с всяким шлаком типа epiphany, емержится, как уже неоднократно было подсказано здесь, следующими пакетами:

metacity gnome-settings-daemon gnome-control-center nautilus gnome-desktop gnome-session gnome-panel gnome-icon-theme gnome-themes gnome-terminal

разумеется разрули флагами, чтобы ничего лишнего не подтянулось из мусора

science ★★☆ ()
Ответ на: комментарий от partyzan

Стой. Гном хорошая штука. Мне не нравится набор программ. В следующий раз читай пост и не отписывайся для кол-ва постов

nic11 ()
Ответ на: комментарий от science

Это не минимальный: gnome-control-center nautilus gnome-desktop gnome-icon-theme - лишнее.

anonymous ()

Ставь гном так:

emerge -va metacity gnome-settings-daemon gnome-control-center nautilus gnome-desktop gnome-session gnome-panel gnome-icon-theme gnome-themes gnome-terminal
Всегда ставил гном в Генте так - необходимый и вполне достаточный минимум (речь о втором гноме, конечно же) =]

neocrust ★★★★★ ()

Просто добавь их в package.provided. С какими-то пакетами это не прокатит, но с этими - точно сработает(версии указаны из-за синтаксиса самого файла):

x11-terms/gnome-terminal-3.4.1.1
x11-libs/vte-0.32.1
x11-libs/gnome-pty-helper-0.32.0
media-video/totem-3.2.2
net-im/empathy-3.2.2
app-editors/gedit-3.4.1
gnome-extra/gnome-contacts-3.2.2
gnome-extra/yelp-3.2.1
app-text/yelp-tools-3.2.1
gnome-extra/gnome-user-docs-3.4.1
app-dicts/gnome-dictionary-3.4.0
Lighting ★★★★★ ()
Ответ на: комментарий от science

О да, помойка в world - это гораздо лучше.

Ты хоть в следующий раз в хэндбук загляни, прежде чем такое советовать(если что, там прямым текстом написано, что в world не следует добавлять пакеты, которые напрямую не нужны пользователю, а просто являются зависимостями или системными пакетами).

Lighting ★★★★★ ()
Ответ на: комментарий от Lighting

Ух ты, спасибо. Однажды прочитал про provided, но сейчас совсем забыл. Вот это - точно то, что надо =)

ЗЫ. А если там указываются версии, портежи разве не могут поставить другую версию? *пошел курить маны*

nic11 ()
Ответ на: комментарий от nic11

ЗЫ. А если там указываются версии, портежи разве не могут поставить другую версию? *пошел курить маны*

Ну так и указывай последнюю доступную. Если что, предназначение этого файла - предоставить пользователю возможность самому собирать выбранные пакеты, но чтобы они оставались в базе портейджа.

Lighting ★★★★★ ()
Ответ на: комментарий от Lighting

О да, помойка в world - это гораздо лучше.

Не вижу смысла не заносить пакет в world, если он мне действительно нужен.

Deleted ()
Ответ на: комментарий от Deleted

Ты хоть в следующий раз в хэндбук загляни, прежде чем такое советовать(если что, там прямым текстом написано, что в world не следует добавлять пакеты, которые напрямую не нужны пользователю, а просто являются зависимостями или системными пакетами).

А теперь топай читать man'ы и хэндбук.

Lighting ★★★★★ ()
Ответ на: комментарий от Deleted

Если этот пакет тянется зависимостью, то зачем его заносить в world?! Чтобы потом превратить систему в помойку?!

daemonpnz ★★★★★ ()
Ответ на: комментарий от Lighting

Но товарищ science указывал на то, что эти метапакеты тянут ненужное, таким образом, он предложил поставить гном без них. Ещё раз: метапакетов гнома в системе нет и не надо, а для пакетов, которые нужны, есть /var/lib/portage/world.

Deleted ()
Ответ на: комментарий от Lighting

Ты упоролся — тянуть метапакетом зависимости, а потом заносить их в provided; всё правильно говорят, наутилус с гномпанелью прописать в world.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.