LINUX.ORG.RU

Проблемы с ati и xorg

 , ,


0

2

Видеокарта ATI Mobility Radeon HD 3470.
Дистр slackware-current
kernel-3.0.21
mesa-8.0.3
Драйвера были из xf86-video-radeonhd-1.3.0, но после обновления до xorg-server-1.12.1. Иксы перестали работать должным образом, KDE не возможно загрузить.

xorg.conf
/var/log/Xorg.0.old
Интересный кусок в логе

(EE) module ABI major version (8) doesn't match the server's version (12)
(II) UnloadModule: "radeonhd"
(II) Unloading radeonhd
(EE) Failed to load module "radeonhd" (module requirement mismatch, 0)
(EE) No drivers available.

Попробовал поставить драйвера xf86-video-ati-6.14.4. Результат изменился, но KDE по прежнему не загружается.
Лог немного изменился. /var/log/Xorg.0.old

(EE) AIGLX error: r600 does not export required DRI extension
(EE) AIGLX: reverting to software rendering


Firmware накати к последнему и заведется).

Xe0N ()

В первом случае попытка загрузить иксы со старым модулем.

Во втором случае не заводится ускорение и падают иксы. Я никогда не использовал radeonhd, поэтому не очень понимаю из-за падают в данном случае иксы. Наверное его просто не допилили под новые иксы.
Попробуй с драйвером radeon, он должен с новой версией иксов нормально работать.

Radius ★★★★ ()
Ответ на: комментарий от Radius

Так во втором случае я использую не radeonhd, а ati.
Если в xorg.conf прописать вместо ati, radeon. То результат не меняется.
А xf86-video-ati-6.14.4 это последняя версия.

ozs ()
Ответ на: комментарий от ozs

Пардон, не так понял. Ну ati и radeon это один и тот же драйвер. У меня на самом деле есть похожая проблема с psb_gfx, но иксы не падают, только не заводится AIGLX. Пока решил откатом на старые иксы.

Radius ★★★★ ()
Ответ на: комментарий от leave

Его забросили еще два года тому назад, но у меня карточка старая поэтому я и продолжал им пользоваться, пока всё работало.

А теперь, он с новыми иксами не дружит. Но вот почему не хочет работать xf86-video-ati-6.14.4 ?

ozs ()
Ответ на: комментарий от ozs

Удалите xorg.conf вообще. И, если firmware не установлена, то установите, как сказал тов. Xe0N.

carasin ★★★★★ ()

radeonhd

Как там оно в криокамере?

anonymous ()
Ответ на: комментарий от PrikPavel

плюсую, к сожалению. только с ним заводилась атишка.

Komintern ★★★★★ ()

radeonhd умер, в Slackware нет зависимостей, поэтому при использовании Current надо внимательно читать Changelog и смотреть на Added и Removed. Конкретно в этом случае, я на 90% уверен, что драйверу нужен KMS.

Deleted ()

кстати fglrx не работает что ли с 1.12 ксоргом?

Radius ★★★★ ()
Ответ на: комментарий от Sonsee

На самом деле никакой разницы в данном случае, только 1.11 удалили совсем из репов, поэтому поставил 1.10.

Кстати вопрос на засыпку, если вчера допустим был 1.11 в тестинге, а сегодня его заменили на 1.12, то где мне можно найти этот 1.11 если он даже в кэше не остался? Просто некоторые проприетарные поделки строго привязаны к определенной версии иксов, а из сорцов ой как неохота собирать, учитывая что он только вчера готовый в репах лежал. Может быть где-то складируются промежуточные версии, только гугл секрета не хочет выдавать?

Radius ★★★★ ()
Ответ на: комментарий от Deleted

radeonhd до поры до времени нормально работал. А теперь когда он отказался работать пришлось перейти на xf86-video-ati-6.14.4.

я на 90% уверен, что драйверу нужен KMS

Можно поподробнее

ozs ()
Ответ на: комментарий от ozs

Пересобери radeonhd, если устраивает. Слакваревый бинарь собран под старые иксы, о чём они тебе и говорят.

Можно поподробнее

Kernel Mode Settings.

Deleted ()
Ответ на: комментарий от Deleted

Так и сделал. Проблема решилась.

Но в логах так и осталось, но зато иксы не падают.

(EE) AIGLX error: r600 does not export required DRI extension

(EE) AIGLX: reverting to software rendering

ozs ()
Ответ на: комментарий от ozs

А раньше со старыми иксами такого не было? И какие щас иксы?

Radius ★★★★ ()
Ответ на: комментарий от ozs

Я не совсем в курсе нюансов, но может надо установить мезу более старую? У тебя наверное последняя версия, а старый драйвер наверняка требует старую мезу.

Radius ★★★★ ()
Ответ на: комментарий от ozs

3D-ускорения нет, отрисовка кое-где медленная будет. Добей всё же ati, включи KMS.

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.