LINUX.ORG.RU

[gentoo] [ati] зависание иксов


0

1

Зависание после старта иксов. Система не реагирует ни на какие сочетания клавиш.

#> cat /var/log/Xorg.0.log
http://pastebin.com/pZzEDvNT

#> cat /etc/X11/xorg.conf
http://pastebin.com/U3PX1ZuH

#> eix -I x11-drivers/*ati
[U] x11-drivers/xf86-video-ati
     Available versions:  6.13.2 6.14.0 6.14.1 6.14.2 6.14.3
     Installed versions:  6.14.0(06:32:25 PM 01/19/2012)
     Homepage:            http://xorg.freedesktop.org/
     Description:         ATI video driver

C 6.14.3 то же самое.

Все ж написано в логах:

[   106.917] (II) [KMS] drm report modesetting isn't supported.
Как ядро компелял? В консоли фреймбуфер работает?

morse ★★★★★ ()

Add radeon.modeset=1 to the kernel options in the bootloader configuration file to enable KMS.

tiandrey ★★★★★ ()

Система не реагирует ни на какие сочетания клавиш.

Даже на это: Alt+SySRQ+R ?

После нажатия данного сочетания можно перейти в в консоль, нажав Ctrl+Alt+F1.

nihil ★★★★★ ()
Ответ на: комментарий от garmonbozia

Вы уверены, что это зависание иксов? Я думаю, что вам нужно пересобрать пакеты с драйверами устройств ввода.

# emerge -av1 xf86-input-keyboard xf86-input-mouse xf86-input-evdev

Скорее всего проблема в том, что вы обновляли (пересобирали) xorg-server, после чего обязательна пересборка драйверов устройств ввода под текущую версию xorg-server`а.

Так же покажите ваш xorg.conf и лог xorg-server`а.

Неплохо было бы увидеть список установленных драйверов для видео и используемую реализацию opengl.

# emerge gentoolkit wgetpaste
# eix -I xorg-drivers --only-names
# eselect opengl list
# wgetpaste /var/log/X.org.0.log

И конфигурацию ядра:

cat /usr/src/linux/.config | grep -i "drm\|radeon\|kms" | grep -v "#"

И установлен ли пакет radeon-ucode или linux-firmware.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87
#> eix -I xorg-drivers --only-names
x11-base/xorg-drivers
#> eselect opengl list
Available OpenGL implementations: [1] xorg-x11 *
 #> wgetpaste /var/log/Xorg.0.log
Your paste can be seen here: http://paste.pocoo.org/show/538633/ 
 #> cat /usr/src/linux/.config | grep -i "drm\|radeon\|kms" | grep -v "#"
CONFIG_DRM=m
CONFIG_DRM_KMS_HELPER=m 
CONFIG_DRM_TTM=m 
CONFIG_DRM_TDFX=m 
CONFIG_DRM_R128=m 
CONFIG_DRM_RADEON=m 
CONFIG_DRM_I810=m 
CONFIG_DRM_I830=m 
CONFIG_DRM_I915=m 
CONFIG_DRM_MGA=m 
CONFIG_DRM_SIS=m 
CONFIG_DRM_VIA=m 
CONFIG_DRM_SAVAGE=m 
 #> eix radeon-ucode -c
[I] x11-drivers/radeon-ucode (20110531@01/22/2012): IRQ microcode for r6xx/r7xx/Evergreen/Northern Islands Radeon GPUs and APUs 
garmonbozia ()
Ответ на: комментарий от garmonbozia

kostik87

eix -I xorg-drivers --only-names

Неправильно написал, нужно так:

eix -I x11-drivers/ --only-names
Смущает эта строка:

(II) [KMS] drm report modesetting isn't supported.

Включите опцию 'CONFIG_DRM_RADEON_KMS=y'.

Покажите 'lsmod'.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87
#> eix -I x11-drivers/ --only-names
x11-drivers/radeon-ucode
x11-drivers/xf86-input-evdev
x11-drivers/xf86-input-keyboard
x11-drivers/xf86-input-mouse
x11-drivers/xf86-video-ati
x11-drivers/xf86-video-fbdev
x11-drivers/xf86-video-glint
x11-drivers/xf86-video-intel
x11-drivers/xf86-video-mach64
x11-drivers/xf86-video-mga
x11-drivers/xf86-video-neomagic
x11-drivers/xf86-video-nv
x11-drivers/xf86-video-openchrome
x11-drivers/xf86-video-r128
x11-drivers/xf86-video-savage
x11-drivers/xf86-video-sis
x11-drivers/xf86-video-tdfx
x11-drivers/xf86-video-trident
x11-drivers/xf86-video-vesa
x11-drivers/xf86-video-vmware

Опцию поправил, с генкернелем проблема

* Running with options: all

* ERROR: Kernel Makefile (/usr/src/linux/Makefile) missing.  Maybe re-install the kernel sources.

#> uname -r
2.6.38-gentoo-r2

Теперь ставить свежее ядро (=gentoo-sources-?), скармливать ему /usr/scr/linux/.config и запускать genkernel all?

#> lsmod | wgetpaste
Your paste can be seen here: http://paste.pocoo.org/show/538642/
garmonbozia ()
Ответ на: комментарий от garmonbozia

Странно, у вас нет загруженных модулей 'drm' и 'radeon', у вас видимо их xorg-server подгружает, но он у вас не запускается.

Не знаю, что вы сделали с исходниками ядра, но придётся переставлять.

cp /usr/src/linux/.config /usr/src/config_bac
emerge gentoo-sources
eseelct kernel list
eselect kernel set <номер из вывода выше>
cp /usr/src/config_bac /usr/src/linux/.config
genkernel all

Хотя у вас конфиг должен быть и в самом ядре:

zcat /proc/config.gz > /usr/src/linux/.config

#> uname -r
2.6.38-gentoo-r2

Почему ядро такое старое ? Если давно не делали emerge --sync пока не делайте, а то всю систему придется потом обновлять.

Не забудьте затем в загрузчике указать ваше новое ядро.

Почему не читаете официальную документацию по настройке ?

Там всё расписано, какие опции нужно включить в ядре и какие пакеты поставить.

http://www.gentoo.org/doc/en/xorg-config.xml

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87
cp /usr/src/config_bac /usr/src/linux/.config
genkernel all

Так не пойдёт, будет использоваться конфиг genkernel`а по-умолчанию.

По привычке написал, забыл тонкости genkernel`а, сам предпочитаю его не использовать, а собирать ядро вручную.

Либо так:

cp /usr/src/config_bac /usr/src/linux/.config
cd /usr/src/linux
make bzImage
make modules
mount /boot
make install
make modules_install

Либо так:

mkdir /etc/kernels/
cp /usr/src/config_bac /etc/kernels/kernel-config-x86-2.6.38-gentoo-r2

2.6.38-gentoo-r2 замените на версию исходников ядра.

genkernel all

kostik87 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.