LINUX.ORG.RU

#error «Only <glib.h> can be included directly.»

 ,


0

1
/bin/sh ../libtool --tag=CXX   --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include      -O2 -g0 -pipe -Wall -c -o bitlog.lo bitlog.cc
libtool: compile:  x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -O2 -g0 -pipe -Wall -c bitlog.cc  -fPIC -DPIC -o .libs/bitlog.o
In file included from /usr/lib64/glib-2.0/include/glibconfig.h:9:0,
                 from bitlog.h:28,
                 from bitlog.cc:21:
/usr/include/glib-2.0/glib/gmacros.h:32:2: ошибка: #error "Only <glib.h> can be included directly."
make[3]: *** [bitlog.lo] Ошибка 1

В чем проблема? Как это побороть?

★★★★★

Ответ на: комментарий от deterok

Эту и все остальные, где подобное встречается.

Это счастье в новой glib2 приплыло. Раньше было ворнингом, теперь стало ошибкой.

geekless ★★ ()
Ответ на: комментарий от geekless

Эх, может комит накидаешь на http://gpsim.sourceforge.net?
Ну или хотя бы ткни, что почитать для добавки своего комита на sourceforge, будет мой первый коминт в чужом свободном проекте(и вообще в свободном):)

deterok ★★★★★ ()
Ответ на: комментарий от deterok

Сливаешь сорцы из их svn (ну или что там у них), правишь код, создаешь на сайте багрепорт в описанием проблемы, приаттачиваешь к нему вывод svn diff (т.е. твой патч).

geekless ★★ ()

в сорцах где найдется посыл <glib/blablabla.h> нужно заменить на <glib.h> , в любом случае лечится достаточно просто...

Gramozeka ★★ ()
Ответ на: комментарий от Gramozeka

Без флага gtk собралось, но хотелось бы заиметь gui, при этом, во время конфигурации, выбивает

ecking popt.h usability... yes
checking popt.h presence... yes
checking for popt.h... yes
checking for pkg-config... /usr/bin/pkg-config
configure: error: Cannot find gtkextra-2.0 package

deterok ★★★★★ ()
Ответ на: комментарий от Gramozeka

да есть она, но 3.* и в моей соседней теме человек утверждает, что у него все отлично работает. Предполагаю, что надо конфиг мейка откорректировать еще.

deterok ★★★★★ ()
Ответ на: комментарий от deterok

вот этот баг (с чего начался топик) почитай, там приатачен fix для него, попробуй может и поможет. У мну гента ещё на 2.6.37 ведре и не обновлялась почти с год, а поднимать её до актуальной версии мне (некогда\лень), поэтому проверить не могу. На Слаке то не глядя взлетела, но там другой подход.

Gramozeka ★★ ()

подписался. при сборке гнумерика и абиворда та же фигня.

devl547 ★★★★★ ()
Ответ на: комментарий от Gramozeka

Пока личный костыль сварганил для gpsim-0.26.1/configure

$PKGCONFIG --exists gtkextra-3.0
  if test $? != 0; then
    as_fn_error $? "Cannot find gtkextra-2.0 package" "$LINENO" 5
  fi

  X_LDFLAGS=`$PKGCONFIG --libs gtk+-2.0 gthread-2.0`
  X_CFLAGS=`$PKGCONFIG --cflags gtk+-2.0`
  Y_LDFLAGS=`$PKGCONFIG --libs gtkextra-3.0`
  Y_CFLAGS=`$PKGCONFIG --cflags gtkextra-3.0`
  GTK_VERSION_T=`$PKGCONFIG --modversion gtk+-2.0`
  echo linking with gtk-$GTK_VERSION_T

deterok ★★★★★ ()
Ответ на: комментарий от deterok

ну не знаю, костыли дело такое... сугубо интимное. Сейчас проверил - из установленного :

glib-1.2.10

glib2-2.28.6

glibc-2.15

gtk+-1.2.10

gtk+2-2.24.4

затребовал он ещё gtkextra-2 , поставил ему gtkextra-2.1.2 и собрался влёт...

тыц - по ссылке жуткое ШГ под компизом..

Gramozeka ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.