LINUX.ORG.RU

Debian Sid. Терминал ослеп.


0

1

Поставил дистрибутив из нестабильной ветки. Во время загрузки, темнеет экран и пропадают сообщения о запуске сервисов. Как следствие приглашение залогинится тоже не видно. Приходится вслепую. Потом startx.

Ответ на: комментарий от lazyklimm

видюха/драйверы какие?

intel

Кстати, о иксах. Хотел, как обычно, поставить их минималку.

xserver-xorg-video-intel
xinit
x11-utils
Он мне лишнее подтянул - libradeon1, xterm... Еще что-то. В сиде с зависимостями нормально?

killpid ()
Ответ на: комментарий от killpid

В сиде с зависимостями нормально?

apt-config dump | grep -i install

покажи

Install-Recommends и Install-Suggests я предпочитаю отрубать к черту

lazyklimm ★★★★★ ()
Ответ на: комментарий от killpid

судя по apt-cache depends никаких жестких зависимостей на libradeon1 нет

lazyklimm ★★★★★ ()
Ответ на: комментарий от killpid

APT::Install-Recommends «1»;

ну вот тебе и причина мусора

пропиши в /etc/apt/apt.conf.d/80install (например) строчку:

APT::Install-Recommends "0";

и опционально эти

APT::Get::AutomaticRemove "0";
Debug::pkgAutoRemove "0";

потом можешь снести libradeon и прочий хлам

lazyklimm ★★★★★ ()
Ответ на: комментарий от killpid

тут почитай, кажись похожий симптом

http://wiki.debian.org/KernelModesetting#Intel_GfxCards

In my system (HP/Compaq nx7300 with 945GM) enabling of KMS when loading the i915 module caused blank screen (seems not to be related to incorrect mode, rather the system got suspended or hibernated) when booting the system. Problem could be cured by changing of /etc/modprobe.d/i915-kms.conf to options i915 modeset=0. What's interesting, booting with acpi=off also cured the problem. The same problem occured in a desktop system with 82865G

lazyklimm ★★★★★ ()
Ответ на: комментарий от killpid

но он у тебя и отключен. Отключи рекомендуемые зависимости, они в 90% не нужны, а в оставшихся 10 можно поставить самому - apt о них в любом случае упомянет

lazyklimm ★★★★★ ()
Ответ на: комментарий от killpid

Удаление libdrm-radeon1 тянет libgl1-mesa-dri.

не верю

apt-cache depends libdrm-radeon1
libdrm-radeon1
  Зависит: libc6
  Зависит: libdrm2
  ПредЗависит: multiarch-support
lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm
~> r libdrm-radeon1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libdrm-radeon1 libgl1-mesa-dri
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
After this operation, 91.3 MB disk space will be freed.
Do you want to continue [Y/n]?
killpid ()
Ответ на: комментарий от killpid

попробуй удалить, а потом поставить libgl1-mesa-dri отдельно

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm
~> apt-cache depends libgl1-mesa-dri
libgl1-mesa-dri
  Depends: libc6
  Depends: libdrm-intel1
  Depends: libdrm-nouveau1a
  Depends: libdrm-radeon1
  Depends: libdrm2
  Depends: libexpat1
  Depends: libffi5
  Depends: libgcc1
  Depends: libstdc++6
  Suggests: libglide3
  Conflicts: <xlibmesa-dri>
  Breaks: libgl1-mesa-dri-experimental
  Breaks: libgl1-mesa-glx
  Breaks: <libgl1-mesa-glx-no-multiarch>
  Breaks: xserver-xorg-core
  Breaks: <xserver-xorg-core-no-multiarch>
  Replaces: libgl1-mesa-dri-experimental
  Replaces: <xlibmesa-dri>
killpid ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.