LINUX.ORG.RU

Alsa загружен, но звук не работает


0

1

Долгое время пользовался OSS, но с ним постоянно наблюдались небольшие щелчки в колонках. Однако после последнего обновления на oss 4.2 build 2005 данная проблема обострилась до громких щелчков и даже попискивания. Сегодня решил попробовать alsa. Скачал исходники, скомпилировал, установил. Всё прошло гладко: всё работает, кроме звука :)

regy@G713:~$ uname -r
3.0.0-12-generic

regy@G713:~$ lspci|grep Audio
00:07.0 Audio device: nVidia Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)
02:00.1 Audio device: nVidia Corporation Device 0e0c (rev a1)

regy@G713:~$ lsmod|grep snd
snd_hda_codec_hdmi	 31426  4 
snd_hda_codec_via	  61329  1 
snd_hda_intel		  24262  11 
snd_hda_codec		  91754  3 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_intel
snd_hwdep			  13276  1 snd_hda_codec
snd_pcm				80468  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq_midi		   13132  0 
snd_rawmidi			25241  1 snd_seq_midi
snd_seq_midi_event	 14475  1 snd_seq_midi
snd_seq				51567  2 snd_seq_midi,snd_seq_midi_event
snd_timer			  28932  2 snd_pcm,snd_seq
snd_seq_device		 14172  3 snd_seq_midi,snd_rawmidi,snd_seq
snd					55902  32 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore			  12600  1 snd
snd_page_alloc		 14115  2 snd_hda_intel,snd_pcm

regy@G713:/media/data5/dd$ aplay -vv aaa.wav

Plug PCM: Rate conversion PCM (48000, sformat=S32_LE)
Converter: libspeex (builtin)
Protocol version: 10002
Its setup is:
  stream	   : PLAYBACK
  access	   : RW_INTERLEAVED
  format	   : S16_LE
  subformat	: STD
  channels	 : 2
  rate		 : 44100
  exact rate   : 44100 (44100/1)
  msbits	   : 16
  buffer_size  : 15052
  period_size  : 940
  period_time  : 21333
  tstamp_mode  : NONE
  period_step  : 1
  avail_min	: 940
  period_event : 0
  start_threshold  : 15052
  stop_threshold   : 15052
  silence_threshold: 0
  silence_size : 0
  boundary	 : 986447872
Slave: Soft volume PCM
Control: PCM Playback Volume
min_dB: -51
max_dB: 0
resolution: 256
Its setup is:
  stream	   : PLAYBACK
  access	   : MMAP_INTERLEAVED
  format	   : S32_LE
  subformat	: STD
  channels	 : 2
  rate		 : 48000
  exact rate   : 48000 (48000/1)
  msbits	   : 32
  buffer_size  : 16384
  period_size  : 1024
  period_time  : 21333
  tstamp_mode  : NONE
  period_step  : 1
  avail_min	: 1024
  period_event : 0
  start_threshold  : 16384
  stop_threshold   : 16384
  silence_threshold: 0
  silence_size : 0
  boundary	 : 1073741824
Slave: Direct Stream Mixing PCM
Its setup is:
  stream	   : PLAYBACK
  access	   : MMAP_INTERLEAVED
  format	   : S32_LE
  subformat	: STD
  channels	 : 2
  rate		 : 48000
  exact rate   : 48000 (48000/1)
  msbits	   : 32
  buffer_size  : 16384
  period_size  : 1024
  period_time  : 21333
  tstamp_mode  : NONE
  period_step  : 1
  avail_min	: 1024
  period_event : 0
  start_threshold  : 16384
  stop_threshold   : 16384
  silence_threshold: 0
  silence_size : 0
  boundary	 : 1073741824
Hardware PCM card 0 'HDA NVidia' device 0 subdevice 0
Its setup is:
  stream	   : PLAYBACK
  access	   : MMAP_INTERLEAVED
  format	   : S32_LE
  subformat	: STD
  channels	 : 2
  rate		 : 48000
  exact rate   : 48000 (48000/1)
  msbits	   : 32
  buffer_size  : 16384
  period_size  : 1024
  period_time  : 21333
  tstamp_mode  : ENABLE
  period_step  : 1
  avail_min	: 1024
  period_event : 0
  start_threshold  : 1
  stop_threshold   : 1073741824
  silence_threshold: 0
  silence_size : 1073741824
  boundary	 : 1073741824
  appl_ptr	 : 0
  hw_ptr	   : 0

regy@G713:~$ alsactl init
Found hardware: "HDA-Intel" "VIA VT1708S" "HDA:11060397,18490397,00100000" "0x1849" "0x0397"
Hardware is initialized using a generic method

В alsamixer всё установлено на максимум и mute везде снят. система xubuntu 11.10 У кого-нибудь имеются идеи, как отремонтировать звук? P.S. возвращение на oss или перекомпиляцию ядра не предлагать. Эти варианты для меня не подходят по ряду причин.


> Скачал исходники, скомпилировал, установил

система xubuntu 11.10

да ну?

TheAnonymous ★★★★★ ()
Ответ на: комментарий от Axon

Axon, из исходников собрал: alsa-driver-1.0.24.88.gb41c8.1877.ga1e0a alsa-lib-1.0.24.1.46.g15c6f alsa-utils-1.0.24.2 Из репозитария поставил: alsa-firmware, alsa-firmware-loaders, alsa-oss, alsa-tools, alsa-tools-gui

Rejy ()

ID: 91450
Nick: Rejy

Ну точно, тролль.

//Ужу, верни аввтрку с котом!!!

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

И чтобы никто (модераторы в первую очередь) не догадался. ;)

amorpher ★★★★★ ()
Ответ на: комментарий от Rejy

Меня сейчас вообще давит вот эта тема с колонок (соседи мертвы уже(?))
In Search of Sunrise, Vol. 4

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

>>Щелчки? С alsa звука нет вообще, хотя всё плееры, включая команду aplay искренне верят в то, что всё работает. Я честно не понимаю, что вызывает твоё негодование. И как по мне, ты больше похож на тролля. И если ты не знаешь, как исправить ситуацию со звуком не засоряй тему.

Rejy ()
Ответ на: комментарий от amorpher

Я ubuntu пользуюсь начиная с версии 8.04, обновляясь по мере выхода новых версий. (xubuntu у меня сейчас, потому что gnome и unity идущие в ubuntu 11.10 настолько заточены под пальцетыки, что использовать их на обычном ПК мне показалось проблематично и я из репозитория поставил xubuntu-desktop, удалив gnome и unity) Как видишь, пользуюсь этой системой очень давно, там много разного софта, настроек и файлов, которые мне нельзя терять. Лучше уж будет тогда последовать инструкции с gentoo-wiki и монолитно втесать драйвера alsa в ядро, но всё таки без этого.

Rejy ()
Ответ на: комментарий от Rejy

>>...но всё таки без этого...

хотелось бы обойтись.

Rejy ()
Ответ на: комментарий от amorpher

Наверно ты прав - я дурак и тролль. Глупо было надеяться на чью-то реальную помощь. Спасение утопающих - дело самих утопающих) Буду перекомпилировать ядро, иного выхода похоже нет(

Rejy ()
Ответ на: комментарий от Rejy

Так я и думал, вы собрали ядерную часть в юзерспейсе. Это теоретически возможно заставить работать (вроде бы), но изо всех сил не рекомендуется девелоперами альсы и никто не гарантирует вам, что вам это удастся. Нет абсолютно никаких причин так делать, то, что должно быть в ядре, там и должно быть.
Если ваше ядро собрано без поддержки alsa, то его придётся либо пересобирать (не вижу в этом проблемы, честно говоря), либо просто заменить на стоковое дистрибутивное.
А на аморфера не обращайте внимания, он безобидный, просто наркоман. :-)

Axon ★★★★★ ()
Ответ на: комментарий от Axon

Спасибо за поддержку. Ядро пересобрал, но эффект вышел тот-же. Все приложения считают, что всё работает, но звука нет, как и не было. Про live cd я чуть чуть соврал. Под рукой не было версии 11.10 и я использовал 11.04(там практически таже версия alsa). Сейчас докачал 11.10 звука там тоже нет, симптомы теже. Проблему со звуком всё же решил. Нагуглил, что приблизительно неделю назад в mercurial появился oss 4.2 buid 2006, но на оф. ftp его ещё нет. Установил его. Всё работает. Все звуковые помехи исчезли. Последнее время кажется oss стал активно развиваться, так что останусь пока на нём:) А alsa к сожалению до сих пор сырая.

Rejy ()
Ответ на: комментарий от Rejy

alsaconf из погремушки выпилили? Если есть, то попробуй его запустить.

imul ★★★★★ ()

Мне в такой ситуации помог запуск alsaconf

bff7755a ()
Ответ на: комментарий от ZenitharChampion

Ты даже ОП-пост не чиатал; cкор набиваешь?

uzbl ()
Ответ на: комментарий от uzbl

Лолчто?

alsa-driver должен быть просто включён в ядре при компиляции. Он же скачал сырцы отдельно и установил вне ядра. Так делать можно, но не нужно.

Axon ★★★★★ ()
Ответ на: комментарий от Axon

Отдельные сорцы всё равно собираются в модули ядра. Вы не понимаете, что значит kernel-space и user-space; чтобы перенести алса в userspace её нужно полностью переписать.

uzbl ()
Ответ на: комментарий от uzbl

Я, на самом деле, не обладаю кристальным пониманием этого вопроса. Просто когда-то давно я сам сделал по незнанию как ТС, начал гуглить почему ничего не работает, и наткнулся на какие-то альсовские доки, в которых было написано, что собирать альсу вне ядра - плохая идея. Если «вне ядра» != «в юзерспейсе», то прошу прощения за некорректную формулировку, но я понял именно так.

Axon ★★★★★ ()

Попробуй отконфигурировать/создать файл ~/.asoundrc и прописать устройство, на которое необходимо выводить звук. Мне в свое время помогло.

beriya ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.