LINUX.ORG.RU

[xl2tpd][beeline]Не поднимается ppp0 - накручивает гигабайты tx bytes


1

2

В общем, такие дела. Настраиваю по этой инструкции http://www.opennet.ru/tips/2539_l2tp_vpn_debian_linux_beeline_pptp.shtml Пробовал инструкции и скрипты с форума корбины, но тоже не работает.

Пробовал xl2ptd 1.2.7 с патчами от проекта vpnpptp (там спецом для корбины поправки) и официальный 1.3.0, в который приняли некоторые патчи (вроде бы).

А результат всегда один: ifconfig показывает, что ppp0 есть, но вместо интернета накручиваются гигабайты tx bytes и отваливается локалка (не знаю, должна ли). Без запуска xl2tp все локальные ресурсы работают.

В syslog всё нормально - xl2tpd работает, авторизовался и ip-адреса получил.

Маршруты тоже подхватываются, согласно route -n.

Дописывал в xl2tpd.conf tx = 100000000 - не работает. Повторно указывал маршрут к vpn серверу после поднятия ppp0, но не помогает.

Подозреваю, что решение рядом, но ничего найти не могу.

Даже не знаю, какие логи показывать.

Он обычно добавляет роут до VPN-сервера через ppp-туннель. Этот роут неправильный, надо его убрать и добавить роут через локалку.

Adjkru ★★★★★ ()

Ну хотя бы для начала покажи выхлопы команд
ip addr
ip route
Может сюда кто забредёт у кого l2tp билайновский работает и что-нибудь посоветует.

imul ★★★★★ ()

Adjkru, не очень понял, как это сделать.

imul.

Вот маршруты до и после поднятия ppp0 До http://pastebin.com/JTrHVWYk После http://pastebin.com/AQD5PhdQ

И ещё скрипт не выполняется. Говорит, syntax error : 5 : "(" unexpected (expecting «fi» ). Может, это из-за этого маршрут сам не обновляется?

   RUN="yes"
   if [ "$RUN" = "yes" ]; then
        if [ "$new_static_routes" != "" ]; then
                if [ "$reason" = "BOUND" ] || [ "$reason" = "REBOOT" ]; then
                        my_static_routes=($new_static_routes)

                        for(( i=0; i < ${#my_static_routes[@]}; i=i+2 )); do
				/sbin/route add -host "${my_static_routes[$i]}" gw "${my_static_routes[$i+1]}"
                        done
                fi
        fi
   fi

Panic_At_The_Kernel ()

route add -host 85.21.0.103 gw 10.208.24.1 dev eth0 vpn-сервер абсолютно у Вас не маршрутизирован, поэтому и гигабайты набегает трафика. tx bps = 100000000 должно быть написано, а не tx = 100000000.

Grom ()
Ответ на: комментарий от Grom

Сейчас попробую. tx был правильно записан, я просто по памяти писал. И этот параметр сам передается в свежих версиях xl2tpd.

Panic_At_The_Kernel ()
Ответ на: комментарий от Adjkru

Просьба потестить патч, чтобы xl2tpd использовал ядерный сокет в ядрах выше 2.6.32: https://gist.github.com/1306094

У меня нагрузка на CPU снизилась с 40% до 1%

А что-нибудь нужно дополнительно настраивать в системе, кроме пересбоки xl2tpd с патчем? Или какие-то опции дополнительно указать при сборке? Пакет я собрал и поставил, но разницы не заметил в потреблении ЦП - как жрало 7-9% при скачке на 20 мегабитах, так и осталось.

Panic_At_The_Kernel ()
Ответ на: комментарий от Panic_At_The_Kernel

Спасибо за ответ.

Нет, не надо, разве что modprobe l2tp_ppp

После этого в логе должно появиться using kernel l2tp support.

Adjkru ★★★★★ ()
Ответ на: комментарий от Adjkru

Всё, работает. Надо только modprobe l2tp_ppp раньше загружать. htop вообще никакой нагрузки от xl2tpd не показывает.

Panic_At_The_Kernel ()
Ответ на: комментарий от Panic_At_The_Kernel

Написал им в багтрекер две недели назад. Пока что ничего не сказали.

Adjkru ★★★★★ ()
Ответ на: комментарий от Adjkru

спасибо за патч! сначала думал , что не заведется, так как при компиляции не нравились пару переменных в код, но в итоге все в порядке - нагрузка на Цп упала, пинги стали меньше, скорость больше - прямо , как на openl2tp .

magnitto ()
Ответ на: комментарий от magnitto

openl2tp заметно менее крив кстати, по исходникам. жду версии 1.9, в которой наконец-то обещали добавить ppp options как альтернативу циско-подобным настройках, среди которых почему-то нет usepeerdns.

Adjkru ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.