LINUX.ORG.RU
ФорумAdmin

beeline & xl2tpd


1

1

Нужна помощь в настройке билайн интернет на openwrt. Для тех, кто не в курсе, билайн работает через VPN на L2TP без шифрования с авторизацией по CHAP. С винды все нормально работает. Через роутер как-бы тоже работает. Но билайну не нравятся какие-то опции полученного vpn соединения. Пинги не ходят, по web пускает только на некоторые страницы вроде help.internet.beeline.ru (то есть это уже значит, что vpn и маршрутизация работают, пакеты ходят), при попытке захода броузером по http на любой ip адрес получаем от билайна страницу вида :

Уважаемый абонент ! Вы подключаетесь к сети интернет с неверным типом соединения. Необходимо пересоздать VPN подключение или перенастроить роутер согласно инструкциям на сайте поддержки.

Что имеем на openwrt. openwrt работает с такого рода соединениями через xl2tpd. Так что вопрос касается настройки связки beeline + linux + xl2tpd, неважно openwrt или нет. Для чистоты эксперимента настраиваю xl2tpd вручную без использования механизмов управления интерфейсами openwrt.

xl2tpd.conf :

[global]
port = 1701
auth file = /etc/xl2tpd/xl2tp-secrets
access control = no

[lac corbina] (вместо corbina можно всё, что угодно)
lns = 83.102.254.215
;lns = tp.internet.beeline.ru
redial = yes
redial timeout = 15
require chap = yes
require authentication = no
name = <my_username>
ppp debug = yes
pppoptfile = /etc/ppp/options.xl2tpd.corbina
require pap = no
autodial = yes

options.xl2tpd.corbina

name <my_username>
remotename l2tp
ipparam corbina
ifname 'l2tp-bee'
connect /bin/true
logfile /var/log/xl2tpd.corbina.log
nodeflate
nobsdcomp
persist
maxfail 0
nopcomp
noaccomp
defaultroute

В chap-secrets прописаны l/p

Судя по логам все абсолютно нормально. Фактически VPN работает без проблем.

xl2tpd.corbina.log

Plugin pppol2tp.so loaded.
using channel 2
Using interface l2tp-bee
Connect: l2tp-bee <--> 
PPPoL2TP options: debugmask 0
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x3ff20660>]
rcvd [LCP ConfReq id=0x1 <mru 1460> <asyncmap 0xa0000> <auth chap MD5> <magic 0x1e3037aa> <pcomp> <accomp>]
sent [LCP ConfAck id=0x1 <mru 1460> <asyncmap 0xa0000> <auth chap MD5> <magic 0x1e3037aa> <pcomp> <accomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x3ff20660>]
PPPoL2TP options: debugmask 0
sent [LCP EchoReq id=0x0 magic=0x3ff20660]
rcvd [CHAP Challenge id=0x1 <c22349f68bb5a460bb6acf6190b961a1>, name = "bras41.spb"]
sent [CHAP Response id=0x1 <c4e12ae730511b620bd26bc5f99e4d8c>, name = "0896320007"]
rcvd [CHAP Success id=0x1 ""]
CHAP authentication succeeded
CHAP authentication succeeded
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0>]
rcvd [IPCP ConfReq id=0x1 <addr 83.102.254.215>]
sent [IPCP ConfAck id=0x1 <addr 83.102.254.215>]
rcvd [IPCP ConfNak id=0x1 <addr 37.145.55.122>]
sent [IPCP ConfReq id=0x2 <addr 37.145.55.122>]
rcvd [IPCP ConfAck id=0x2 <addr 37.145.55.122>]
local  IP address 37.145.55.122
remote IP address 83.102.254.215
Terminating on signal 15
Connect time 5.6 minutes.
Sent 16820 bytes, received 244806 bytes.
PPPoL2TP options: debugmask 0
sent [LCP TermReq id=0x2 "User request"]
sent [LCP TermReq id=0x3 "User request"]
Connection terminated.
Modem hangup

Я сделал для сравнения cap дампы процесса установления соединения у microsoft и с xl2tpd, но не могу разобрать что там не так. Никаких принципиальных отличий не вижу. Просто билайн что-то такое хитрое требует, а я не знаю что.

Отвечаю сам себе. Эта недостающая закорючка называется tx bps=100000000 По умолчанию в это поле вставляется 0, что не нравится билайну.

Если использовать механизмы openwrt, то нет способа прописать эту опцию в конфиг, потому что lac-блоки создаются динамически.

Смотрим файл /lib/netifd/proto/l2tp.sh и видим :

 xl2tpd-control add l2tp-${config} pppoptfile=${optfile} lns=${server} redial=yes redial timeout=20
 xl2tpd-control connect l2tp-${config}

Придется дописывать опцию прямо в скрипт :

 xl2tpd-control add l2tp-${config} pppoptfile=${optfile} lns=${server} redial=yes redial timeout=20 "tx bps=100000000"
 xl2tpd-control connect l2tp-${config}

как бы после этого заводится

bolvan ()
Ответ на: комментарий от bolvan

Спасибо, что поделились, о наимудрейший!
Драгоценного времени немного больше стало... :)

MaksVal ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.