LINUX.ORG.RU

АrchLinux не поднимается интерфейс ppp0.


0

1

Запускаю vpnclient — sudo pon us
после этого:

ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 00:00:21:5c:0b:22 brd ff:ff:ff:ff:ff:ff
    inet 10.1.70.141/24 brd 10.1.70.255 scope global eth0
20552: ppp0: <POINTOPOINT,MULTICAST,NOARP> mtu 1500 qdisc noop state DOWN qlen 3
    link/ppp 

ls /sys/class/net/
eth0  lo  ppp0 

также
sudo ip link set ppp0 up 

и тем не менее:
sudo pppd call us dump debug hide-password nodetach
pppd options in effect:
debug debug		# (from command line)
nodetach		# (from command line)
persist		# (from /etc/ppp/peers/us)
maxfail 0		# (from /etc/ppp/peers/us)
dump		# (from command line)
noauth		# (from /etc/ppp/peers/us)
refuse-pap		# (from /etc/ppp/peers/us)
name free		# (from /etc/ppp/peers/us)
password ??????		# (from /etc/ppp/peers/us)
remotename PPTP		# (from /etc/ppp/peers/us)
		# (from /etc/ppp/options)
pty pptp xxx.com --nobuffer --nolaunchpppd --debug		# (from /etc/ppp/peers/us)
nocrtscts		# (from /etc/ppp/peers/us)
		# (from /etc/ppp/options)
noaccomp		# (from /etc/ppp/peers/us)
asyncmap 0		# (from /etc/ppp/options)
nopcomp		# (from /etc/ppp/peers/us)
lcp-echo-failure 4		# (from /etc/ppp/options)
lcp-echo-interval 30		# (from /etc/ppp/options)
hide-password		# (from command line)
novj		# (from /etc/ppp/peers/us)
novjccomp		# (from /etc/ppp/peers/us)
defaultroute		# (from /etc/ppp/peers/us)
		# (from /etc/ppp/options)
noproxyarp		# (from /etc/ppp/peers/us)
usepeerdns		# (from /etc/ppp/peers/us)
nobsdcomp		# (from /etc/ppp/peers/us)
nodeflate		# (from /etc/ppp/peers/us)
require-mppe-128		# (from /etc/ppp/peers/us)
noipx		# (from /etc/ppp/options)
using channel 21890
Using interface ppp1
Connect: ppp1 <--> /dev/pts/3
anon warn[open_inetsock:pptp_callmgr.c:329]: connect: Connection refused
anon fatal[callmgr_main:pptp_callmgr.c:127]: Could not open control connection to ххх.ххх.ххх.103
anon fatal[open_callmgr:pptp.c:479]: Call manager exited with error 256
Script pptp xxx.com --nobuffer --nolaunchpppd --debug finished (pid 32703), status = 0x1
Modem hangup
Connection terminated.
using channel 21892
Using interface ppp1
Connect: ppp1 <--> /dev/pts/3
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x4d09b4e2>]
anon warn[open_inetsock:pptp_callmgr.c:329]: connect: Connection refused
anon fatal[callmgr_main:pptp_callmgr.c:127]: Could not open control connection to ххх.ххх.ххх.103
anon fatal[open_callmgr:pptp.c:479]: Call manager exited with error 256
Modem hangup
Connection terminated.

Поиск по ошибке, никчему толком не привёл. Маршруты соответственно прописать не могу. В какую сторону копать?

★★★★★

Ответ на: комментарий от baverman

>Что здесь не ясно?

И как с этим бороться? Сервер по ip адресу и порту пингуется. Все настройки firewall'a у меня сброшены. Компьютер с win ХP в этой же сети коннектится без проблем.

kitar ★★★★★ ()
Ответ на: >Что здесь не ясно? от kitar

Хочу например добавить маршрут через ppp0, и получаю:

 SIOCADDRT: Network is down
как и показывает в строке с ip a:
20552: ppp0: <POINTOPOINT,MULTICAST,NOARP> mtu 1500 qdisc noop state DOWN qlen 3
link/ppp

kitar ★★★★★ ()
Ответ на: комментарий от neocrust

1 пункт - вместо myhost вписать имя хоста. Спорный пункт, но попробуй.

neocrust ★★★★★ ()
Ответ на: комментарий от baverman

>Скорее всего проблема в разных настройках шифрования.

Пытаюсь в третий раз сказать, о том, что не поднимается интерфейс ppp0. Настройки шифрования брал и с винды в том числе.

kitar ★★★★★ ()
Ответ на: комментарий от neocrust

Доберусь до компьютера с Арчиком, попробую разве что закоментировать default gw в /etc/rc.conf, хотя сомневаюсь. По одной из ссылок упоминается dhcp dhcpcd для vpn, я не ставил, попробую, хотя опять же в винде dhcp enabled — no, как-то так по памяти.

kitar ★★★★★ ()
Ответ на: комментарий от kitar

У меня такой /etc/ppp/peers/vpn-server

pty «pptp vpn-server --nolaunchpppd» name DOMAIN\\username remotename PPTP require-mppe-128 file /etc/ppp/options.pptp ipparam vpn-server //здесь может быть другое что-то... :) persist

anonymous ()
Ответ на: комментарий от kitar

Чудеса какие-то, в ip a нет вообще такого интерфейса.

Его и не должно там быть, так как pppd его и пытается поднять, но обламывается при pptp соединении.

baverman ★★★ ()
Ответ на: комментарий от baverman

>Его и не должно там быть

Моя ошибка оказалась, выше логи — это при запущенном vpnclient'e. Просто при логировании — ppp0 отабражается правильно. Соединения всё равно нет.

kitar ★★★★★ ()
Ответ на: >Его и не должно там быть от kitar

«выдрал» из win XP:

TYPE of VPN: PPTP VPN

Server type PPP

Authentication MSCHAPV2

Encription MPPE 128

Делаю по аналогии: sudo cat /etc/ppp/peers/us

pty "pptp впн_сервер.com --nolaunchpppd --debug"
name моё_имя
password мой_пароль
remotename PPTP
require-mppe-128
require-mschap-v2
refuse-eap
refuse-pap
refuse-chap
refuse-mschap
noauth
debug
persist
maxfail 0
defaultroute
#replacedefaultroute
usepeerdns 
и sudo cat /etc/ppp/options.pptp
# Lock the port
lock

# Authentication
# We don't need the tunnel server to authenticate itself
noauth

# We won't do PAP, EAP, CHAP, or MSCHAP, but we will accept MSCHAP-V2
# (you may need to remove these refusals if the server is not using MPPE)
refuse-pap
refuse-eap
refuse-chap
refuse-mschap

# Compression
# Turn off compression protocols we know won't be used
nobsdcomp
nodeflate

# Encryption
# (There have been multiple versions of PPP with encryption support,
# choose with of the following sections you will use.  Note that MPPE
# requires the use of MSCHAP-V2 during authentication)

# http://ppp.samba.org/ the PPP project version of PPP by Paul Mackarras
# ppp-2.4.2 or later with MPPE only, kernel module ppp_mppe.o
# {{{
#Require MPPE 128-bit encryption
require-mppe-128
# }}}

# http://polbox.com/h/hs001/ fork from PPP project by Jan Dubiec
# ppp-2.4.2 or later with MPPE and MPPC, kernel module ppp_mppe_mppc.o
# {{{
# Require MPPE 128-bit encryption
mppe required,stateless
# }}}
Уже и в разных вариациах, хоть стреляй — не получается.

kitar ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.