LINUX.ORG.RU

KMS, radeon, проблемы


0

1

после установки новой HD6790 иксы перестали запускаться с ошибкой

(EE) RADEON(0): Chipset: "AMD Radeon HD 6700 Series" requires KMS
(EE) Screen(s) found, but none have a usable configuration.
при этом dmesg | grep drm даёт

[drm] Initialized drm 1.1.0 20060810
[drm] radeon kernel modesetting enabled.

с радеонами в линуксе ещё не сталкивался. в чём проблема, как фиксить?

ЗЫ смущает «20060810» - тогда ещё и в помине не было HD6790. дело в этом?

★★★★★

Проверь наличие ucode, или как он там у тебя называется в репах. Иногда запихивают в firmware.

В dmesg стоит смотреть всё, а не только |grep drm.

x3al ★★★★★ ()

ядро может старовато, не?
20060810 не страшно, на 3.1 ядре тоже самле, нужно смотреть версию drm 2.7, 2.10, 2.11 и тд

Novell-ch ★★★★★ ()

после старта kms должен быть drm 2.x

firmware есть? грузится?

madgnu ★★★★★ ()
Ответ на: комментарий от jcd

>2.6.38

Вроде NI, которые не cayman, должны работать, но я бы обновил ядро и libdrm.

madgnu ★★★★★ ()
Ответ на: комментарий от Loki13

>Модуль radeon в initrd есть?

у меня initrd в ядре

modprobe radeon что говорит


ничего не говорит, успешно. но при перезапуске иксов ничего не меняется, те же ошибки.

jcd ★★★★★ ()
Ответ на: комментарий от jcd

>ничего не говорит, успешно. но при перезапуске иксов ничего не меняется, те же ошибки.

Так а по факту KMS есть при загрузке? Может radeon.modeset=1 попробовать ядру передать?

Loki13 ★★★★★ ()
Ответ на: комментарий от Loki13

передаю, безрезультатно. KMS есть, если поставить radeon.modeset=0 - строка [drm] radeon kernel modesetting enabled пропадает.

jcd ★★★★★ ()
Ответ на: комментарий от madgnu

проблема была вообще не в линуксе :) решилась убиранием биосной галки «framebuffer location - above 4G»

jcd ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.