LINUX.ORG.RU

Arch не запускаются иксы из консоли


0

1

Установил сегодня Arch x86_x64. Поднял иксы, поставил кеды, все в порядке, очень нравится. Только заметил странную вещь. Если просто загрузиться, то сразу запускается kdm (как я и прописывал в inittab), консоль я не вижу, все работает как часы. Но если специально выйти, и в kdm выбрать «Console login», то иксы больше уже не запустить. При startx выдает следующее
/etc/X11/xinit/xinitrc: line 52: twm: command not found
/etc/X11/xinit/xinitrc: line 56: exec: xterm - command not found
/etc/X11/xinit/xinitrc: line 53 xclock: command not found
и на этом все. Драйвер nouveau, и mesa 3d. Но, повторюсь, если просто перезагрузиться, то все работает. За полчаса до этого пробовал установить на другой винт (просто познакомиться с арчем), делал все в точности то же самое, с этим же драйвером, но такой проблемы не было. Видимо, что-то все же пропустил.

★★★★★

Внезапно, а не отсутствуют ли у тебя соответственно twm, xterm и xclock? Помнится мне, xterm уж точно не обязательная зависимость для иксов.

metar ★★★ ()
Ответ на: комментарий от ArtKun

у тебя иксы пытаются голышом запуститься. А тебе надо, чтоб оно kdm запускало. Посмотри, что там у тебя в init нарисовано, чтоб иксы запускать - и дергай за него.

shutty ()
Ответ на: комментарий от ArtKun

При чем тут inittab? Покажи .xinitrc своего пользователя (ты же в консоли не из под root пытаешся Х-ы запускать?).

vadik ★★ ()
Ответ на: комментарий от ArtKun

И да, попробуй убрать kdm из него и где он у тебя там еще прописан.

damnemall ()
Ответ на: комментарий от ArtKun

> Заголовок пункта из АрчВики - «Запуск KDM через /etc/inittab [предпочтительнее]»

В роли модуля в /etc/rc.conf он тоже вел себя неплохо, не замечал абсолютно никаких проблем.

damnemall ()
Ответ на: комментарий от ArtKun

> .xinitrc у меня ОТСУТСТВУЕТ.

Так ты сделал, что я написал, или нет?

damnemall ()
Ответ на: комментарий от ArtKun

Все равно для запуска Х-ов по команде startx нужно чтобы был сконфигурирован файл ~/.xinitrc. Если в каталоге пользователя этот файл не будет найден, то Х-ы воспользуются файлом /etc/X11/xinit/xinitrc (а в нем и прописаны все те команды которые ты постчитал ошибками в стартовом сообщении).

vadik ★★ ()
Ответ на: комментарий от damnemall

Все ясно, тогда первый мне не нужен. Спасибо еще раз.

ArtKun ★★★★★ ()
Ответ на: комментарий от ArtKun

> кстати а чем он от первого отличается?
Большим количеством комментариев.

tn1 ()
Ответ на: комментарий от Ghostwolf

ЕМНИП, иксы у меня и без них запускались.

Наверное, потому что вы не запускали startx без параметров или поправили .xinitrc?

metar ★★★ ()
Ответ на: комментарий от metar

Я ничего не изменял, проверял лишь конфиг иксов после установки. Были такие же ошибки, т.к. .xinitrc дефолтный и эти пакеты не стояли, но иксы успешно стартовали.

Ghostwolf ★★★★ ()
Ответ на: комментарий от vitruss

Нет, у меня ничего не открывались терминалы, в остальном все как обычно. Собственно, в чем у автора проблема? Он же не собирается под голыми иксами работать.

Ghostwolf ★★★★ ()
Ответ на: комментарий от vitruss

Эх, проблема не решилась. Как ни крути inittab и rc.conf, кнопки выключения/перезагрузки скрыты. Не осилил различий между русским и английским АрчВики (кто-то из них точно накурился), поэтому прошу кого-нибудь с нормально рабочими кедами показать мне свой /etc/inittab и сказать, есть ли у него при этом kdm в демонах.

ArtKun ★★★★★ ()
Ответ на: комментарий от ArtKun

kdm нужно прописать либо в rc.conf чтобы он запускался как демон (арчевики не рекомендует), либо в inittab.

#
# /etc/inittab
#

#  Runlevels:
#    0    Halt
#    1(S)	Single-user
#    2    Not used
#    3    Multi-user
#    4    Not used
#    5    X11
#    6    Reboot

## Only one of the following two lines can be uncommented!
# Boot to console
#id:3:initdefault:
# Boot to X11
id:5:initdefault:

rc::sysinit:/etc/rc.sysinit
rs:S1:once:/etc/rc.single
rm:2345:once:/etc/rc.multi
rh:06:once:/etc/rc.shutdown
su:S:wait:/sbin/sulogin -p

# -8 options fixes umlauts problem on login
c1:2345:respawn:/sbin/agetty -8 -s 38400 tty1 linux
c2:2345:respawn:/sbin/agetty -8 -s 38400 tty2 linux
#c3:2345:respawn:/sbin/agetty -8 -s 38400 tty3 linux
#c4:2345:respawn:/sbin/agetty -8 -s 38400 tty4 linux
#c5:2345:respawn:/sbin/agetty -8 -s 38400 tty5 linux
#c6:2345:respawn:/sbin/agetty -8 -s 38400 tty6 linux

# Serial Virtual Console for KVM and others VMs
#s0:2345:respawn:/sbin/agetty -8 -s 9600 ttyS0 linux

# Hypervisor Virtual Console for Xen and KVM
#h0:2345:respawn:/sbin/agetty -8 -s 38400 hvc0 linux

ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# Example lines for starting a login manager
#x:5:respawn:/usr/bin/xdm -nodaemon
#x:5:respawn:/usr/sbin/gdm -nodaemon
x:45:respawn:/usr/bin/kdm -nodaemon
#x:5:respawn:/usr/bin/slim >/dev/null 2>&1
#x:45:respawn:/bin/su crow -l -c "ck-launch-session /bin/bash --login -c xinit>/dev/null 2>&1"
#x:5:respawn:exec ck-launch-session /bin/bash -login ~/.xinitrc
#x:5:respawn:/usr/sbin/lxdm >& /dev/null
# End of file

Crow ()
Ответ на: комментарий от ArtKun

кеды запускаешь через kdm или в консоли startx? если запускать из kdm, то все долдно работать. попробуй перезагрузить с помощью горячих клавиш. по дефолту перезагрузка без запроса в кедах: ctrl + alt + shift + del

Crow ()
Ответ на: комментарий от Crow

KDM сам загружается после перезагрузки - так и запускаю. Или, снова копать в сторону xinitrc?

ArtKun ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.