LINUX.ORG.RU

Не работает интернет через pppoe


0

1

Провайдер предоставляет инет через pppoe.
В винде работает, в линуксе (debian sid) все настроил, пытаюсь запустить.
Добавляется новый интерфейс ppp0, выдается айпишник.
Пингую dns - пингуется, еще некоторые локальные адреса тоже пингуются.
Ничего из инета не пингуется, remote IP тоже не пингуется.


# cat /var/log/syslog | grep ppp
Aug 21 21:43:47 debian pppd[28952]: Plugin rp-pppoe.so loaded.
Aug 21 21:43:47 debian pppd[28953]: pppd 2.4.5 started by root, uid 0
Aug 21 21:43:47 debian pppd[28953]: PPP session is 272
Aug 21 21:43:47 debian pppd[28953]: Connected to 00:25:ba:4d:c1:1e
via interface eth0
Aug 21 21:43:47 debian pppd[28953]: Using interface ppp0
Aug 21 21:43:47 debian pppd[28953]: Connect: ppp0 <--> eth0
Aug 21 21:43:48 debian pppd[28953]: CHAP authentication succeeded: CHAP authentication success
Aug 21 21:43:48 debian pppd[28953]: CHAP authentication succeeded
Aug 21 21:43:48 debian pppd[28953]: peer from calling number 00:25:BA:4D:C1:1E authorized
Aug 21 21:43:48 debian pppd[28953]: local IP address 172.16.6.235
Aug 21 21:43:48 debian pppd[28953]: remote IP address 109.195.34.1
Aug 21 21:43:48 debian pppd[28953]: primary DNS address 109.195.33.1
Aug 21 21:43:48 debian pppd[28953]: secondary DNS address 109.195.32.1


# ifconfig
eth0 Link encap:Ethernet HWaddr c8:0a:a9:7e:75:31
inet6 addr: fe80::ca0a:a9ff:fe7e:7531/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:70540 errors:0 dropped:0 overruns:0 frame:0
TX packets:96662 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:14914119 (14.2 MiB) TX bytes:12082170 (11.5 MiB)
Interrupt:41 Base address:0xa000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:6048970 errors:0 dropped:0 overruns:0 frame:0
TX packets:6048970 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:177593270 (169.3 MiB) TX bytes:177593270 (169.3 MiB)

ppp0 Link encap:Point-to-Point Protocol
inet addr:172.16.6.235 P-t-P:109.195.34.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:576 Metric:1
RX packets:2400 errors:0 dropped:0 overruns:0 frame:0
TX packets:4936 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:377120 (368.2 KiB) TX bytes:787377 (768.9 KiB)

wlan0 Link encap:Ethernet HWaddr f0:7b:cb:95:4a:70
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0 ppp0
109.195.34.1 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0


# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


172.16.6.235

пинг не показатель. Ты за NAT'ом провайдера, он может запросто резать ICMP.

/etc/resolv.conf покажи ещё.

И да, странички в браузере открываются-то или нет?

adriano32 ★★★ ()
Ответ на: комментарий от adriano32

Блин, вот я идиот. Не догадался браузер открыть.
Похоже провайдер-гад по маку фильтрует.
Спасибо за помощь :)

silav ()
Ответ на: комментарий от silav

Похоже провайдер-гад по маку фильтрует.

Что за бред по поводу мака? Провайдер твой — отсталое унылое говно: он держит всех клиентов во внутренней локальной сети, выдавая так называемые «серые» адреса, не даёт он вам прямых адресов в интернет, а собственно доступ предоставляет через свой NAT, который в добавок режет пинг пакеты и как ты вскоре узнаешь что-нибудь ещё.

Проверить можешь зайдя на cmyip.com или 2ip.ru или просмотрев дополнительную информацию в GMail —> адрес который ты увидишь не совпадёт с 172.16.6.235.

adriano32 ★★★ ()

Создай файл /etc/resolv.conf с таким содержимым:

nameserver 8.8.8.8
nameserver 8.8.4.4

Топорно, но работает.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от adriano32

В браузере все отправляются на страницу провайдера, где он ругается на «несоответствие оборудования» или что-то типа того. У меня просто винда на компе стоит и там все работает, а линукс на ноуте. Подсмотрел мак на компе, установил его на ноуте, и все заработало. Это сообщение пишу уже из линукса.
Всем спасибо еще раз!

silav ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.