LINUX.ORG.RU

Автозапуск демонов в Ubuntu


0

1

Некоторые демоны (ssh, samba), даже если их удалить из уровней запуска, всё равно стартуют при запуске системы. Собственно, кто управляет их автозапуском, и что делать, если автозапуск надо отключить? Вроде что-то удалось нагуглить по поводу upstart, но текстах по нему много букв, но информацию о том, как отключить автозапуск службы, если им ведает он, не нашёл.

☆☆☆☆☆

Видимо стартуют сервисы, в зависимостях которых есть samba или ssh, они я требуют их запуск.

kostik87 ★★★★★ ()

/etc/init
Кажется они пока ещё не добавили нормальной возможности отключать сервисы, вроде в будущем можно будет в эти .conf файлы добавлять команду disabled, а пока можно просто переименовать файл в .conf~ и сервис запускаться не будет.

firestarter ★★★☆ ()
Ответ на: комментарий от firestarter

Впрочем, если туда написать disabled, сервис работать не будет из-за синтаксической ошибки в файле :D

firestarter ★★★☆ ()
Ответ на: комментарий от firestarter

>а пока можно просто переименовать файл в .conf~ и сервис запускаться не будет.

Спасибо. А при обновлении .conf-файл не вернётся?

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от eR

>стоп, а как добавить нужнео? ну допустим vsftpd?

А чем не устраивает классический способ, через уровни запуска?

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от Ttt

Вернется. Но такие обновления редко чаще раза в полгода происходят.

firestarter ★★★☆ ()
Ответ на: комментарий от eR

> стоп, а как добавить нужнео? ну
допустим vsftpd?

/etc/init/vsftpd.conf появится при установке vsftpd.
Ну а если нужен автозапуск какой то своей задачи, то естественно нужно писать своё правило. Кстати, некоторые сервисы ещё не переписаны на upstart, они стартуют с помощью /etc/init.d скриптов.

firestarter ★★★☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.