LINUX.ORG.RU

[осваиваю Fedora] негодный emacs


0

1

До этого rpm-based дистрибутивов не использовал. Нужен совет от пользователей Fedora!

Я обычно использую самую свежую версию Emacs и org-mode, которую может предоставить дистрибутив.(из testing/unstable в Debian, из ~amd64 в Gentoo) В Fedora я не нашел пакета с org-mode. Он идет вместе с Emacs, причем старый и 'покоцаный': нет babel(!), сразу заметил, что нет некоторых функций.(например, хотел посмотреть версию - не оказалось org-version)

Как в Fedora я могу заполучить нормальный org-mode средствами дистрибутива? (версия Emacs и так свежая) (чтобы он сам обновлялся)

Также в официальном репе мало пакетов для Emacs'а, Lisp'а и его друзей. Некоторые нашел в инете с пометкой 'deprecated'. Может есть какие-нибудь альтернативные репозитории?

Ответ на: комментарий от kermzyxer

> А обновляться как... руками? Ведь таких пакетов будет не один.
тогда xemacs.(у них есть пакетный менеджер)

tn1 ()
Ответ на: комментарий от Reset

> она разве не сдох ?
Очень сложный вопрос. stable за 2009, зато beta за 2011.

tn1 ()
Ответ на: комментарий от Reset

Пакет в gentoo от 30 апреля 2011.(сейчас скачаю, посмотрю)

tn1 ()
Ответ на: комментарий от tn1

PS зато пакетный менеджер есть.

Да он и в нормальном эмаксе есть:

package.el (from ELPA) will be added to vanilla GnuEmacs, version 24. As of 2010-06-18, package.el has been merged with the development version of Emacs, and an ELPA repository has been set up at http://elpa.gnu.org/.

Еще есть el-get какой-то https://github.com/dimitri/el-get

Short Story: el-get allows you to install and manage elisp code for Emacs. It supports lots of differents types of sources and is able to install them, update them and remove them, but more importantly it will init them for you.

zpp ()
Ответ на: комментарий от zpp

> package.el (from ELPA) will be added to vanilla GnuEmacs, version 24.
Радует. ТС`у как я понял нужен по дефолту.

А обновляться как... руками?

tn1 ()
Ответ на: комментарий от zpp

Спасибо. Гляну на него и на emacs 24. Просто очень уж удобно использовать для emacs'овских пакетов основной пакетный менеджер. В Debian и Gentoo то, что ставится из testing сравнимо с git clone.

kermzyxer ()
Ответ на: комментарий от tn1

> Радует. ТС`у как я понял нужен по дефолту.

А обновляться как... руками?

Неужели не прокатит поставить elpa через самого себя?
И в любом случае: одно дело обновить раз в месяц пакетный менеджер и совсем другое - синхронизировать до более свежих бесконечные моды emacs'а.

kermzyxer ()
Ответ на: комментарий от Evgueni

В том то и дело, что не устраивает! org-mode активно пишется, в новых версиях, например, лучше работает автодополнение и поддержка ЯП.

kermzyxer ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.