LINUX.ORG.RU

не работает apt-get


0

1

Ось - debian sid. При попытке запуска apt-get пишет следующее:

apt-get: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by apt-get) apt-get: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/libapt-pkg.so.4.10)

Все библиотеки на месте, в чём проблема?


Все библиотеки на месте, в чём проблема?

В первой части предложения.

Даунгрейдь вручную apt-get при помощи dpkg из /var/cache/apt или скачай откуда.

t184256 ★★★★★ ()
Ответ на: комментарий от smzp

Охохо. Я же написал всё.

sudo dpkg -i /var/cache/apt/archives/libstdc++<tab><tab><какую надо><enter>
t184256 ★★★★★ ()
Ответ на: комментарий от t184256

Спасибо, уже разобрался. Просто скачал более новую версию этой библиотеки: libstdc++.so.6

smzp ()

ололололололо. а я ведь только сегодня в обед читал винрарный тредик в котором ЖоБе с пеной у рта доказывал фракталу что в бинарных дистрах вообще и в дебиане в частности в отличии от генты всё чики-пуки, при обновлении ничего не ломается, ошибки линковки не бывает и ваще всё в шоколаде. ржунимагу

anonymous ()

а как удалось добиться такого эффекта?

o-lo-lo ()
Ответ на: комментарий от anonymous

ололололололо.

заставь гентушника дебиану молиться, он и apt сломает

anonymous ()
Ответ на: комментарий от o-lo-lo

Обновить apt-get из unstable (или какая там у дебиана ветка тестовая)?

uzbl ()
Ответ на: ололололололо. от anonymous

Re: ололололололо.

Ну, йа юзаю стабильные ветки генты и дебиана, там такого не бывает ☺

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.