LINUX.ORG.RU

Ошибка пакетной операции. Установка или удаление пакетов программ не удалось. [Ubuntu 10.10 amd64]


0

1

При установке обновлений\нативных приложений зачастую (но не всегда) выводит эту ошибку.
После неё установленные приложения\обновления всё равно работают, но ошибка всё-же настораживает.


Вот вывод одной из «ошибочно» установленных программ.
В данном случае это Аудиоконвертер.

installArchives() failed: Выбор ранее не выбранного пакета soundconverter.
(Чтение базы данных ...
(Чтение базы данных ... 5%
(Чтение базы данных ... 10%
(Чтение базы данных ... 15%
(Чтение базы данных ... 20%
(Чтение базы данных ... 25%
(Чтение базы данных ... 30%
(Чтение базы данных ... 35%
(Чтение базы данных ... 40%
(Чтение базы данных ... 45%
(Чтение базы данных ... 50%
(Чтение базы данных ... 55%
(Чтение базы данных ... 60%
(Чтение базы данных ... 65%
(Чтение базы данных ... 70%
(Чтение базы данных ... 75%
(Чтение базы данных ... 80%
(Чтение базы данных ... 85%
(Чтение базы данных ... 90%
(Чтение базы данных ... 95%
(Чтение базы данных ... 100%
(Чтение базы данных ... на данный момент установлено 153644 файлов и каталогов.)
Распаковывается пакет soundconverter (из файла .../soundconverter_1.4.4-2_all.deb)...
Обрабатываются триггеры для desktop-file-utils ...
Обрабатываются триггеры для python-gmenu ...
Rebuilding /usr/share/applications/desktop.ru_RU.UTF8.cache...
Обрабатываются триггеры для hicolor-icon-theme ...
Обрабатываются триггеры для man-db ...
Обрабатываются триггеры для python-support ...
Настраивается пакет ttf-lyx (1.6.7-1) ...
E: /var/lib/defoma/locked exists.
E: Another defoma process seems running, or you aren't root.
E: If you are root and defoma process isn't running undoubtedly,
E: it is possible that defoma might have aborted.
E: Please run defoma-reconfigure -f to fix its broken status.
dpkg: не удалось обработать параметр ttf-lyx (--configure):
подпроцесс установлен сценарий post-installation возвратил код ошибки 1
dpkg: зависимости пакетов не позволяют настроить пакет python-matplotlib-data:
python-matplotlib-data зависит от ttf-lyx, однако:
Пакет ttf-lyx пока не настроен.
dpkg: не удалось обработать параметр python-matplotlib-data (--configure):
проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет python-matplotlib:
python-matplotlib зависит от python-matplotlib-data (>= 0.99.3-1ubuntu1), однако:
Пакет python-matplotlib-data пока не настроен.
dpkg: не удалось обработать параметр python-matplotlib (--configure):
проблемы зависимостей — оставляем не настроенным
Настраивается пакет ttf-mscorefonts-installer (3.2) ...
These fonts were provided by Microsoft «in the interest of cross-
platform compatibility». This is no longer the case, but they are
still available from third parties.
You are free to download these fonts and use them for your own use,
but you may not redistribute them in modified form, including changes
to the file name or packaging format.
All fonts downloaded and installed.
E: /var/lib/defoma/locked exists.
E: Another defoma process seems running, or you aren't root.
E: If you are root and defoma process isn't running undoubtedly,
E: it is possible that defoma might have aborted.
E: Please run defoma-reconfigure -f to fix its broken status.
dpkg: не удалось обработать параметр ttf-mscorefonts-installer (--configure):
подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Настраивается пакет soundconverter (1.4.4-2) ...
No apport report written because MaxReports is reached already
Настраивается пакет ttf-mscorefonts-installer (3.2) ...
These fonts were provided by Microsoft «in the interest of cross-
platform compatibility». This is no longer the case, but they are
still available from third parties.
You are free to download these fonts and use them for your own use,
but you may not redistribute them in modified form, including changes
to the file name or packaging format.
All fonts downloaded and installed.
E: /var/lib/defoma/locked exists.
E: Another defoma process seems running, or you aren't root.
E: If you are root and defoma process isn't running undoubtedly,
E: it is possible that defoma might have aborted.
E: Please run defoma-reconfigure -f to fix its broken status.
dpkg: не удалось обработать параметр ttf-mscorefonts-installer (--configure):
подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Настраивается пакет ttf-lyx (1.6.7-1) ...
E: /var/lib/defoma/locked exists.
E: Another defoma process seems running, or you aren't root.
E: If you are root and defoma process isn't running undoubtedly,
E: it is possible that defoma might have aborted.
E: Please run defoma-reconfigure -f to fix its broken status.
dpkg: не удалось обработать параметр ttf-lyx (--configure):
подпроцесс установлен сценарий post-installation возвратил код ошибки 1
dpkg: зависимости пакетов не позволяют настроить пакет python-matplotlib-data:
python-matplotlib-data зависит от ttf-lyx, однако:
Пакет ttf-lyx пока не настроен.
dpkg: не удалось обработать параметр python-matplotlib-data (--configure):
проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет python-matplotlib:
python-matplotlib зависит от python-matplotlib-data (>= 0.99.3-1ubuntu1), однако:
Пакет python-matplotlib-data пока не настроен.
dpkg: не удалось обработать параметр python-matplotlib (--configure):
проблемы зависимостей — оставляем не настроенным



Как можно избавится от этого косяка и из за чего он вообще выходит?

При удалении пакета вывел аналогичную ошибку.

mr_penguin ()
sudo rm /var/lib/defoma/locked

и еще раз попробуй.

Nervous ★★★ ()
Ответ на: комментарий от Nervous

Удалил файл. Опробовал и установил\удалил парочку рандомных приложений. Ошибка не вылезла.

Благодарю!

mr_penguin ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.