LINUX.ORG.RU

Мля ...состояние python в debian убивает....


0

0

Ну вот и что делать?


Настраивается пакет python-gtk2 (2.8.6-6) ...
Traceback (most recent call last):
  File "/usr/sbin/update-python-modules", line 284, in ?
    process(basedir,install_modules(py_installed))
  File "/usr/sbin/update-python-modules", line 150, in process
    func(basedir, dir, file)
  File "/usr/sbin/update-python-modules", line 122, in install_modules_func
    os.symlink(fullpath,destpath)
OSError: [Errno 17] File exists
dpkg: не удалось обработать параметр python-gtk2 (--configure):
 подпроцесс post-installation script возвратил код ошибки 1
dpkg: зависимости пакетов не позволяют настроить пакет python-gnome2:
 python-gnome2 зависит от python-gtk2 (>= 2.8.6-1), однако:
  Пакет python-gtk2 пока не настроен.
dpkg: не удалось обработать параметр python-gnome2 (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет python-glade2:
 python-glade2 зависит от python-gtk2 (= 2.8.6-6), однако:
  Пакет python-gtk2 пока не настроен.
dpkg: не удалось обработать параметр python-glade2 (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет hal-device-manager:
 hal-device-manager зависит от python2.4-gnome2, однако:
  Пакет python2.4-gnome2 не установлен.
  Пакет python-gnome2, предоставляющий python2.4-gnome2, пока не настроен.
 hal-device-manager зависит от python2.4-glade2, однако:
  Пакет python2.4-glade2 не установлен.
  Пакет python-glade2, предоставляющий python2.4-glade2, пока не настроен.
dpkg: не удалось обработать параметр hal-device-manager (--configure):
 проблемы зависимостей -- оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 python-gtk2
 python-gnome2
 python-glade2
 hal-device-manager
E: Sub-process /usr/bin/dpkg returned an error code (1)

Re: Мля ...состояние python в debian убивает....

Debian/Unstable == ССЗБ

sdio ★★★★★ ()

Re: Мля ...состояние python в debian убивает....

Сказать apt-get update. Зоибали с одной и той же претензией приходить -- "я сильно умный сижу на unstable и сделал в неудачный момент два месяца назад update, и теперь у меня ничего не работает, помогите"

Zulu ★★☆☆ ()

Re: Мля ...состояние python в debian убивает....

2 Zulu

Самый умный, да? Если бы все решалась обновлением, я бы сюда не постил

Обапдейться, но как был геммор с питоном так и остался...

Sargan ()
Ответ на: Re: Мля ...состояние python в debian убивает.... от Sargan

Re: Мля ...состояние python в debian убивает....

~$ dpkg -l | grep python
ii  python                          2.4.3-11                   An interactive high-level object-oriented language (defaul
ii  python-cairo                    1.2.0-1                    Python bindings for the Cairo vector graphics library
ii  python-central                  0.5.5                      register and build utility for Python packages
ii  python-dbus                     0.71-3                     simple interprocess messaging system (Python interface)
ii  python-glade2                   2.8.6-6                    GTK+ bindings: Glade support
ii  python-gmenu                    2.14.3-1                   an implementation of the freedesktop menu specification fo
ii  python-gnome2                   2.12.4-5                   Python bindings for the GNOME desktop environment
ii  python-gnupginterface           0.3.2-9                    Python interface to GnuPG (GPG)
ii  python-gtk2                     2.8.6-6                    Python bindings for the GTK+ widget set
ii  python-libxml2                  2.6.26.dfsg-3              Python bindings for the GNOME XML library
ii  python-minimal                  2.4.3-11                   A minimal subset of the Python language (default version)
ii  python-numeric                  24.2-6                     Numerical (matrix-oriented) Mathematics for Python
ii  python-pyorbit                  2.0.1-5                    A Python language binding for the ORBit2 CORBA implementat
ii  python-pysqlite2                2.3.2-1                    python interface to SQLite 3
ii  python-support                  0.5.2                      automated rebuilding support for python modules
ii  python-uno                      2.0.4~rc3-1                Python interface for OpenOffice.org
ii  python2.3                       2.3.5-15                   An interactive high-level object-oriented language (versio
ii  python2.4                       2.4.3-8                    An interactive high-level object-oriented language (versio
ii  python2.4-minimal               2.4.3-8                    A minimal subset of the Python language (version 2.4)

Zulu ★★☆☆ ()

Re: Мля ...состояние python в debian убивает....

sargan@notebook:~$ dpkg -l | grep python
ii  python                           2.4.3-11                      An interactive high-level object-oriented language (de
ii  python-cairo                     1.2.0-1                       Python bindings for the Cairo vector graphics library
ii  python-central                   0.5.5                         register and build utility for Python packages
ii  python-dbus                      0.71-3                        simple interprocess messaging system (Python interface
ii  python-foomatic                  0.7.6                         Python interface to the Foomatic printer database
iU  python-glade2                    2.8.6-6                       GTK+ bindings: Glade support
ii  python-gmenu                     2.14.3-1                      an implementation of the freedesktop menu specificatio
iU  python-gnome2                    2.12.4-5                      Python bindings for the GNOME desktop environment
iF  python-gtk2                      2.8.6-6                       Python bindings for the GTK+ widget set
ii  python-ipy                       0.42-7                        Python module for handling IPv4 and IPv6 addresses and
ii  python-libxml2                   2.6.26.dfsg-3                 Python bindings for the GNOME XML library
ii  python-minimal                   2.4.3-11                      A minimal subset of the Python language (default versi
ii  python-mpdclient                 0.11.1-2                      Python interface to MPD
ii  python-numeric                   24.2-6                        Numerical (matrix-oriented) Mathematics for Python
ii  python-pyorbit                   2.0.1-5                       A Python language binding for the ORBit2 CORBA impleme
ii  python-qt3                       3.16-1.2                      Qt3 bindings for Python
ii  python-sip4                      4.4.5-2                       Python/C++ bindings generator runtime library
ii  python-support                   0.4.3                         automated rebuilding support for python modules
ii  python-uno                       2.0.3-6                       Python interface for OpenOffice.org
ii  python2.3                        2.3.5-15                      An interactive high-level object-oriented language (ve
ii  python2.4                        2.4.3-9                       An interactive high-level object-oriented language (ve
ii  python2.4-minimal                2.4.3-9                       A minimal subset of the Python language (version 2.4)

Sargan ()
Ответ на: Re: Мля ...состояние python в debian убивает.... от Sargan

Re: Мля ...состояние python в debian убивает....

sudo apt-get remove python-gtk2 python-gnome2 python-glade2

apt-get update

sargan@notebook:~$ sudo apt-get install python-gtk2
Чтение списков пакетов... Готово
Построение дерева зависимостей... Готово
НОВЫЕ пакеты, которые будут установлены:
  python-gtk2
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 327 пакетов не обновлено.
Необходимо скачать 0B/1182kB архивов.
После распаковки объем занятого дискового пространства возрастёт на 4022kB.
Выбор ранее не выбранного пакета python-gtk2.
(Чтение базы данных... на данный момент установлено 83666 файлов и каталогов.)
Распаковывается пакет python-gtk2 (из файла .../python-gtk2_2.8.6-6_i386.deb)...
Настраивается пакет python-gtk2 (2.8.6-6) ...
Traceback (most recent call last):
  File "/usr/sbin/update-python-modules", line 284, in ?
    process(basedir,install_modules(py_installed))
  File "/usr/sbin/update-python-modules", line 150, in process
    func(basedir, dir, file)
  File "/usr/sbin/update-python-modules", line 122, in install_modules_func
    os.symlink(fullpath,destpath)
OSError: [Errno 17] File exists
dpkg: не удалось обработать параметр python-gtk2 (--configure):
 подпроцесс post-installation script возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 python-gtk2
E: Sub-process /usr/bin/dpkg returned an error code (1)

Sargan ()

Re: Мля ...состояние python в debian убивает....

>>Было бы ещё неплохо извиниться перед Zulu. Простите если требую невозможного. :)

Не вопрос, только извиниться за что? Он в в резких выражениях предложил решить проблему не тем способом которым она решается. Я ответил подобным тоном.

Sargan ()

Re: Мля ...состояние python в debian убивает....

>>Сказать apt-get update. Зоибали с одной и той же претензией >>приходить -- "я сильно умный сижу на unstable и сделал в неудачный >>момент два месяца назад update, и теперь у меня ничего не работает, >>помогите"

Как я понял Zulu имел ввиду, что у меня базы апта старые, возможно с испорченными зависимостями, пару раз такое было на unstable... Но тут проблема была в том, что сам пакет python-support должен был САМ обновиться при установке, скажем, новой версии python-gtk2, тогда бы и проблема не вылезла... Я с мандривы в свое время слез именно потому, что хотел избавиться от головной боли при установке пакетов....

ЗЫ: Возможно помог бы apt-get upgrade, но во первых не факт, во вторых это из пушки по комарам.

Sargan ()
Ответ на: Re: Мля ...состояние python в debian убивает.... от Sargan

Re: Мля ...состояние python в debian убивает....

Имелось в виду как раз apt-get update && apt-get upgrade. Какой смысл обновлять список пакетов, не обновляя сами пакеты?

Ну, да, можно обновить не всё, а только то, что конкретно у тебя глючит, но суть его ответа была именно в том, что обновись и не жалуйся, что в тестируемом дистрибутиве двухмесячной давности есть проблемы, если ты даже не потрудился обновить его до актуального состояния.

Teak ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.