LINUX.ORG.RU

Вопрос по дебианам, репозиториям и PPA


0

0

Захотелось мне поставить свежий audacious (2.4) в Ubuntu 10.04.

Нашел этот пакетик в PPA:
https://launchpad.net/~philip5/ archive/extra

Добавил его, делаю apt-get update/upgrade и получаю сообщение о том, что оно хочет поставить все пакеты, что есть в этом PPA. А мне этого не нужно, мне нужен только audacious.

Посмотрел apt-cache policy, понизил приоритет этого источника.

/etc/apt/preferences

Package: * 
Pin: release a=lucid,o=LP-PPA-philip5-extra
Pin-Priority: 300

После чего удалось установить только audacious с зависимостями из этого PPA.

apt-get install audacious/lucid libaudclient2/lucid libaudid3tag2/lucid libaudcore1/lucid libmowgli2/lucid audacious-plugins/lucid libmcs1/lucid

Внимание, вопрос: правильно ли я все сделал?
Если да, то почему процесс установки отдельного приложения из PPA — такой геморрой?

★★★★★

Мне идея ppa всегда казалась неправильной и геморной. Лучше бы сделали как в ауре.

Zodd ★★★★★ ()
Ответ на: комментарий от Igron

Там самое главное один аур подрубаешь, а не «А давайте каждому по ppa».

Zodd ★★★★★ ()
Ответ на: комментарий от Igron

на самом деле просто удобнее реализована навигация по ауру, я бы так сказал

Ingvarr ★★★ ()

preferences можно было бы и не ковырять, достаточно было после update установить плеер (если он уже был установлен, то он просто обновился бы из подключенного РРА) и после этого этот РРА отключить.

firestarter ★★★☆ ()
Ответ на: комментарий от firestarter

> preferences можно было бы и не ковырять, достаточно было после update установить плеер (если он уже был установлен, то он просто обновился бы из подключенного РРА)

Еще раз повторяю, помимо плеера оно захотело поставить кучу другой фигни. Т.е. сделай бы я «sudo apt-get install audacious», оно бы мне обновило и гимп и вообще все что там есть.

и после этого этот РРА отключить.


Это вообще совет ни к селу, ни к городу.

Igron ★★★★★ ()
Ответ на: комментарий от Igron

значит audacious хочет >=некая_шняга от которой зависит gimp, и выбрал самую свежую некую_шнягу а не ту, которая «=».
соответственно потянулись ещё зависимости, блаблабла, и gimp решил обновится т.к. ещё какая-то_шняга возжелала >=gimp.

system-root ★★★★★ ()
Ответ на: комментарий от system-root

> значит audacious хочет >=некая_шняга от которой зависит gimp, и выбрал самую свежую некую_шнягу а не ту, которая «=».

соответственно потянулись ещё зависимости, блаблабла, и gimp решил обновится т.к. ещё какая-то_шняга возжелала >=gimp.


Не-ет. Дело в приоритетах: в новом источники приложения оказались свежее.

Если следовать твоей логике, каким образом тогда я установил audacious без gimp, и ничего при этом не сломалось?

Igron ★★★★★ ()
Ответ на: комментарий от Igron

>> и после этого этот РРА отключить.

Это вообще совет ни к селу, ни к городу.


Это для того чтобы в следующий раз при aptitude upgrade ничего не обновлялось оттуда, ты же этого не хочешь, как я понял из первого поста.

firestarter ★★★☆ ()
Ответ на: комментарий от firestarter

> Это для того чтобы в следующий раз при aptitude upgrade ничего не обновлялось оттуда, ты же этого не хочешь, как я понял из первого поста.

Я хочу, чтоб обновлялся только audacious, и ставились версии 2.4.1, 2.4.2 при появлении их в PPA.

Igron ★★★★★ ()
Ответ на: комментарий от Igron

>Если следовать твоей логике, каким образом тогда я установил audacious без gimp, и ничего при этом не сломалось?

ну да, просто всё обновилось из за того, что в той ppa всё было посвежее.
в этом и гемор этих ppa, что их куча и они не всегдо соотносятся друг с другом.

system-root ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.