LINUX.ORG.RU

[mhddfs] Не работает, хочет modprobe fuse


0

0

Вот мой /etc/fstab:


# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

/dev/sda1       /        ext3    errors=remount-ro 0       1

/dev/sdb1       /mnt/home1  ext3    defaults        0       1
/dev/sdc1       /mnt/home2      ext3    defaults 0      1


mhddfs#/mnt/home1,/mnt/home2 /home     fuse  defaults 0 0




proc            /proc           proc    defaults        0       0
/dev/cdrom        /media/cdrom0   udf,iso9660 user,noauto     0       0


/dev/sda2      swap    swap                                    0       0


При этом руками из консоли к тем же точкам всё монтируется и ок. А тут при загрузке просит сделать modprobe fuse (зачем?) и не пашет.


К вышесказанному

echo 'fuse' >>/etc/modules
xnj,s yt gfhbnmcz dhexye.

darkshvein ☆☆ ()

Собери fuse в ядре и добавь в /etc/conf.d/modules (в генте так)

ClanMax ()
Ответ на: комментарий от anon_666

А почему тогда монтируется вручную, вот что интересно.

ShTH ()
Ответ на: комментарий от anon_666

Добавление в модули FUSE помогло. Теперь всё примонтировалось корректно, судя по ls /home. Но залогиниться я не могу, пишет что cannot find ~/ directory. Что это? Конфиги всё на месте.

ShTH ()
Ответ на: комментарий от ClanMax

А в /home есть папочка с именем пользователя то? Все конфиги должны храниться в /home/username

Всё так и есть. Потому и странно

ShTH ()
Ответ на: комментарий от ShTH

Вот не все как у людей. config.gz хотя бы включили. А попробуй удалить правила из fstab, а потом из другого пользователя все примонтировать и войти.

ClanMax ()
Ответ на: комментарий от ShTH
/dev/sdb1       /mnt/home1  ext3    defaults        0       1 
/dev/sdc1       /mnt/home2      ext3    defaults 0      1 
 
 
mhddfs#/mnt/home1,/mnt/home2 /home     fuse  defaults 0 0 

Закомментируй и сделай это все руками после включения. Потом войди под своим домашним пользователем. Если все будет нормально то проблема в fuse

ClanMax ()
Ответ на: комментарий от ShTH

У меня вот так:

$ grep -r -i fuse /{etc,lib}/udev/rules.d/
/lib/udev/rules.d/99-fuse.rules:KERNEL=="fuse", MODE="0666"
/lib/udev/rules.d/50-udev-default.rules:KERNEL=="fuse",			MODE="0666", OPTIONS+="static_node=fuse" \
/lib/udev/rules.d/50-udev-default.rules:  RUN+="/bin/mount -t fusectl fusectl /sys/fs/fuse/connections"
Что если добавить 50-udev-default.rules как у меня?

anon_666 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.