LINUX.ORG.RU

Нет прав монтирования


0

0

Товарисчииии, поможите срочно! :) Создал нового пользователя, после чего не смог примонтировать дополнительный ext4 раздел. Пишет что-то типа этого «только root имеет право монтировать /dev/sda5 /mnt/sda5 раздел» Что там в правах добавить надо? Или нового пользователя забыл включить в какую нить группу? Или в fstab секцию umask прописать?

Должны быть указаны опции: users,exec,suid,dev.

AITap ★★★★★ ()

В /etc/fstab добавить опцию «user» либо «users». За разъяснениями добро пожаловать в man mount

dumal ★★ ()

/dev/sd*N /куда/ ext4 defaults 0 2

Ну или с UUID вместо ссылки на устройство
Узнай:
sudo blkid -o value -s UUID /dev/sd*N

amorpher ★★★★★ ()

Откатись на виду и «работай» там под «Администратор»

Led ★★★☆☆ ()

> Создал нового пользователя,

после чего не смог примонтировать дополнительный ext4 раздел.

Раздел тоже создал или он был ранее?

До этого он монтировался или нет?

Как монтировался раньше?

Монтируется ли теперь таким-же методом как раньше?

«только root имеет право монтировать /dev/sda5 /mnt/sda5 раздел» Что там в правах добавить надо?

В fstab запись есть?

Если есть, то монтировать надо указывая только точку монтирования, устройство указывать не нужн.

sin_a ★★★★★ ()
Ответ на: комментарий от GotF

Всё попорядку

Раздел тоже создал или он был ранее?

Раздел создан ещё при царе горохе.

< До этого он монтировался или нет?

Иссесено монтировался. Он и Сейчас монтируется если под рутом зайти.

< В fstab запись есть?

Вот fstab целиком на обозрение.

/dev/sda2 swap swap defaults 0 0
/dev/sda3 / ext4 defaults 1 1
/dev/sda5 /Linux_DATA ext4 noauto 1 0  ###### Этот раздел монтируется только под рутом.
/dev/sda1 /NTFS-C ntfs-3g umask=000,nls=utf8 1 0
/dev/sda6 /NTFS-E ntfs-3g umask=000,nls=utf8 1 0
/dev/sdb1 /NTFS-D ntfs-3g umask=000,nls=utf8 1 0
/dev/sdb5 /NTFS-F ntfs-3g umask=000,nls=utf8 1 0
/dev/cdrom /mnt/cdrom iso9660 iocharset=utf8,noauto,owner,ro 0 0
/dev/sdb1 /mnt/flash vfat noauto,codepage=866,iocharset=utf8,async,noexec,user,rw 1 0
/dev/fd0 /mnt/floppy noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
Кстати, NTFS разделы монтируются нормально! А вот ext4 нивкакую Опция umask=000 для ext4 раздела ничего не дала.

Humaxoid ()
Ответ на: комментарий от Humaxoid

> /dev/sda5 /Linux_DATA ext4 noauto 1 0 ###### Этот раздел монтируется только под рутом.

Всё правильно. Если убрать noauto в параметрах то он будет подключаться сам при старте системы. А если добавить параметр user, то можно будет монтировать обычным пользователем.

sin_a ★★★★★ ()
Ответ на: комментарий от sin_a

> Всё правильно. Если убрать noauto в параметрах то он будет подключаться сам при старте системы. А если добавить параметр user, то можно будет монтировать обычным пользователем.

Спасибо за подсказку. Сtйчас буду эксперементировать с параметром user. Параметр noauto думаю нужно оставить. Потому что мне не надо чтобы этот раздел автоматически монтировался при старте системы. Я его монтирую ручками при необходимости mount /dev/sda5 после он мотируется с параметрами указанными в fstab

Humaxoid ()
Ответ на: комментарий от dumal

> Думаю, что предыдущий оратор дал более правильный совет

Это зависит от целей.

cvs-255 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.