LINUX.ORG.RU

[emacs] - Symbol's value as variable is void: f


0

0

Периодически после длительной работы с emacs в .emacs появляется:

(custom-set-variables
  ;; custom-set-variables was added by Custom.
  ;; If you edit it by hand, you could mess it up, so be careful.
  ;; Your init file should contain only one such instance.
  ;; If there is more than one, they won't work right.
 '(canlock-password "9ce59f31a59fc3b5224d6c2b688c1a5c8f0e9136")
 '(gnus-use-adaptive-scoring f)
 '(muse-file-extension "muse")
 '(muse-html-charset-default "utf-8")
 '(muse-html-encoding-default (quote utf-8))
 '(muse-html-meta-content-encoding (quote utf-8))
 '(muse-mode-auto-p nil))
(custom-set-faces
  ;; custom-set-faces was added by Custom.
  ;; If you edit it by hand, you could mess it up, so be careful.
  ;; Your init file should contain only one such instance.
  ;; If there is more than one, they won't work right.
 )

После этого при последующей загрузке emacs я получаю следующее сообщение об ошибке:

custom-initialize-reset: Symbol's value as variable is void: f

Как избежать появления этих строк в моем конфиге ?

★★

Ответ на: комментарий от lemas

Эти строки - результат применения настроек в custom. Чтоб они не появлялись - не нужно пользоваться custom. Хотя я и не понимаю чем они вам мешают. А касательно ошибки - наверное там должно быть `gnus-use-adaptive-scoring t`, а не `gnus-use-adaptive-scoring f`.

xetf ★★ ()
Ответ на: комментарий от lemas

ну, логично предположить, что нужно добавить в конфиг что-то типа

(Custom-mode -1)

Neclude ()

>(gnus-use-adaptive-scoring f)

Э-э-э, что за 'f' тут? Может, nil? Может, t?

Зайди M-x customize-group gnus-score-adapt и исправь.

Либо просто сотри в эту строчку в ~/.emacs

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

Либо просто сотри в эту строчку в ~/.emacs

Стереть не проблема - она снова появляется :)

lemas ★★ ()
Ответ на: комментарий от lemas

Ну так там может быть выбрано три значения: word, line или, если не выбрано ни одно из них, то nil. Других значений эта переменная принимать не должна. Предполагаю, что ты случайно исправил переменную в .emacs и не заметил. Теперь emacs каждый раз пытается подгрузить это f, а это ошибка. Вместо f напиши nil, а потом уже решишь, что тебе тебе нужно word, line или оставить nil. Если просто сотрешь эту переменную из .emacs, то она будет считаться nil.

Zubok ★★★★★ ()

> Периодически после длительной работы с emacs в .emacs появляется:

Эти строчки — результат применения подсистемы управления настройками
под названием Custom. Похоже, что ты изменил какие-то опции Emacs
с помощью M-x customize-option и сохранил изменения. Если ты этого
не делал, то ситуация странная. Проявляется ли это поведение при
работе с Емаксом `emacs -q`?

Sphinx ★★☆☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.