LINUX.ORG.RU

Отсутствие звука в deb lenny | ca0106 | alsa


0

0

Есть встроенная звуковуха SB Live 24bit, определилась верно - ca0106. Поставлена alsa со всеми утилитами, пользователь в группе audio, все каналы рамьючены, alsaconf запускался и отработал верно, сама alsa запущена. Звука все равно нет. Проблема в том, что cat /dev/urandom > /dev/dsp и cat /dev/urandom > /dev/audio - no space left on device. Колонки рабочие, из под другой системы все звучит. Кто сталкивался, куда копать? Ядро - 2.6.26-2amd64

Ответ на: комментарий от amorpher

snd_ca0106 37760 0 snd_seq_midi 11072 0 snd_seq_midi_event 11904 1 snd_seq_midi snd_rawmidi 26784 2 snd_ca0106,snd_seq_midi snd_ac97_codec 115416 1 snd_ca0106 snd_pcm 81800 2 snd_ca0106,snd_ac97_codec snd_seq 54304 2 snd_seq_midi,snd_seq_midi_event snd_timer 25744 2 snd_pcm,snd_seq snd_seq_device 11668 3 snd_seq_midi,snd_rawmidi,snd_seq snd 63688 7 snd_ca0106,snd_rawmidi,snd_ac97_codec,snd_pcm,snd_seq,snd_timer,snd_seq_device soundcore 12064 1 snd ac97_bus 6272 1 snd_ac97_codec snd_page_alloc 13072 2 snd_ca0106,snd_pcm pppoe 14976 2 pppox 7960 1 pppoe ipv6 288456 16 ppp_generic 27816 6 pppoe,pppox slhc 10240 1 ppp_generic sbp2 25356 0 loop 19468 0 serio_raw 9988 0 i2c_i801 13596 0 psmouse 42268 0 i2c_core 27936 1 i2c_i801 pcspkr 7040 0 rng_core 8968 0 usblp 16896 0 i82975x_edac 9096 0 edac_core 49560 1 i82975x_edac button 11680 0 evdev 14208 5 ext3 125072 1 jbd 51240 1 ext3 mbcache 12804 1 ext3 ide_cd_mod 36360 0 cdrom 37928 1 ide_cd_mod sd_mod 29376 3 piix 12424 0 [permanent] usbhid 45792 0 hid 41792 1 usbhid ff_memless 9224 1 usbhid ide_pci_generic 9220 0 [permanent] ata_piix 22660 2 floppy 61800 0 it821x 11140 0 [permanent] ide_core 128284 4 ide_cd_mod,piix,ide_pci_generic,it821x ohci1394 32692 0 ata_generic 10116 0 ieee1394 93944 2 sbp2,ohci1394 libata 165600 2 ata_piix,ata_generic scsi_mod 161016 3 sbp2,sd_mod,libata dock 14112 1 libata ehci_hcd 36108 0 tg3 97156 0 uhci_hcd 25760 0 thermal 22688 0 processor 42304 1 thermal fan 9352 0 thermal_sys 17728 3 thermal,processor,fan

Mike_N_Mechanics ()
Ответ на: комментарий от amorpher

Все переключатели, все выставлено. Теперь почему-то слетают конфиги alsa каждую перезагрузку и сбрасываются на другую карточку - ATI HD48x0 - видимо это выход с графической карты. Думаю, надо прописать alsactl restore в скрипты. Но это не особо важно - звука нет ни до ни после alsaconf. Я довольно долго уже вошкаюсь с этим звуком - мне бы хотя бы локализовать проблему. С ALSA, к сожалению, общаюсь всего дня два, опыта нет.

Mike_N_Mechanics ()
Ответ на: комментарий от Mike_N_Mechanics

если Gnome
посмотреть в gnome-sound-properties
или
из пакете gnome-media
запустить из консоли gstreamer-properties

elipse ★★★ ()
Ответ на: комментарий от amorpher

Еще раз опишу ситуацию - все плееры работают (по-крайней мере - делают вид), все настройки сделаны и карточка определна верно. Но! Звука все равно нет. Такое чувство, что пропадает он не где-то в ALSA, а уже по пути к колонкам. Однако ж в Win2k8 все работало from box.

Mike_N_Mechanics ()
Ответ на: комментарий от amorpher

На звук есть аж целых четыре карты.

card 0: CA0106 [CA0106], device 0: ca0106 [CA0106] Subdevices: 1/1 Subdevice #0: subdevice #0

card 0: CA0106 [CA0106], device 1: ca0106 [CA0106] Subdevices: 1/1 Subdevice #0: subdevice #0

card 0: CA0106 [CA0106], device 2: ca0106 [CA0106] Subdevices: 1/1 Subdevice #0: subdevice #0

card 0: CA0106 [CA0106], device 3: ca0106 [CA0106] Subdevices: 1/1 Subdevice #0: subdevice #0

Гугл говорит, что это нормально. Есть еще звуквой чип на графической карте, поменял приоритеты загрузки, на всякий случай, толку ноль. Га*но какое-то, не понятно ничего.

Mike_N_Mechanics ()
Ответ на: комментарий от Mike_N_Mechanics

>Ну да, с учетом того, что SB встроенная и именно ее мне надо заставить рабоать - совет просто в точку.

Да, не зря я спать пошёл :)
Не знаю. Ты где-то, извиняюсь за выражение, возможно просто тупишь. Попереключай в миксере ещё раз всё что можно.
Фирмаварь, как в начале написано, стоит. ХЗ, была у меня такая карта (внешняя) ещё года 3 назад - работала (openSUSE, Debian, Ubuntu, Slackware) и на 64бит. в том числе, без особых проблем.
Алсу, ядро из тестинга попробуй.

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

Да я не обижаюсь, я бы рад скинуть все это на «тупишь», но вот уж как-то не получается. Я нашел на сайтах убунты и в багтрекерах людей, которые также мучались с этой карточкой и не нашли решения >:\

была у меня такая карта (внешняя) ещё года 3 назад

На alsa-project было где-то написано, что эта карта еле-еле поддерживается. total frustation!

Mike_N_Mechanics ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.