LINUX.ORG.RU

GTK+ и размер фонта


0

0

После очередного обновления (где то неделю назад) в GTK+ приложениях размер и начертание фонтов перестали регулироваться.

В ~/.gtkrc-2.0 прописано и имя фонта и его размер. Но любое изменение никак не влияет на вновь запущенные приложения.

$ cat ~/.gtkrc-2.0
# -- THEME AUTO-WRITTEN DO NOT EDIT
include "/usr/share/themes/QtCurve/gtk-2.0/gtkrc"

style "user-font" {
	font_name = "DejaVu Sans 8"
}

widget_class "*" style "user-font"

gtk-font-name="DejaVu Sans 8"

gtk-theme-name  = "QtCurve"

include "/home/andrey/.gtkrc.mine"

# -- THEME AUTO-WRITTEN DO NOT EDIT
$ cat /home/andrey/.gtkrc.mine
// тут пусто

Сейчас сделал даунгрейд, но это не решило проблему: x11-themes/gtk-engines-2.18.3 x11-themes/gtk-engines-qtcurve-0.69.2

До этого версии этих пакетов были последние.

В какую сторону копать?

★★★★★

Среда — GNOME? Если да — настраивать через гуй, если нет...
Возможно, тем не менее, стоит копать в сторону gnome-settings-daemon:
для начала запущен ли он («$ps aux | grep gnome-settings-daemon») и так далее.

Tayler ★★ ()
Ответ на: комментарий от Tayler

Нет, никаких DE не использую. Так же не использую DE-зависимый софт. В качестве WM использую Ion3.

Есть утилита gtk-chtheme (http://plasmasturm.org/programs/gtk-chtheme/) и gtk-theme-switch (http://www.muhri.net/nav.php3?node=gts), они прекрасно переключают GTK+-тему, но фонт даже в них не меняется.

andreyu ★★★★★ ()

угу, тоже не понимаю

APM ()

Ну самое простое - посмотреть «/usr/share/themes/QtCurve/gtk-2.0/gtkrc».

Не факт, что поможет, но так... убедиться ))

hibou ★★★★★ ()
Ответ на: комментарий от hibou

> Ну самое простое - посмотреть «/usr/share/themes/QtCurve/gtk-2.0/gtkrc».

Посмотрел, конечно :)
Но что там смотреть то. Попробовал тему crux - размер фонтов меняется, но ниже «9» не ставится. Все остальные темы не реагируют на изменение фонта вообще. А ведь раньше все регулировалось.

andreyu ★★★★★ ()
Ответ на: комментарий от andreyu

> Так же не использую DE-зависимый софт.
Точно? =)
«$ps aux | grep gnome» ничего не выдает?

Попробуйте еще строку «gtk-theme-name = „QtCurve“»
в начало конфига .gtkrc-2.0 переместить,
мало ли, может тема затирает что-нибудь.

Tayler ★★ ()
Ответ на: комментарий от Tayler

> «$ps aux | grep gnome» ничего не выдает?

Нет, чисто.

Попробуйте еще строку «gtk-theme-name = „QtCurve“»


Не помогло.

andreyu ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.