LINUX.ORG.RU

Psimedia в debian lenny


0

0

Поставил на своем ленни пакет psimedia из сквиза. Пробовал его с psi-0.13 и psi-plus. И то и то зависает при запуске. В терминале при запуске вот что:

..................................................................................................................

Found plugin: /usr/lib/psi/plugins/libgstprovider.so Loading Plugin «/usr/lib/psi/plugins/libgstprovider.so» Trying to load plugin Attempted to load /usr/lib/psi/plugins/libgstprovider.so, but it is not a valid plugin.

(<unknown>:6945): GLib-GObject-WARNING **: cannot register existing type `GstAudioresample'

(<unknown>:6945): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed Unable to load element 'audioresample'. Accessing missing option options.ui.notifications.send-receipts

(<unknown>:6945): GLib-GObject-WARNING **: cannot register existing type `GstVideoSink'

(<unknown>:6945): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(<unknown>:6945): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

(<unknown>:6945): GLib-GObject-WARNING **: cannot register existing type `GstRtpBin'

(<unknown>:6945): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(<unknown>:6945): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

(<unknown>:6945): GLib-GObject-WARNING **: cannot register existing type `GstVideoMaxRate'

(<unknown>:6945): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(<unknown>:6945): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

(<unknown>:6945): GLib-GObject-WARNING **: cannot register existing type `GstLiveAdder'

(<unknown>:6945): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(<unknown>:6945): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

(<unknown>:6945): GLib-GObject-WARNING **: cannot register existing type `GstAudioresample'

(<unknown>:6945): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(<unknown>:6945): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

(<unknown>:6945): GLib-GObject-WARNING **: cannot register existing type `GstSpeexDSP'

(<unknown>:6945): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(<unknown>:6945): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

(<unknown>:6945): GLib-GObject-WARNING **: cannot register existing type `GstAudioresample'

(<unknown>:6945): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed Unable to load element 'audioresample'. Accessing missing option options.ui.notifications.send-receipts

(<unknown>:6945): GLib-GObject-WARNING **: cannot register existing type `GstVideoSink'

(<unknown>:6945): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(<unknown>:6945): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

можно ли как-нибудь это исправить?


Нужен gstreamer, gst-plugins-base, gst-plugins-good. Вот из-за отсутствия последнего у меня были подобные эффекты (догадался не сразу :) )

aix27249 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.