LINUX.ORG.RU

pcmanfm не отображает значки


0

1

Gentoo, OpenBox. При запуске pcmanfm высыпает кучу сообщений:

** (pcmanfm:2905): DEBUG: unable to load icon user-home

(pcmanfm:2905): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed ** (pcmanfm:2905): DEBUG: unable to load icon user-desktop

(pcmanfm:2905): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed ** (pcmanfm:2905): DEBUG: unable to load icon user-trash

(pcmanfm:2905): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed ** (pcmanfm:2905): DEBUG: unable to load icon system-software-install

(pcmanfm:2905): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed ** (pcmanfm:2905): DEBUG: unable to load icon . GThemedIcon drive-removable-media drive-removable drive

(pcmanfm:2905): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed ** (pcmanfm:2905): DEBUG: unable to load icon folder

(pcmanfm:2905): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed ** (pcmanfm:2905): DEBUG: unable to load icon . GThemedIcon folder inode-directory gnome-mime-inode-directory inode-x-generic

** (pcmanfm:2905): DEBUG: unable to load icon . GThemedIcon text-plain gnome-mime-text-plain text-x-generic application-x-executable

** (pcmanfm:2905): DEBUG: unable to load icon . GThemedIcon application-xml gnome-mime-application-xml text-html application-x-generic application-x-executable

** (pcmanfm:2905): DEBUG: unable to load icon . GThemedIcon application-x-xbel gnome-mime-application-x-xbel text-html application-x-generic application-x-executable

** (pcmanfm:2905): DEBUG: unable to load icon . GThemedIcon application-octet-stream gnome-mime-application-octet-stream application-x-generic

** (pcmanfm:2905): DEBUG: unable to load icon . GThemedIcon application-x-bzip-compressed-tar gnome-mime-application-x-bzip-compressed-tar package-x-generic application-x-generic

запускается и отображает одни подписи, без значков. Установил LXDE, там этой проблемы нет. Кто нибудь сталкивался?

Ответ на: комментарий от anonymous_sapiens

Да я уже и из оверлея ставил, потом обратно откатился. Бесполезно. Главное если логинюсь в LXDE, то там всё отображается как надо.

Captcha ()
Ответ на: комментарий от GotF

Ну точно, сменил тему, заработало. Я столько времени убил на это, а оказалось.... тьфу блин. Спасибо, друг :)

Captcha ()
Ответ на: комментарий от GotF

У меня новый Thunar 1.2.1 не отображает значки файлов и иконки значков запуска в Диспетчере настроек из тем GNOME-Dust, -Wise, -Wine и т.д., установленных в домашний каталог. Для тем «Среда GNOME», «Мгла», «Южный крест», установленных из портов, и темы «BlankOn» в домашнем каталоге всё отображается.

На всякий случай:

> pkg_info -Ex svg
librsvg2-2.32.1_1

То есть я делаю вывод: в выбранной теме не все иконки присуствуют. Вместо отсутствующих иконок отображается пустое пространство.

iZEN ★★★★★ ()
Ответ на: комментарий от iZEN

ОЧЕ некропост, но как ты решил проблему со значками?

Lighting ★★★★★ ()
Ответ на: комментарий от Xenon

Пардон, Тред на читаю @ сразу отвечаю. Не увидел, что решено.

Xenon ★★★ ()
Ответ на: комментарий от Xellos

Откатился на предыдущую версию gtk-2.0, помогло.

Xellos ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.