LINUX.ORG.RU

Нету звука после перехода на ALSA


0

0

Всем доброго времени суток!
Заранее извиняюсь если такой вопрос поднимался, но я ответа не нашёл.
У меня Ubuntu 9.10 и стоял раньше стандартный пульс, но он что то резко начал жрать по 300 метров памяти(для меня это не приемлемо, у меня её всего 768), и решил я установить ALSA вроде установил, но звук в системе не появился, а при открытии Система->Параметры->Звук выдаёт сообщение «Ожидание ответа звуковой подсистемы», но при этом скайп я настроил что могу вполне нормально звонить(ввод и вывод звука работает).
Помогите пожалуйста, а то скучно в тишине.
Заранее спасибо.

но он что то резко начал жрать по 300 метров памяти

Стандартный вопрос: как ты это определил?

Deleted ()

> стандартный пульс

пульс сам по себе звук не умеет проигрывать, это делает alsa в любом случае. его можно только 'выключить' и проигрывать напрямую через альсу.

системный утилиты рассчитаны на установку определённых программ - корячишь систему не рассчитывай что обычные средства будут работать.

Пользуйся alsamixer.

gena2x ★★★ ()
Ответ на: комментарий от gena2x

системный утилиты рассчитаны на установку определённых программ - корячишь систему не рассчитывай что обычные средства будут работать.

А xfce4-mixer подойдёт? Хотя какая разница, звука всё равно нет(
Причём система не ругается а типа воспроизводит, только одна тишина....

Ramzes001 ★★ ()
Ответ на: комментарий от Deleted

Стандартный вопрос: как ты это определил?

Просто система начала жестко виснуть, и тупить, я зашёл в системный монитор, отсортировал процессы по занимаемой памяти, и понял какая сволоч жрёт все ресурсы

Ramzes001 ★★ ()
Ответ на: комментарий от Ingvarr

это пример :)

Извиняюсь за безграмотность(просто подумал что он и не должен воспроизводить ни чего)
Ввёл путь, получил следующие: ramzes@ramzes-desktop:~$ aplay /media/d/музыка/01_kino_zvezda_po_imeni_solnce.mp3
Воспроизведение Сырые данные '/media/d/музыка/01_kino_zvezda_po_imeni_solnce.mp3' : Unsigned 8 bit, Частота 8000 Гц, Моно тоже тишина(

Ramzes001 ★★ ()
Ответ на: комментарий от Ramzes001

> Ввожу aplay blahblahblah.wav выдаёт blahblahblah.wav: No such file or directory

Вы прикалываетесь? Этот файл есть у всех.

andreyu ★★★★★ ()
Ответ на: комментарий от andreyu

Нет alsamixer выкрутил на максимум, всё равно тишина....
P.S. Ну не могу я понять почему скайп работает,а VLS с теме же настройками нет!

Ramzes001 ★★ ()
Ответ на: комментарий от Ramzes001

>Извиняюсь за безграмотность(просто подумал что он и не должен воспроизводить ни чего) Ввёл путь, получил следующие: ramzes@ramzes-desktop:~$ aplay /media/d/музыка/01_kino_zvezda_po_imeni_solnce.mp3 Воспроизведение Сырые данные '/media/d/музыка/01_kino_zvezda_po_imeni_solnce.mp3' : Unsigned 8 bit, Частота 8000 Гц, Моно тоже тишина(

aplay умеет только wav и еще несколько сырых форматов. mp3 в список доступных не входит.

TuxR ★★★★ ()
Ответ на: комментарий от TuxR

Он мусор всякий играет емнип. Звук есть, просто некрасивый

Unclown ()
Ответ на: комментарий от Ramzes001

> Нет alsamixer выкрутил на максимум, всё равно тишина....

А кнопку m на нужном канале нажимать пробовали?

P.S. Ну не могу я понять почему скайп работает,


Может скайп прямо в /dev/dsp пишет?

andreyu ★★★★★ ()
Ответ на: комментарий от Unclown

Я ни чего не понимаю! VLC начал работать когда я поставил «вывод аудио через UNIX OSS» Это значит что я где та накосячил?

Ramzes001 ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.