LINUX.ORG.RU

После удаления fglrx не стартуют исксы с драйвером radeon


0

0

Видеокарта ATI Radeon X1200, ОС - Slackware 12.2. Не стартуют иксы с драйвером radeon. До этого устанавливала драйвер fglrx таким способом:
sh ati-driver-installer-<version>.run --buildpkg Slackware/All потом installpkg то, что получилось, затем aticonfig --initial. Удалила с помощью removepkg (но похоже этого не достаточно :)) и заменила xorg.conf на старый
Вот что в конце /var/log/Xorg.0.log:
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed

Backtrace:
0: X(xf86SigHandler+0x7e) [0x80d8b5e]
1: [0xffffe400]
2: /usr/lib/xorg/modules/drivers//radeon_drv.so(RADEONDRIGetVersion+0x12b) [0xb7bf9d9b]
3: /usr/lib/xorg/modules/drivers//radeon_drv.so [0xb7bc983d]
4: /usr/lib/xorg/modules/drivers//radeon_drv.so(RADEONPreInit+0x9d5) [0xb7bcb945]
5: X(InitOutput+0x9b7) [0x80a2317]
6: X(main+0x296) [0x806dbb6]
7: /lib/libc.so.6(__libc_start_main+0xe0) [0xb7dc0390]
8: X(FontFileCompleteXLFD+0x20d) [0x806d121]

Fatal server error:
Caught signal 11. Server aborting

Как теперь исправить? Заранее спасибо

Re: После удаления fglrx не стартуют исксы с драйвером radeon

Может от fglrx остался ядрёный модуль?

Deleted ()

Re: После удаления fglrx не стартуют исксы с драйвером radeon

Может radeonhq попробовать?

kraw ★★★★ ()

Re: После удаления fglrx не стартуют исксы с драйвером radeon

Может перенастроить иксы следует (Xorg -configure)?

aydar ★★★★★ ()

Re: После удаления fglrx не стартуют исксы с драйвером radeon

нужно переустановить libGL.so.1
обычно пакет mesa


fglrx заменяет эти файлы

Sylvia ★★★★★ ()

Re: После удаления fglrx не стартуют исксы с драйвером radeon

В общем так.. Модуль не нашла, да и с другими ядрами тот же результат (и со слакваревскими и с самосборным) Пакет mesa-7.0.3-i486-1(этот?) был установлен. С драйвером radeonhd удалось загрузиться, но ужасно медленно все прорисовывается (тему и настройки xfce сменила на дефолтные - все равно). Осталось попробовать Xorg -configure.

Cigarettesmoker ()

Re: После удаления fglrx не стартуют исксы с драйвером radeon

Сделала:
Xorg -configure
cp ~/xorg.conf.new /etc/X11/xorg.conf
echo xterm > .xinitrc
Не помогло, вот xorg.conf:

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	RgbPath      "/usr/share/X11/rgb"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/TTF"
	FontPath     "/usr/share/fonts/OTF"
	FontPath     "/usr/share/fonts/Type1"
	FontPath     "/usr/share/fonts/misc"
	FontPath     "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
	Load  "GLcore"
	Load  "glx"
	Load  "dbe"
	Load  "extmod"
	Load  "dri"
	Load  "xtrap"
	Load  "record"
	Load  "type1"
	Load  "freetype"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"            	# [<bool>]
        #Option     "AccelMethod"        	# [<str>]
        #Option     "offscreensize"      	# [<str>]
        #Option     "SWcursor"           	# [<bool>]
        #Option     "ignoreconnector"    	# [<str>]
        #Option     "forcereduced"       	# [<bool>]
        #Option     "forcedpi"           	# <i>
        #Option     "useconfiguredmonitor" 	# [<bool>]
        #Option     "HPD"                	# <str>
        #Option     "NoRandr"            	# [<bool>]
        #Option     "RROutputOrder"      	# [<str>]
        #Option     "DRI"                	# [<bool>]
        #Option     "TVMode"             	# [<str>]
        #Option     "ScaleType"          	# [<str>]
        #Option     "UseAtomBIOS"        	# [<bool>]
        #Option     "AtomBIOS"           	# [<str>]
        #Option     "UnverifiedFeatures" 	# [<bool>]
	Identifier  "Card0"
	Driver      "radeonhd"
	VendorName  "ATI Technologies Inc"
	BoardName   "Radeon X1200 Series"
	BusID       "PCI:1:5:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Cigarettesmoker ()

Re: После удаления fglrx не стартуют исксы с драйвером radeon

Надо было еще пакет xorg-server переустановить) Спасибо всем)

Cigarettesmoker ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.