LINUX.ORG.RU

Проблема


0

0

Приветствую всех. Настраиваю свой модем Thompson SpeedTouch 330 под ALT Linux...вроде бы нашёл документации толковые ,нашел файлы нужные для установки, и возникла загвоздка значит распаковал пакет rp-pppoe-3.8...дальше делал по мануалу ..запустил там скрипт configure из под рута и вылезло вот что: checking for gcc... gcc checking for C compiler default output file name... configure: error: C compiler cannot create executables See `config.log' for more details.

разъясните пожалуйста что это значит...и как избавиться от данной проблемы...что за такой config.log и зачем туда смотреть:)

anonymous

Ответ на: комментарий от timth

Есть apt-get...менеджер пакетов показывает,что он установлен , но в списке программ его вроде бы и нет.. остаётся вопрос как его запустить?

даже если и запущу этот самый apt, чем он мне поможет? ведь rp-pppoe запакован в src.rpm

anonymous
()
Ответ на: комментарий от UVV

хмм...пишет, что нет такой команды..мож я что то неправильно делаю

блин..напишите пожалуйста кому не лень как можно подробнее как установить интернет PPPOE ADSL на альте...и вобще возможно ли это?

anonymous
()
Ответ на: комментарий от annoynimous

> отставить весь вышенаписанный крэп. Отца спасет команда adsl-setup
Извиняюсь, не сразу понял, что речь про адсл.
Команду нужно вводить под пользователем root!

UVV ★★★★★
()
Ответ на: комментарий от UVV

эта команда должна работать без сторонне установленных пакетов или нет? просто если скажем просто так ввести эту команду под рутом, то опять же ошибка о несуществовании команды, а если установить rp-pppoe(а там есть скрипт adsl-setup.in) и попытаться завести его из под рута то выдаёт такие вот ошибки...

/home/maks/RPM/SOURCES/rp-pppoe-3.5/scripts/adsl-setup.in: line 44: @ECHO@: command not found /home/maks/RPM/SOURCES/rp-pppoe-3.5/scripts/adsl-setup.in: line 45: @ECHO@: command not found /home/maks/RPM/SOURCES/rp-pppoe-3.5/scripts/adsl-setup.in: line 46: @ECHO@: command not found /home/maks/RPM/SOURCES/rp-pppoe-3.5/scripts/adsl-setup.in: line 47: @ECHO@: command not found /home/maks/RPM/SOURCES/rp-pppoe-3.5/scripts/adsl-setup.in: line 50: @ID@: command not found /home/maks/RPM/SOURCES/rp-pppoe-3.5/scripts/adsl-setup.in: line 51: @ECHO@: command not found

мне вообще интересно я в том направлении двигаюсь? на Альте установка интернета возможна только таким способом? и зависит ли способ установки от марки модема?

anonymous
()

apt-get update apt-get install rp-pppoe

от рута.

polachok
()

Загвоздка у вас в этом:
> и возникла загвоздка значит распаковал пакет rp-pppoe-3.8
Вам не нужны исходники. Вам нужно просто поставить пакет!
делается это командой rpm -i

UVV ★★★★★
()
Ответ на: комментарий от UVV

ну вот..я например установил пакет rp-pppoe-3.5-338.i586.rpm только не пойму, что с ним дальше делать?

anonymous
()
Ответ на: комментарий от anonymous

> ну вот..я например установил пакет rp-pppoe-3.5-338.i586.rpm только не пойму, что с ним дальше делать?

где ты этот пакет взял?

overmind88 ★★★★★
()
Ответ на: комментарий от overmind88

ссылка не сохранилась но не с репозиториев этот rp-pppoe-3.5-338.i586.rpm и ещё установить требует:

insserv is needed by rp-pppoe-3.5-338 devs is needed by rp-pppoe-3.5-338

с ним проехали..ладно

так..нашёл значит в репозитории Сизиф пакеты - вот они: rp-pppoe-base-3.7-alt2.i586.rpm rp-pppoe-client-3.7-alt2.i586.rpm rp-pppoe-gui-3.7-alt2.i586.rpm

вижу теперь в папке system:/media/hda3/usr/sbin скрипты pppoe-setup pppoe-connect pppoe-start pppoe-stop pppoe-status что дальше? их ли нужно запускать и если да то каким образом?

anonymous
()
Ответ на: комментарий от overmind88

почему не ставлю? а откуда я взял то, что в последнем своём посте написал? :) вы мне лучше подскажите как ADSL соединение установить, что и где скачать? какую программу использовать для соединения

anonymous
()

Ты хоть скажи, что у тебя за дистрибутив.

jackill ★★★★★
()

Я настраивал этот модем в openSuSe 10.2

к стати, собирал утилиты из исходников, возможно я настраивал по тому же мануалу что и ты. Очевидно для сборки не хватает каких-то файлов (зависимость). Как тебе советовали выше лучше поставить пакет с утилитами, зависимости будут автоматически разрешены (я разрешал их сам, первый дистр шлакваре :).

была еще пара подводных камней, даже пришлось пресобирать ядро, в дефолтовом конфиге не была включена опция поддержки USBFS.

gnomino
()

Да, не оветил на второй вопрос config.log -- лог конфигурирования сборки программы, создается во время выполнения скрипта configure, находится в той же дирректории, если хочешь его посмотреть: less config.log

gnomino
()
Ответ на: комментарий от gnomino

У меня ALT Linux, в первом посте кстати написано:)

>>>к стати, собирал утилиты из исходников, возможно я настраивал по тому же мануалу что и ты. Очевидно для сборки не хватает каких-то файлов (зависимость). Как тебе советовали выше лучше поставить пакет с утилитами, зависимости будут автоматически разрешены

Да где ж пакет этот найти, подскажите название:) и пожалуйста распишите как что дальше с ним делать...просто интернет на Линуксе позарез нужен для дальнейшего изучения Линукса...а так бегать с винды на Линукс, чтобы проверять каждую деталь очень выматывает..

anonymous
()
Ответ на: комментарий от anonymous

Значит на линуксе нет тырнета. Это усложняет проблему. Суть в том, что у каждого дистрибутива Линукс есть сетевые хранилища софта -- репозитарии. Они прописывабтся в настройках программы менеджера пакетов. Для того что бы поставить какую-либо программу тебе надо только знать ее название, и указать менеджеру, что ты ее хочешь установить, если для этой программы требуется что-то еще, то менеджер докачивает это из интернета автоматически. rp-pppoe -- часть названия пакета, тебе налдо его скачать из пера ALT-а, http://mirror.yandex.ru/ -тут есть один из репов. можешь окрыть пакет менеджером, там где-то (я не знаю, Альтом не пользовался, но это есть везде), будет список зависимостей, просто докачаешь те пакеты которых в системе нет.

gnomino
()
Ответ на: комментарий от gnomino

ок сейчас попробую...

s/пера/репа/ ALT-а это что такое?

и ещё вопросик, когда я найду все пакеты и установлю, то каким образом их запускать?

anonymous
()
Ответ на: комментарий от anonymous

>s/пера/репа/ ALT-а это что такое?

В предыдущем сообщении этого оратора надо читать "репа" вместо "пера"

>каким образом их запускать?

Писали выше

manntes ★★
()
Ответ на: комментарий от anonymous

эх.... У тебя есть мануал? Делай как там написано.

Пакет -- несколько файлов собраные в один архив + служебная информация, список зависимостей, например.

ЗЫ s/// -- функция замены

gnomino
()
Ответ на: комментарий от manntes

>>>каким образом их запускать?

>>>Писали выше

писали же вроде только про инсталяциию, про запуск что-то я не долглядел, если можно повторите...

не репозитории есть три файла

rp-pppoe-base-3.7-alt2.i586.rpm rp-pppoe-client-3.7-alt2.i586.rpm rp-pppoe-gui-3.7-alt2.i586.rpm

они все у меня проинсталированны по показаниям менеджера, и программы зависимости от них тоже установлены? что осталось сделать чтобы непосредственно установить подключение?

anonymous
()
Ответ на: комментарий от anonymous

вопрос на засыпку:

Фирмваре скачал?

кинь ссылку на твой мануал, разве там пошагово не написано как устанавливать драйвера и настраивать подключение?

gnomino
()
Ответ на: комментарий от anonymous

> что осталось сделать чтобы непосредственно установить подключение?
Запустить в консоли из-под пользователя root команду adsl-setup

UVV ★★★★★
()
Ответ на: комментарий от gnomino

>>>Фирмваре скачал?

Всмысле для своего модема? у меня есть какой то SpeedTouch330_firmware_3012 ..это оно?

anonymous
()
Ответ на: комментарий от overmind88

pppoe-setup работает:) щас с настройками разбираюсь

Enter the Ethernet interface connected to the ADSL modem здесь нужно вводить eth0 или для USB модема что то другое необходимо? (модем Thomson SpeedTouch 330 USB)

anonymous
()
Ответ на: комментарий от overmind88

overmind88, спасибо большое за ссылку

Вобщем прошёлся по этому мануалу, дошёл до последнего пункта..до него всё получалось. Значит,после вызова su пишу:

cp speedtch-{1,2}.bin /lib/firmware && install -m 744 br2684ctl /usr/sbin && install -m400 speedtch /etc/ppp/peers && install -m400 secrets /etc/ppp/chap-secrets && install -m400 secrets /etc/ppp/pap-secrets && install -m744 dial /etc/init.d/dial && insserv dial && rm -f /etc/init.d/rc5.d/K*dial

Вылезает сообщение: bash: insserv: command not found

где моя ошибка?

anonymous
()
Ответ на: комментарий от anonymous

gnomino, вы кажется говорили, что настраивали по данному мануалу, в чем же дело? почему insserv: command not found

anonymous
()
Ответ на: комментарий от anonymous

Давненько это было, да и обрати внимание, я настраивал сусю и мануал дя суси, в этом проблем небыло, да и настраивал я не совсем по мануалу. Сейчас помню только общий смысл и то в чем у меня были проблемы.

Insserv - Enable an installed system init script -- сделай это средствами своего дистрибутива, комманда видимо для суси.

gnomino
()
Ответ на: комментарий от anonymous

Это первая строка мануала, те этой командой ты прописываешь запуск скрипта в автозагрузку, сделай это средствами твоего дистрибутива.

gnomino
()
Ответ на: комментарий от gnomino

а..ну то есть получается, что эта команда влияет на то, будет ли интернет подключаться сразу при входе в систему? и мне нужно найти аналог этой команды на ALT Linux ? я правильно вас понял?

anonymous
()
Ответ на: комментарий от anonymous

Понял правильно. в ALT Linux есть нверное какой-нить гуй (с кнопочками и галочками), для настройки автозапуска.

Мне кажется что ты упираешься в несуществующую стену, а ты уверен что все нормально? запусти скрипт ручками, подключится инет или нет? Когда все будет работать, вот тогда в автозапуск и кинешь.

ЗЫ Здесь принято к друг другу на ты

gnomino
()
Ответ на: комментарий от gnomino

>ЗЫ Здесь принято к друг другу на ты

как пожелаешь...

>Мне кажется что ты упираешься в несуществующую стену

о чём это ты?

думаю, я здесь уже ничего нового не узнаю...буду ждать ответа с техподдержки, может, там что - нибудь нового скажут

Всем большое спасибо за помощь и терпеливость.

anonymous
()
Ответ на: комментарий от anonymous

>буду ждать ответа с техподдержки

Обычно техподдержка линуксоидов шлет лесом, по себе знаю, пару раз послали, больше уже не обращался :)

>о чём это ты?

о том что ты пытаешся установить в систему скрипт, но не знаешь работает ли он, те скорее всего проходишь мимо проблемы которая есть на самом деле, а зациклился на мелочи.

Запусти скрипт, если подключение подымется, значит все шорошо, но, я почти уверен, что ничего не заработает :)

>здесь уже ничего нового не узнаю

сильно сказал :)

gnomino
()
Ответ на: комментарий от gnomino

gnomino, мда действительно послали:) эх...что же делать...есть ещё варианты?

anonymous
()
Ответ на: комментарий от anonymous

>почему insserv: command not found

я уже объяснил, эту "ошибку" пока можно не учитыать.

В чем еще проблемы? Ты скрипты запкскать пытался? Интерфейс nas0 появляется? Или тупо все копи-пастишь по мануалу.

ЗЫ модем работал отлично, да и настраивал я не долго, проблема у меня была в ядре и неправильной сылке.

gnomino
()
Ответ на: комментарий от gnomino

>Интерфейс nas0 появляется?

а где он должен появиться?

ну естественно копи пастю, пока что у меня другого варианта как бы и нет...

anonymous
()
Ответ на: комментарий от anonymous

Значит будут проблемы :(

Рекомендую разобрать каждую сторчку из скриптов (man command), если не будешь понимать что делаешь, будешь плутать в трех соснах.

PS dmesg|grep firmware --запости вывод?

gnomino
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.