LINUX.ORG.RU

FreeBSD4.5+XFree4.1.0


0

0

Прописал в /etc/X11/XF86Config

Option  "XkbRules"  "xfree86"
        Option      "XkbModel"  "pc105"
        Option      "XkbLayout" "ru"
        Option      "XkbVariant" "winkeys"
        Option      "XkbOptions" "grp:ctrl_shift_toggle"

+ русские шрифты.

Русский беспроблемно отображатся, а переключатель раскладок не работает :( в лог пишет: 

(II) Keyboard "Keyboard0" handled by legacy driver
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
Couldn't load XKB keymap, falling back to pre-XKB keymap

Как можно побороть?
anonymous

Re: FreeBSD4.5+XFree4.1.0

Убери
Option "XkbVariant" "winkeys"
будет переключаться по ctrl+shift

anonymous ()

Re: FreeBSD4.5+XFree4.1.0

блин я только щас заметил что до сих пор работаю с xmodmap - и проблем нисчем нет (правда я ничего кроме xterm/xemacs/netscape и не использую) :) xmodmap - рулит, xkb - тоже рулит, mail.ru - говно!

lg ★★ ()

Re: FreeBSD4.5+XFree4.1.0

Локаль не настроена - сходите на http://www.freebsd.org.ru на первую старницу - там доходчивое и полное описание, и без нормальной локали xkb не заработают.

gennik ()

Re: FreeBSD4.5+XFree4.1.0

hey lg Please send your .Xmodmap to sadjyg@SLACKWAREnm.ru minus distro. Regards!

about question: maybe

Option "XkbLayout" "ru(winkeys)"

instead

Option "XkbLayout" "ru"
Option "XkbVariant" "winkeys"
?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.