LINUX.ORG.RU

Upgrade системы amd64

 ,


0

1

После длительных манипуляций с обновлениями выяснил, что моё железо полноценно работает только с одним ядром 5.8.0-43 (Ubuntu Focal 20.04 LTS, ASUS X555L, AMD64). Проблемы с WiFi/Bluetooth на плате Mediatek MT7630E. Пробовал ядра 5.12, 5.13, но все безуспешно (не находит требуемые header-файлы), либо не работает и не переустанавливается Bluetooth, либо целиком WiFi (на плате эти функции интегрированы). Сейчас пытаюсь удалить все установочные (и иные) файлы этих неиспользуемых версий установленных ядер, делаю это, например, по гайду https://losst.ru/kak-udalit-starye-versii-yadra-v-ubuntu через Synaptic (буду пытаться, пока достаточного опыта нет), и задаюсь вопросом:

как «жить» дальше, как и когда обновляться, удастся ли когда-либо обновить систему к новой LTS 22.04?

В кратце история «болезни»: однажды не смог установить PgAdmin4 к Postgres, репозиторий оказался не рабочим или что-то сделал не так. В итоге перестал работать Software & Updates, просто не открывался вообще. Не нашел никаких способов и пришлось достать LiveUSB, с которого начинал, и установить систему поверх (без удалений и форматирования). Но включил автообновление, и в итоге получил 5.13, в которой железо отказывалось работать.

Теперь загружаюсь через Дополнительные опции загрузки с выбором своего рабочего ядра.

Прошу помочь советами: как правильно проводить обновления в Ubuntu Linux, особенно, через встроенный Software Updater, автозапуск которого просто не нахожу возможности отключить.


Сейчас пытаюсь удалить все установочные (и иные) файлы этих неиспользуемых версий установленных ядер, делаю это, например, по гайду

Не надо читать графоманские статьи. Убунту это пересборка дебиана (и кстати, желательно дебиан и установить а не это). Удаление пакетов делается так:

apt-get purge пакет1 пакет2 ...
Посмотреть список установленных пакетов можно так:
dpkg -l
С ядром связаны те, названия которых начинаются на linux-image или linux-headers - выбирай ненужные и удаляй. Туда же удаляй всякие «software updater»-ы чтобы не мешали.

В кратце история «болезни»: однажды не смог установить PgAdmin4 к Postgres, репозиторий оказался не рабочим или что-то сделал не так.

Если не разбираешься - никогда не устанавливай никакой софт, кроме как командой apt-get install или apt install. И не будет проблем. Гайды в инете, с советами что-то скачивать с каких-то сайтов и запускать с root правами (командой sudo), опять часто вредительские.

firkax ★★ ()
Последнее исправление: firkax (всего исправлений: 1)

Есть и проблемы с чисткой, попробуй вычиститься, например, при выборе в Synaptic ядра:

Linux kernel extra modules for version 5.12.11 on 64 bit x86 SMP

получаю предупреждения:

Contains the corresponding System.map file, the modules built by the
packager, and scripts that try to ensure that the system is not left in an
unbootable state after an update.

Supports Generic processors.

Geared toward desktop and server systems.

You likely do not want to install this package directly. Instead, install
the linux-generic meta-package, which will ensure that upgrades work
correctly, and that supporting packages are also installed.

сломаю GRUB/EFI, как пить дать. Что и как тут делать? Удаляю не старое ядро, а наоборот «более свежее».

mkaro ()
Ответ на: комментарий от firkax

Пытаюсь, конечно, разобираться, знаю о возможных проблемах, кроме apt практически больше ничем не устанавливаюсь, но вот так получается… нужна практика всегда.

В чистке реально чувствую себя неуверенно, боюсь сломать все одним махом. У меня такая картинка:

mkaro@asus:~$ apt list --installed | egrep "linux-image|linux-headers"

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

linux-headers-5.12.11-051211/now 5.12.11-051211.202106161201 all [installed,local]
linux-headers-5.13.0-39-generic/focal-updates,focal-security,now 5.13.0-39.44~20.04.1 amd64 [installed]
linux-headers-5.8.0-43-generic/focal-updates,focal-security,now 5.8.0-43.49~20.04.1 amd64 [installed]
linux-headers-generic-hwe-20.04/focal-updates,focal-security,now 5.13.0.39.44~20.04.24 amd64 [installed,automatic]
linux-image-5.13.0-39-generic/focal-updates,focal-security,now 5.13.0-39.44~20.04.1 amd64 [installed,automatic]
linux-image-5.8.0-43-generic/focal-updates,focal-security,now 5.8.0-43.49~20.04.1 amd64 [installed,automatic]
linux-image-generic-hwe-20.04/focal-updates,focal-security,now 5.13.0.39.44~20.04.24 amd64 [installed,automatic]
linux-image-unsigned-5.12.11-051211-generic/now 5.12.11-051211.202106161201 amd64 [installed,local]

Хочу удалить все, кроме 5.8.0.43, но есть еще и другие версии рядом (39,49,53), о которых Synaptic вообще ничего не «говорит»:

mkaro@asus:~$ ls -la /boot/
total 659685
drwxr-xr-x  4 root root      4096 Apr 14 21:50 .
drwxr-xr-x 22 root root      4096 Apr 10 17:50 ..
-rw-r--r--  1 root root    253744 Jun 16  2021 config-5.12.11-051211-generic
-rw-r--r--  1 root root    257735 Mar 24 19:27 config-5.13.0-39-generic
-rw-r--r--  1 root root    248291 Feb  5  2021 config-5.8.0-43-generic
-rw-r--r--  1 root root    248245 Mar 26  2021 config-5.8.0-49-generic
-rw-r--r--  1 root root    248270 May  6  2021 config-5.8.0-53-generic
drwx------  3 root root      1024 Jan  1  1970 efi
drwxr-xr-x  4 root root      4096 Apr 14 21:00 grub
lrwxrwxrwx  1 root root        33 Apr 14 21:00 initrd.img -> initrd.img-5.12.11-051211-generic
-rw-r--r--  1 root root  98393022 Apr 14 21:00 initrd.img-5.12.11-051211-generic
-rw-r--r--  1 root root 104644766 Apr 14 21:50 initrd.img-5.13.0-39-generic
-rw-r--r--  1 root root 104645507 Apr 10 20:30 initrd.img-5.13.0-39-generic.old-dkms
-rw-r--r--  1 root root  84911077 Apr 14 21:50 initrd.img-5.8.0-43-generic
-rw-r--r--  1 root root  84910685 Apr 14 21:50 initrd.img-5.8.0-43-generic.old-dkms
-rw-r--r--  1 root root  13351450 Apr 10 19:16 initrd.img-5.8.0-49-generic
-rw-r--r--  1 root root  86434144 Apr 21  2021 initrd.img-5.8.0-49-generic.old-dkms
-rw-r--r--  1 root root  13351456 Apr 10 19:16 initrd.img-5.8.0-53-generic
lrwxrwxrwx  1 root root        28 Apr 14 21:00 initrd.img.old -> initrd.img-5.13.0-39-generic
-rw-r--r--  1 root root    182704 Aug 18  2020 memtest86+.bin
-rw-r--r--  1 root root    184380 Aug 18  2020 memtest86+.elf
-rw-r--r--  1 root root    184884 Aug 18  2020 memtest86+_multiboot.bin
-rw-------  1 root root   6020860 Jun 16  2021 System.map-5.12.11-051211-generic
-rw-------  1 root root   5963072 Mar 24 19:27 System.map-5.13.0-39-generic
-rw-------  1 root root   5515823 Feb  5  2021 System.map-5.8.0-43-generic
-rw-------  1 root root   5531453 Mar 26  2021 System.map-5.8.0-49-generic
-rw-------  1 root root   5531695 May  6  2021 System.map-5.8.0-53-generic
lrwxrwxrwx  1 root root        30 Apr 14 21:00 vmlinuz -> vmlinuz-5.12.11-051211-generic
-rw-------  1 root root  14954688 Jun 16  2021 vmlinuz-5.12.11-051211-generic
-rw-------  1 root root  10174400 Mar 24 19:34 vmlinuz-5.13.0-39-generic
-rw-r--r--  1 root root   9716672 Feb  9  2021 vmlinuz-5.8.0-43-generic
-rw-------  1 root root   9786496 Mar 26  2021 vmlinuz-5.8.0-49-generic
-rw-------  1 root root   9789856 May  6  2021 vmlinuz-5.8.0-53-generic
lrwxrwxrwx  1 root root        25 Apr 14 21:00 vmlinuz.old -> vmlinuz-5.13.0-39-generic

mkaro ()
Ответ на: комментарий от mkaro

Удаляю не старое ядро, а наоборот «более свежее».

при загрузке линухи выбери нужное ядро, потом со спокойной душой удали лишние.

ну и посмотреть в сторону самосборного ядра.

pfg ★★★★★ ()
Последнее исправление: pfg (всего исправлений: 1)
Ответ на: комментарий от pfg

А вот можно ли рассчитывать, что она оправданно может быть «спокойной»… Вот объясните, какие файлы и где (чем) выбирать для удаления. Понимаю, вешаю свою работу на других)), нет, так не хочу, за все буду отвечать сам.

mkaro ()
Ответ на: комментарий от mkaro

что пишет

apt-get purge linux-headers-5.12.11-051211 linux-headers-5.13.0-39-generic linux-headers-generic-hwe-20.04 linux-image-5.13.0-39-generic linux-image-generic-hwe-20.04 linux-image-unsigned-5.12.11-051211-generic
?

firkax ★★ ()
Ответ на: комментарий от firkax

apt-get purge дает запрос на подтвеждение удаления «Y/n», точно?

mkaro ()
Ответ на: комментарий от mkaro

Дурное дело нехитрое. Махнуть всегда успеешь. Сначала четко для себя определись, обновлять или не обновлять. Если продолжишь обновлять, то и незачем затевать эту возню. Если не обновлять, то ядро 5.8* - это примерно *бунту 20.04.2. Быстрей, проще и надежней установить ее вчистую.

andytux ★★★ ()
Ответ на: комментарий от andytux

Наверно, соглашусь! Это правильное решение, тоже так думаю. А может поэкспериментировать, всяко опыт? Удаляться, так с музыкой).

mkaro ()
Ответ на: комментарий от andytux

Быстрей, проще и надежней установить ее вчистую.

Нет.

Быстрее и проще сделать apt-get purge.

Надёжней - забыть убунту как страшный сон и установить дебиан.

firkax ★★ ()
Ответ на: комментарий от andytux

Конечно, я хотел бы оставить для себя возможность будущих апгрейдов, надо идти в ногу со временем. Но мое железо пока понимает только этот один релиз, не получается ни с каким другим, пока. Баг в софте с этим Mediatek. Пишут о нем, и проблема пока не решена. Просто интересно сейчас разобраться с чисткой и обновлениями как можно глубже на будущее. Вопросы все задаю здесь.

mkaro ()
Ответ на: комментарий от mkaro

Тоже дело, особенно, если есть бэкап. Впрочем, если-бы он был, то и вопрос не стоял.

andytux ★★★ ()
Ответ на: комментарий от mkaro

Да, есть, конечно же, запрос на подтверждение. Попробовал пока так:

mkaro@asus:~$ apt-get purge linux-headers-5.12.11-051211
E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
mkaro@asus:~$ sudo apt-get purge linux-headers-5.12.11-051211
[sudo] password for mkaro: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  linux-headers-5.12.11-051211*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 74.9 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.

mkaro ()
Ответ на: комментарий от firkax
mkaro@asus:~$ sudo apt-get purge linux-headers-5.12.11-051211 linux-headers-5.13.0-39-generic linux-headers-generic-hwe-20.04 linux-image-5.13.0-39-generic linux-image-generic-hwe-20.04 linux-image-unsigned-5.12.11-051211-generic
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  amd64-microcode intel-microcode iucode-tool linux-hwe-5.13-headers-5.13.0-39 thermald
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  linux-image-unsigned-5.13.0-39-generic
Suggested packages:
  fdutils linux-doc | linux-hwe-5.13-source-5.13.0 linux-hwe-5.13-tools linux-headers-5.13.0-39-generic linux-modules-extra-5.13.0-39-generic
The following packages will be REMOVED:
  linux-generic-hwe-20.04* linux-headers-5.12.11-051211* linux-headers-5.13.0-39-generic* linux-headers-generic-hwe-20.04* linux-image-5.13.0-39-generic*
  linux-image-generic-hwe-20.04* linux-image-unsigned-5.12.11-051211-generic* linux-modules-5.12.11-051211-generic* linux-modules-extra-5.13.0-39-generic*
The following NEW packages will be installed:
  linux-image-unsigned-5.13.0-39-generic
0 upgraded, 1 newly installed, 9 to remove and 0 not upgraded.
Need to get 10.1 MB of archives.
After this operation, 789 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.

И что делать?

mkaro ()
Последнее исправление: mkaro (всего исправлений: 1)
Ответ на: комментарий от mkaro

да. хотя свое ядро потребует собственноручной поддержки.

pfg ★★★★★ ()
Ответ на: комментарий от mkaro

Ту же инфо дает и Synaptic. «Говорит», что linux-image-unsigned-5.13.0-39-generic переставит (to reinstall). А зачем?…

Попробую, наверно, ради эксперимента, получится ли, что получится. Переставить можно, бэкапов нет, но все «своё», конечно, держу в загажнике (отдальная partition).

mkaro ()
Ответ на: комментарий от firkax

Есть. Вот в исходниках:

mkaro@asus:~$ sudo ls -la /usr/src
total 84
drwxr-xr-x 21 root root 4096 Apr 14 21:39 .
drwxr-xr-x 14 root root 4096 Feb  9  2021 ..
drwxr-xr-x  2 root root 4096 Apr 14 21:37 btusb-4.0
drwxr-xr-x 23 root root 4096 Apr 14 21:00 linux-headers-5.12.11-051211
drwxr-xr-x 24 root root 4096 Apr  9 19:01 linux-headers-5.13.0-39
drwxr-xr-x  7 root root 4096 Apr 10 18:02 linux-headers-5.13.0-39-generic
drwxr-xr-x 24 root root 4096 Apr 10 15:36 linux-headers-5.4.0-107
drwxr-xr-x  7 root root 4096 Apr 10 15:36 linux-headers-5.4.0-107-generic
drwxr-xr-x  7 root root 4096 Feb  5  2021 linux-headers-5.8.0-41-generic
drwxr-xr-x  7 root root 4096 Feb  9  2021 linux-headers-5.8.0-43-generic
drwxr-xr-x  7 root root 4096 Mar 14  2021 linux-headers-5.8.0-44-generic
drwxr-xr-x  7 root root 4096 Apr 14  2021 linux-headers-5.8.0-49-generic
drwxr-xr-x  7 root root 4096 May 20  2021 linux-headers-5.8.0-53-generic
drwxr-xr-x 24 root root 4096 Apr 10 18:02 linux-hwe-5.13-headers-5.13.0-39
drwxr-xr-x 24 root root 4096 Feb  5  2021 linux-hwe-5.8-headers-5.8.0-41
drwxr-xr-x 24 root root 4096 Feb  9  2021 linux-hwe-5.8-headers-5.8.0-43
drwxr-xr-x 24 root root 4096 Mar 14  2021 linux-hwe-5.8-headers-5.8.0-44
drwxr-xr-x 24 root root 4096 Apr 14  2021 linux-hwe-5.8-headers-5.8.0-49
drwxr-xr-x 24 root root 4096 May 20  2021 linux-hwe-5.8-headers-5.8.0-53
drwxr-xr-x  8 root root 4096 Apr 10 16:45 mt7630e-2.1.0
drwxr-xr-x  2 root root 4096 Apr  9 19:02 tp_smapi-0.43
mkaro ()
Ответ на: комментарий от andytux

Дебиан отличается тем, что от него не несёт костылями за километр. Это не локализовано в каком-то конкретном месте, это везде, в каждой мелочи.

firkax ★★ ()
Ответ на: комментарий от firkax
mkaro@asus:~$ dpkg -l | grep -F linux-hwe
ii  linux-hwe-5.13-headers-5.13.0-39              5.13.0-39.44~20.04.1                        all          Header files related to Linux kernel version 5.13.0
ii  linux-hwe-5.8-headers-5.8.0-43                5.8.0-43.49~20.04.1                         all          Header files related to Linux kernel version 5.8.0
mkaro ()
Ответ на: комментарий от mkaro

Вобщем тогда так

  1. apt-get install linux-image-unsigned-5.8.0-43-generic

Он предложит установить один этот пакет по идее и больше ничего, если так то соглашайся.

  1. apt-get purge purge linux-headers-5.12.11-051211 linux-headers-5.13.0-39-generic linux-headers-generic-hwe-20.04 linux-image-5.13.0-39-generic linux-image-generic-hwe-20.04 linux-image-unsigned-5.12.11-051211-generic linux-hwe-5.13-headers-5.13.0-39

Он предложит удалить ровно те пакеты, что указаны в командной строке, и не будет предлагать ничего устанавливать взамен - если так то соглашайся.

firkax ★★ ()
Ответ на: комментарий от mkaro

Не знаю, я просто качал официальный iso установщика и ставил с него (выбирал текстовый режим установщика но наверно это не важно).

А вообще тут какие-то гайды для новичков есть https://www.debian.org/doc/

firkax ★★ ()
Ответ на: комментарий от firkax

Ok. Спасибо. Ну вот все сломаю или терпение кончится (на баги разного толка в Убунте натыкаюсь регулярно) и посмотрю. Debian у меня на гипервизоре Proxmox, все норм. Но только без десктопов всяких.

mkaro ()
Ответ на: комментарий от mkaro

Не знаю, думаю какая-то ерунда с secure boot. Ставить чисто потому что иначе он захочет вот это:

The following NEW packages will be installed:
linux-image-unsigned-5.13.0-39-generic

firkax ★★ ()
Ответ на: комментарий от firkax

В общем, логика понятна. Установщик должен собрать все компоненты (не знаю какие), которые ему требуются… Почему только на LiveUSB их не оказалось, вопрос. И буду ли жить после чистки.

Если меня долго не будет, значит ставлю все с полным форматом.

С EFI не хочется возиться, много времени на него потратил в первый раз. Можно как-нибудь подстраховаться?

Спасибо за информацию, коллеги!

mkaro ()
Ответ на: комментарий от firkax

Такая картинка на первой команде. Хочет удалить 5.8.0.43-generic (то, что мне и жизненно необходимо) и установить unsigned! Что за ерунда.

mkaro@asus:~$ sudo apt-get install linux-image-unsigned-5.8.0-43-generic
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  fdutils linux-doc | linux-hwe-5.8-source-5.8.0 linux-hwe-5.8-tools
The following packages will be REMOVED:
  linux-image-5.8.0-43-generic
The following NEW packages will be installed:
  linux-image-unsigned-5.8.0-43-generic
0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
Need to get 9,503 kB of archives.
After this operation, 212 kB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.
mkaro ()
Ответ на: комментарий от mkaro

Значит «unsigned» это не просто какой-нибуь security. Если я в Synaptic запрашиваю удаление одного ядра, например, linux-image-5.12, то для удаления выбираются все файлы с 5.12. А с 5.13 не так, еще запрашивает установку «unsigned».

Пишут:

linux-image-unsigned это не подписанное ядро.

и еще

... по зависимостям тянется. Не надо ничего удалять. Со временем само почистится.
apt-get autoremove --purge достаточно.

А что удалит apt-get autoremove –purge?

mkaro ()
Ответ на: комментарий от mkaro

Тогда попробуй

apt-get purge purge linux-headers-5.12.11-051211 linux-headers-5.13.0-39-generic linux-headers-generic-hwe-20.04 linux-image-5.13.0-39-generic linux-image-generic-hwe-20.04 linux-image-unsigned-5.12.11-051211-generic linux-hwe-5.13-headers-5.13.0-39 linux-image-unsigned-5.13.0-39-generic

firkax ★★ ()
Ответ на: комментарий от firkax

Получше вроде:

mkaro@asus:~$ sudo apt-get purge linux-headers-5.12.11-051211 linux-headers-5.13.0-39-generic linux-headers-generic-hwe-20.04 linux-image-5.13.0-39-generic linux-image-generic-hwe-20.04 linux-image-unsigned-5.12.11-051211-generic linux-hwe-5.13-headers-5.13.0-39 linux-image-unsigned-5.13.0-39-generic
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'linux-image-unsigned-5.13.0-39-generic' is not installed, so not removed
The following packages were automatically installed and are no longer required:
  amd64-microcode intel-microcode iucode-tool nvidia-kernel-common-470 thermald
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  linux-generic-hwe-20.04* linux-headers-5.12.11-051211* linux-headers-5.13.0-39-generic* linux-headers-generic-hwe-20.04* linux-hwe-5.13-headers-5.13.0-39*
  linux-image-5.13.0-39-generic* linux-image-generic-hwe-20.04* linux-image-unsigned-5.12.11-051211-generic* linux-modules-5.12.11-051211-generic*
  linux-modules-5.13.0-39-generic* linux-modules-extra-5.13.0-39-generic* linux-modules-nvidia-470-5.13.0-39-generic* linux-modules-nvidia-470-generic-hwe-20.04*
  linux-signatures-nvidia-5.13.0-39-generic*
0 upgraded, 0 newly installed, 14 to remove and 0 not upgraded.
After this operation, 975 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.

только REMOVE. Еще смущает nvidia. Неужели не нужен.

mkaro ()
Ответ на: комментарий от pfg

ну и посмотреть в сторону самосборного ядра.

Он даже с пакетами пока не разобрался, какое ещё самосборное ядро?

Dimez ★★★★★ ()
Ответ на: комментарий от firkax

Надёжней - забыть убунту как страшный сон и установить дебиан.

Хорош уже гнать пургу. Системы практически одинаковы, пакеты собраны чуть по-разному (debian более аскетичным можно сделать, ubuntu немного более «жирная»)

Dimez ★★★★★ ()
Ответ на: комментарий от Dimez

Посмотреть туда… человек советует самому собрать ядро. Да, я конечно, не разобрался с такими задачками. Вы опытный человек, вижу, подскажите с чисткой. Последний наш путь (firkax) Upgrade системы amd64 (комментарий)

mkaro ()
Ответ на: комментарий от mkaro

для неопытного пользователя посоветую работать с пакетами через aptitude. интерактивная оболочка упрощает работу.

pfg ★★★★★ ()
Ответ на: комментарий от mkaro

Мне сложно сейчас с телефона подсказывать. Если дождёшься до вечера (когда я буду дома) и вопрос не решится (или система не убьётся, что не хотелось бы), то посмотрю внимательно с большой диагонали.

Dimez ★★★★★ ()
Ответ на: комментарий от pfg

Возьму на заметку. https://www.cyberithub.com/how-to-install-aptitude-command-on-ubuntu-debian-with-examples/

Пока у меня все работает, и WiFi, и Bluetooth. Пишу в чат и слушаю любимого Ангус Янга, все в порядке. Сейчас обязательно нажму apt-get purge.

Даже после перезагрузки, чего раньше с другими ядрами ну никак не добиться, обязательно что-нибудь упадет.

mkaro ()
Последнее исправление: mkaro (всего исправлений: 1)
Ответ на: комментарий от Dimez

Еще немножко посоветуюсь… думаю, мы на правильном пути. В крайнем случае, уж точно все почищу)). Спасибо. Если что, еще будут вопросы).

mkaro ()

Звучит как непростая железная проблема и необходимость (самя натуральная) освоить сборку ядра руками. Для начала по гентушному мануалу (но без genkernel), и это не так страшно как звучит, ведь пакетные дистрибутивы обязательно собержат конфиг и сорцы к каждой собранной версии ядра.

kirill_rrr ★★★★★ ()
Ответ на: комментарий от kirill_rrr

Т.е. у меня путь двигаться дальше только через самосборное ядро или с заменой asus wifi железок. Прикольно, незавидная участь.

И все-таки пока про чистку.

Попробую двумя шагами. Synaptic почему-то видит, но не всё. К 5.12 есть header-ы (/usr/src), а Synaptic про них ничего не говорит.

Итак, у меня 3 ядра:

mkaro@asus:~$ ls -la /lib/modules
total 20
drwxr-xr-x   5 root root 4096 Apr 14 20:59 .
drwxr-xr-x 132 root root 4096 Apr 14 21:43 ..
drwxr-xr-x   5 root root 4096 Apr 14 21:39 5.12.11-051211-generic
drwxr-xr-x   5 root root 4096 Apr 14 21:49 5.13.0-39-generic
drwxr-xr-x   6 root root 4096 Apr 15 01:01 5.8.0-43-generic

Задача: оставить только одно 5.8.0.43.

Первым шагом: удаляю через apt-get purge 5.12.

Насколько я понимаю, разницы между apt-get и apt нет.

На вопрос почему не предлагает подрелизы (39,49,53), возможно, они все-таки нужны:

mkaro@asus:~$ uname -a
Linux asus 5.8.0-43-generic #49~20.04.1-Ubuntu SMP Fri Feb 5 09:57:56 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
mkaro@asus:~$ uname -r
5.8.0-43-generic

какой-то хвостик #49…

Жму:

mkaro@asus:~$ sudo apt purge linux-headers-5.12.11-051211 linux-image-unsigned-5.12.11-051211-generic
Waiting for cache lock: Could not get lock /var/lib/dpkg/lock-frontend. It is held by process 6315 (synaptic)       
Reading package lists... Done                                                                                
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  linux-headers-5.12.11-051211* linux-image-unsigned-5.12.11-051211-generic* linux-modules-5.12.11-051211-generic*
0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
After this operation, 467 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.
mkaro ()
Последнее исправление: mkaro (всего исправлений: 1)
Закрыто добавление комментариев для недавно зарегистрированных пользователей (со score < 50)