LINUX.ORG.RU

OpenWrt не устанавливается пакет kmod-usb-serial

 


0

1

Не устанавливается пакет, есть мысли : root@OpenWrt:~# opkg install kmod-usb-serial

Installing kmod-usb-serial (4.14.241-1) to root… Downloading http://downloads.openwrt.org/releases/19.07.8/targets/ramips/mt76x8/packages/kmod-usb-serial_4.14.241-1_mipsel_24kc.ipk Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-serial:
  •  kernel (= 4.14.241-1-d92769dc5268e102503ae83fe968a56c)
    
  • opkg_install_cmd: Cannot install package kmod-usb-serial.root@OpenWrt:~# uname -a Linux OpenWrt 4.14.241 #0 Thu Jul 29 19:50:28 2021 mips GNU/Linux

root@OpenWrt:~# uname -r

4.14.241

root@OpenWrt:~# opkg list-installed | grep usb

kmod-usb-core - 4.14.241-1 kmod-usb-ehci - 4.14.241-1 kmod-usb-net - 4.14.241-1 kmod-usb-net-qmi-wwan - 4.14.241-1 kmod-usb-ohci - 4.14.241-1 kmod-usb-serial-wwan - 4.14.241-1 kmod-usb-wdm - 4.14.241-1 kmod-usb2 - 4.14.241-1

Подмена hash в /usr/lib/opkg/status спасёт , подробнее в интернете

One ★★★★★ ()

Самый простой и тупой вариант - собирать все нужные пакеты вместе с ядром, тогда версии в зависимостях правильные будут.

sislochka ()
Ответ на: комментарий от sislochka

Я как раз великий компиляторщик буду тут вопросы задавть, с слабым ноутом 2010г.

Organarh ()
Последнее исправление: Organarh (всего исправлений: 1)
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.