LINUX.ORG.RU
решено ФорумAdmin

OpenWrt не ставит OpenVPN

 ,


0

1

Пытаюсь поставить OpenVPN на OpenWrt Barrier Breaker 14.07.

# opkg info openvpn-openssl
Package: openvpn-openssl
Version: 2.3.6-2
Depends: libc, kmod-tun, liblzo, libopenssl
Status: unknown ok not-installed
Section: net
Architecture: ar71xx
Maintainer: Mirko Vogt <mirko@openwrt.org>
MD5Sum: 90c5a8dd979f29e4e6eff64d9a5602af
Size: 140749
Filename: openvpn-openssl_2.3.6-2_ar71xx.ipk
Source: package/network/services/openvpn
Description: Open source VPN solution using OpenSSL

Выдает ошибку:

# opkg install openvpn-openssl
Installing openvpn-openssl (2.3.6-2) to root...
Downloading http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/base/openvpn-openssl_2.3.6-2_ar71xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for openvpn-openssl:
 *      kernel (= 3.10.49-1-0114c71ed85677c9c1e4911437af4743) * 
 * opkg_install_cmd: Cannot install package openvpn-openssl.

Каким боком пакет зависит от ядра? В зависимостях пакета ядро вообще не указано.

★★

Каким боком пакет зависит от ядра? В зависимостях пакета ядро вообще не указано.

Понятно, каким:

# opkg info kmod-tun
Package: kmod-tun
Version: 3.10.49-1
Depends: kernel (= 3.10.49-1-0114c71ed85677c9c1e4911437af4743)
Status: unknown hold not-installed
Section: kernel
Architecture: ar71xx
MD5Sum: f9d9854f559a7482ce9ad89b6f6f5be8
Size: 12406
Filename: kmod-tun_3.10.49-1_ar71xx.ipk
Source: package/kernel/linux
Description: Kernel support for the TUN/TAP tunneling device
SaBo ★★ ()
Ответ на: комментарий от Black_Roland

Из исходников собирал?

Ага. Тоже подумал, что надо поставить уже готовую.
Надеюсь, что конфиги не слетят.

SaBo ★★ ()
Ответ на: комментарий от SaBo

Переставил с готового образа.
Настройки, вроде, все сохранились.

OpenVPN установился.

SaBo ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.