LINUX.ORG.RU

Как убрать растягивание экрана?

 , , ,


0

1

Имеется ноутбук модели Lenovo g50-30 с видеокартой от интел.Когда захожу в игру любую(например возьму Террария)и ставлю разрешение меньше разрешение экрана(1336x768),например 800x600,экран растягивается,и по краям невозможно работать курсором.Линукс стоит у меня второй системой рядом с Вин7,так вот играя там я не наблюдаю такого,но там можно это настраивать.Так вот как я могу такое-же провернуть на Линукс.Мне нужно чтобы изображение не растягивалось,а просто по бокам были чёрные полосы и в середине изображение с разрешением 800х600 Если что стоит Ubuntu 20.04

Ответ на: комментарий от zhuchka05

Тогда смотрите, сгибаете лист А4 пополам, вырезаете отверстие нужного размера, разгибаете и подставляете к монитору.

А если серьёзно, то когда вы изменяете разрешение, картинка будет подгоняться.

fernandos ★★★ ()
Ответ на: комментарий от fernandos

Понятное дело,но если в Винде это как то отключить можно и будут просто полоски по краям,то как это отключить в убунту?

zhuchka05 ()

Попробуй scaling mode поменять:

xrandr --output DVI-D-0 --set "scaling mode" "Center"

Вместо DVI-D-0 пиши свой реальный output, посмотреть можно через xrandr.

Kron4ek ★★★★★ ()
Последнее исправление: Kron4ek (всего исправлений: 1)
Ответ на: комментарий от eternal_sorrow

писец, овощи на лоре даже о базовых вещах не в курсе

anonymous ()
Ответ на: комментарий от Kron4ek

в xrandr выдаёт вот это eDP-1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 193mm

но когда прописываю команду с eDP-1 то пишет warning: output eDP1 not found; ignoring X Error of failed request: BadRROutput (invalid Output parameter)

zhuchka05 ()
Ответ на: комментарий от zhuchka05

Уверен, что правильно прописываешь? Ты написал eDP-1, но в ошибке у тебя eDP1 без тире. То есть ты, похоже, без тире прописал.

Kron4ek ★★★★★ ()
Последнее исправление: Kron4ek (всего исправлений: 2)
Ответ на: комментарий от Kron4ek

Да,прописал без тире. Написал правильно,в консоли после этой команды ничего не выдало,и в игре ничего не поменялось.Всё также экран растягивается

zhuchka05 ()
Ответ на: комментарий от zhuchka05

А какое разрешение экрана было в момент выполнения команды? Просто чтобы был эффект, нужно поменять на другое разрешение и потом обратно на нужное (во всяком случае у меня так).

xrandr --output DVI-D-0 --set "scaling mode" "Center"
xrandr -s 1366x768
xrandr -s 800x600
Kron4ek ★★★★★ ()
Последнее исправление: Kron4ek (всего исправлений: 1)
Ответ на: комментарий от zhuchka05

И можешь вместо «Center» попробовать еще «Full aspect».

Kron4ek ★★★★★ ()
Ответ на: комментарий от Kron4ek

хорошо но так меняется всё разрешение монитора,а мне нужно чтобы именно в игре если я ставлю меньше разрешение-изображение не растягивалось,а было разрешением таким каким я его ставлю и было просто в центре а по бокам были полоски.Но такое ещё раз говорю нужно именно в игре.Может в стиме как то можно это решить потому что в основном игры из стима у меня

zhuchka05 ()
Ответ на: комментарий от zhuchka05

Понимаю. Просто выполни:

xrandr --output eDP-1 --set "scaling mode" "Full aspect"

После этого при заходе в игру разрешение изменится на 800x600 и у тебя появятся полоски по бокам (по крайней мере должны).

Kron4ek ★★★★★ ()
Ответ на: комментарий от anonymous

не катит,курсор все время будет вылазить на рабочий стол,будут случайные нажатия куда не надо

zhuchka05 ()
Ответ на: комментарий от fernandos

Не обязательно, в хороших дровах метод подгонки настраивается. Но я хз как это делается на линуксовом драйвере интела.

kirill_rrr ★★★★★ ()
Ответ на: комментарий от zhuchka05

Запускай стим в отдельной сессии Иксов с нужным соотношением и разрешением.

FireFighter ★★★ ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.