LINUX.ORG.RU

chromium проблемы с аппаратным декодированием 4K 60FPS

 , , , ,


0

1

У кого-то есть проблемы с аппаратным декодированием в хромиуме 4K 60fps vp9? А то у меня всё декодируется аппаратно нормально (включая 1440p 60fps), а 4K 60fps начинается заикаться (при чём он заикается, дропает фреймы, но загрузку проца при этом показывается всего 5-10%).

Сразу скажу что моё железо в этом не виновато (например в firefox всё работает нормально и 4K 60fps с загрузкой проца 5-10%), это именно что-то с хромиумом. Хромиум дефолтный из debian testing. Всё что в хромиуме настраивал — это выставил флаг «Override software rendering list».

Тестировал на этом: https://www.youtube.com/watch?v=1La4QzGeaaQ

4K 60FPS https://ibb.co/HC4fPQ4; 1440P 60FPS https://ibb.co/nw63JGx

★★

У меня 13-14% грузит проц в фаерфоксе иайскэт. Это аппаратное ускорение работает. Полное аппаратное декодирование жрет меньше. Проверяй в minitube. Там только может придется mpv настроиться чтобы аппаратное декодирование работало.

anonymous ()
Ответ на: комментарий от anonymous

Это аппаратное ускорение работает. Полное аппаратное декодирование жрет меньше.

Что ещё за «Полное аппаратное декодирование»? А какое ещё может быть, неполное? Оно у тебя либо есть, либо его нет.

devorg ★★ ()

Мало просто поставить хромиум. Нужно удовлетворить требования. Перейти по адресу chrome://gpu/. В Graphics Feature Status должно быть всё зелёным, кроме Vulkan:. Плюс лучше использовать метод AccelMethod glamor https://wiki.archlinux.org/index.php/ATI

ShadowPrimary вызывает глюки, по крайней мере у радеона, его лучше не юзать.

Section «Module» Load «glx» Load «dri» Load «dri2» Load «glamoregl» Load «freetype» Load «extmod» Load «evdev» Load «GLcore» Load «dbe» Load «xtrap» Load «freetype» Load «record» EndSection Section «OutputClass» Identifier «Radeon» MatchDriver «radeon» Driver «radeon» Option "" Option «ColorTiling» «on» Option «ColorTiling2D» «on» Option «DRI» «2» Option «TearFree» "on Option «SWcursor» «false» EndSection Section «DRI» Mode 0666 EndSection

red_rain ()
Ответ на: комментарий от red_rain
Graphics Feature Status
Canvas: Software only, hardware acceleration unavailable
Compositing: Software only. Hardware acceleration disabled
Multiple Raster Threads: Enabled
Out-of-process Rasterization: Disabled
OpenGL: Disabled
Hardware Protected Video Decode: Disabled
Rasterization: Software only. Hardware acceleration disabled
Skia Renderer: Enabled
Video Decode: Software only. Hardware acceleration disabled
Vulkan: Disabled
WebGL: Software only, hardware acceleration unavailable
WebGL2: Software only, hardware acceleration unavailable
Problems Detected
Gpu compositing has been disabled, either via blocklist, about:flags or the command line. The browser will fall back to software compositing and hardware acceleration will be unavailable.
Disabled Features: gpu_compositing

Кажется, не только у линуксоидов печально. Chrome 87, Windows 10.

anonymous ()
Ответ на: комментарий от anonymous

Мне удалось настроить на Ubuntu 18.04 LTS, так чтобы всё работало. Так что вполне достижимо. Многое зависит от видео драйвера. И тут встройка лучше. Нужно иметь мощный APU, а не видео карту. Потому что есть баг с EFI и вылетом от переполнения оперативной и видео памяти. Firmware работают лучше чем проприетарные драйверы, как ни странно.

red_rain ()