LINUX.ORG.RU

ничто не предоставляет libm.so.6(GLIBC_2.29)(64bit)

 , ,


0

1

Доброго времени суток!

Вот такой сабж при установке некоторых приложений. Сейчас openSuse 15.1 до этого была 42.3 этот же софт работал. Принудительно переставлено glibc не помогает.

На форме ответа не нашел, гугл не помог.

Ответ на: комментарий от sluggard

Сорри. Спасибо. Почистил репозитории. Теперь не находит Х)

Хотел поставить эмуляторы Sony ps2 или ps3, но видно не судьба) попробовал более старые версии, другие ошибки, типа

libwx_baseu-3.0.so.0 => not found
libwx_gtk2u_core-3.0.so.0 => not found
libwx_gtk2u_adv-3.0.so.0 => not found
stslit ()
Ответ на: комментарий от stslit

Ну, PCSX2 есть в репе Emulators для разных версий openSUSE, в твоём случае — http://download.opensuse.org/repositories/Emulators/openSUSE_Leap_15.1/ правда пакеты почему-то только i586.
Вообще, ощущение, что у тебя намешаны репозитории от разных версий дистра, из-за чего постоянно возникают несогласованности зависимостей.

sluggard ★★★★★ ()
Ответ на: комментарий от sluggard

именно эта версия и не работает

[code]

| Псевдоним | Имя | Включен | Проверка GPG | Обновление

—+————————————-+—————————————–+———+————–+———– 1 | google-chrome | google-chrome | Да | (r ) Да | Да
2 | http-download.opensuse.org-31cff6ec | home:plater | Нет | —- | —-
3 | http-download.opensuse.org-630060fe | home:Sauerland:hardware | Да | (r ) Да | Да
4 | http-download.opensuse.org-7e32bfbd | server:messaging | Да | (r ) Да | Да
5 | openSUSE-Leap-15.1-1 | openSUSE-Leap-15.1-1 | Да | (r ) Да | Да
6 | packman_15.1 | packman_15.1 | Да | (r ) Да | Да
7 | repo-debug | openSUSE-Leap-15.1-Debug | Нет | —- | —-
8 | repo-debug-non-oss | openSUSE-Leap-15.1-Debug-Non-Oss | Нет | —- | —-
9 | repo-debug-update | openSUSE-Leap-15.1-Update-Debug | Нет | —- | —-
10 | repo-debug-update-non-oss | openSUSE-Leap-15.1-Update-Debug-Non-Oss | Нет | —- | —-
11 | repo-non-oss | openSUSE-Leap-15.1-Non-Oss | Да | (r ) Да | Да
12 | repo-source | openSUSE-Leap-15.1-Source | Нет | —- | —-
13 | repo-source-non-oss | openSUSE-Leap-15.1-Source-Non-Oss | Нет | —- | —-
14 | repo-update | openSUSE-Leap-15.1-Update | Да | (r ) Да | Да
15 | repo-update-non-oss | openSUSE-Leap-15.1-Update-Non-Oss | Да | (r ) Да | Да
16 | snappy | snappy | Да | (r ) Да | Да
17 | sublime-text | Sublime Text - x86_64 - Stable | Да | (r ) Да | Да
18 | teamviewer | TeamViewer - x86_64 | Да | (r ) Да | Нет
19 | tvinternal_it | TeamViewer Internal (IT repo) - x86_64 | Да | (r ) Да | Нет

[/code]

stslit ()

Официальные сборки pcsx2 всегда отличались неадекватными системными требованиями. То потребуют libGLEW такой версии, которой нет ни в одном дистре (кроме Ubuntu 13.10, в которой ту версию собирали), то libWX не-юникодная версия. 5 лет назад я выкладывал сборки PCSX2 на ЛОР. Я компилировал в CentOS 5, по итогу бинарники зависели от Glibc 2.4+ и GTK+ 2.10. Могу дать свои сборки, только они старые: 1.3.1 и 1.4.0.

ZenitharChampion ★★★★★ ()