LINUX.ORG.RU

Запуск VBox виртуалки по ssh

 


0

1

Доброго времени суток!

Нарисовалась проблема. Есть Linux Mint 19, на нем установлен VirtualBox 6.0 в нем соответственно крутится кучка виртуальных машин разного калибра. Доступ к хостовому компьютеру (то есть к MINT )есть только через SSH. Через ssh подключаюсь, запускаю виртуальную машину командой vboxmagane startvm name_vm --type headless. Система говорит что машина успешно запущена. Пытаюсь пингануть - ничего.

Кто-нибудь сталкивался с запуском виртуалки по сети?


Ответ на: комментарий от zbot

значит ip не тот, или хост не поднял сеть
сделай так: nmap --max-retries 1 -n -Pn 192.168.2.0/24, только подсеть (и маску) смени на свои
работать будет долго, но в итоге должно получилься что-то типа

Nmap scan report for 192.168.2.205
Host is up (1.9s latency).
All 1000 scanned ports on 192.168.2.205 are filtered

Nmap scan report for 192.168.2.206
Host is up (1.9s latency).
All 1000 scanned ports on 192.168.2.206 are filtered

Nmap scan report for 192.168.2.207
Host is up (0.00091s latency).
Not shown: 993 filtered ports
PORT      STATE SERVICE
135/tcp   open  msrpc
139/tcp   open  netbios-ssn
445/tcp   open  microsoft-ds
554/tcp   open  rtsp
2869/tcp  open  icslap
5357/tcp  open  wsdapi
10243/tcp open  unknown

Nmap scan report for 192.168.2.208
Host is up (2.5s latency).
All 1000 scanned ports on 192.168.2.208 are filtered


вот этот 192.168.2.207 и есть моя тачка в семеркой, а машин с ip .205, .206 и .208 нет.

metawishmaster ★★★★ ()
Ответ на: комментарий от project

Это какие-то красноглазые фантазии. Всё отвечает.

а у меня не отвечает, скорее всего, зависит от «версии», или у ты ставил из какой-то похаченой сблрки, я хз

у меня девственная (когда-то была) корпоративка

metawishmaster ★★★★ ()
Ответ на: комментарий от project

Виртуалки в той же сети, сеть настроена как сетевой мост.

NIC 1: MAC: 080027F79E64, Attachment: Bridged Interface 'enp2s0', Cable connected: on, Trace: off (file: none), Type: 82540EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none NIC 2: MAC: 080027DADAA5, Attachment: Bridged Interface 'enp1s0', Cable connected: on, Trace: off (file: none), Type: 82540EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none

zbot ()
Ответ на: комментарий от zbot

Плюс, хотел добавить. Когда работал локально за компом все работало. Машинку удаленно ребутнул. Если открыть VirtualBox локально, все работает как надо. Если по сети через вышеуказанную команду, то не работает. Говорит что запустилась, светится в запущенных виртуалках через vboxmanage list runningvms.

zbot ()
Ответ на: комментарий от zbot

Если открыть VirtualBox локально, все работает как надо.

То есть если запустить из вбоксового гуя то работает, а если из терминала - то нет? У вбокса есть свой встроенный RDP-сервер, попробуй зайти на него и посмотреть что творится в виртуалке.

project ()
Ответ на: комментарий от metawishmaster

У меня не было доступа к GUI Linux. Настроил, залез посмотреть что же там случилось. Перегрузил сетевуху и все заработало. Видимо заглючило. Всем спасибо за участие в решении проблемы. Сорян что все так прозаично!

zbot ()