LINUX.ORG.RU

KDE Konsole + Vim. Не отображает жирный шрифт.

 , , ,


0

3

Всем привет!
Сразу введу в курс дела.

Kubuntu 18.04 LTS
Vim 8.0.1453
Konsole 17.12.3

Проблема заключается в том, что жирный шрифт не отображается.
Например, мне часто приходится редактировать файлы Markdown (*md). Мне нравится делать это через Vim. Но при выделении нужного текста жирным шрифтом (в случае с Markdown - это заключение текста в **двойные звездочки** ) он остается обычным - не жирным.
Проделывая то же самое с курсивом - все в порядке.
Вот пример
https://c.radikal.ru/c05/2004/be/0b55cf54ce80.png
На сколько я понимаю, сама Konsole тут не при чем. Она поддерживает жирный шрифт, т.к. если изменить шрифт в настройках профиля (Konsole - Настроить профить - Внешний вид - Выбор шрифта) на жирный, то в Konsole шрифт становится жирным.
Пользуюсь шрифтом Hack, в котором есть поддержка как курсива, так и жирного начертания. Но так же пробовал и другие дефолтные шрифты, к примеру Ubuntu Mono - результат тот же - болд не отображается.

echo -e "\e[1mbold\e[0m"
echo -e "\e[3mitalic\e[0m"
echo -e "\e[4munderline\e[0m"
echo -e "\e[9mstrikethrough\e[0m"
pon4ik ★★★★★ ()

Как можно проверить жирный шрифт:

  1. vim --clean
  2. введи текст hello world
  3. :syn match World /world/
  4. hi World gui=bold cterm=bold term=bold

https://imgur.com/KacpNrj

habamax ★★ ()
Ответ на: комментарий от parnyagan

нет эффекта…

Проверь в другом эмуляторе терминала или в графическом виме…

habamax ★★ ()
Ответ на: комментарий от parnyagan

Я вижу, что вместо болда используется «яркий» цвет.

Некоторые терминалы так делают и по идее это настраивается.

[x] Draw bold text in bright colors
habamax ★★ ()
Ответ на: комментарий от EXL

Мигрируй на 20.04 LTS.

Ну или поставить другой эмулятор терминала

habamax ★★ ()

В настройках профиля konsole проверь, что в настройках внешнего вида стоит чекбокс для увеличения интенсивности полужирных символов.

Serral ()
Ответ на: комментарий от parnyagan

Ну и теперь сопутствующий вопрос:
Подскажите хорошо читаемый шрифт для консоли.

parnyagan ()
Ответ на: комментарий от parnyagan

Значит дело было в шриште…

оч. странно, хак отлично поддерживает болд.

Может конечно ты шрифт не полностью установил :)

habamax ★★ ()
Ответ на: комментарий от parnyagan

Подскажите хорошо читаемый шрифт для консоли.

тут у всех фломастеры разные.

Iosevka Extended мой выбор (самосборный, без лигатур)

Jetbrains Mono тоже хороший.

Из того, что у тебя должно быть в системе – Liberation Mono

habamax ★★ ()
Ответ на: комментарий от parnyagan

Подскажите хорошо читаемый шрифт для консоли.

У меня стоит Consolas и иногда использую DejaVu Sans Mono.

EXL ★★★★★ ()
Последнее исправление: EXL (всего исправлений: 1)
Ответ на: комментарий от parnyagan

Видимо - древняя console, попробуй st или gnome-terminal. Но, конкретно про markdown, из коробки там в подсветке вроде не жирный стоит, либо у меня тоже глюк какой то в этой точке.

pon4ik ★★★★★ ()
Ответ на: комментарий от habamax

Iosevka Extended

Вы про этот шрифт?
https://github.com/be5invis/Iosevka
Если да, то так и не понял, как его установить.

  1. Клонировал репо.
  2. Закинул все файлы из папки ttf к себе в ~/.fonts/ (там их че то мама не горюй сколько…).
  3. В Системные настройки - Шрифты - Шрифт видит.
  4. Konsole - Настроить профиль - Внешний вид - Выбрать шрифт - Шрифта нет!
parnyagan ()

Тебе уже писали, что нужно проверить настройки профиля. Лезешь в меню konsole:

Настройка -> Настроить профиль -> Внешний вид -> Использовать полужирный шрифт с яркими цветами

Если чекбокс ативен - то будет тебе жЫрный шрифт

htower_ ()
Ответ на: комментарий от parnyagan

Выбрать шрифт - Шрифта нет!

После копирования шрифтов кеш обновить надо.

fc-cache

man fc-cache:

fc-cache scans the font directories on the system and builds font information cache files for applications using fontconfig for their font handling.

Samsky ()

Дело в шрифте. Например у свежеустановленных кубунтах, федорах с кде, в System Settings текст подкатегорий пытается быть Bold, но в итоге он выглядит размазанным.

Причем такое во всех Qt приложениях. И это не фиксят годами!

Например я часто замечал что шрифт Liberations Sans вообще в Qt даже не пытается рисоваться полужирном из-за чего все эти «размазанные» bold выглядят просто как Regular.

bhfq ★★★★★ ()
Ответ на: комментарий от Samsky

После копирования шрифтов кеш обновить надо

Кэш обновлял, просто забыл упомянуть об этом.

parnyagan ()
Ответ на: комментарий от bhfq

Дело в шрифте

Однозначно!!! Т.к. у меня нашелся один шрифт, который все же отображает болд в консоле.
Называется FreeMono. И когда выбираешь его - болд в консоле и в Vim’е сообветственно подхватывается!
Вот прямой тому пример
https://d.radikal.ru/d06/2004/75/c9152b11fcc7.png
Так что с виновником вроде как определились. Осталось только накатить нужный шрифт. Мне, к примеру, очень приглянулся шрифт, который предложил Ув. habamax в этом посте. Шрифт называется Iosevka Extended. Нашел его на GitHub’е, но как я уже писал выше, в консоле он у меня не появился. Обновление кэша шрифтов делал.

parnyagan ()
Ответ на: комментарий от parnyagan

в консоле он у меня не появился

«Показывать все шрифты» попробуй

e1nste1n ★★★★★ ()
Ответ на: комментарий от e1nste1n

«Показывать все шрифты» попробуй

Да, шрифт появился! Но все-равно не могу с ним разобраться, там файлов *ttf в нем целая куча, какие из них надо забрасывать в папку ~/.fonts/ понятия не имею…

Может автор поста подскажет, что из всего этого «счастья» нужно, а что нет?

parnyagan ()
Ответ на: комментарий от parnyagan

Установить Source Code Pro и забить на все проблемы не вариант?

bhfq ★★★★★ ()
Ответ на: комментарий от bhfq

И его пробовал! Там так же идет несколько файлов *ttf, закидывал все что было, выбирал в консоле этот шрифт, но болд не отображался.
Может я что то делаю не так? Потому что уже столько шрифтов перебрал и все в пустую.
Дайте пошаговую инструкцию как правильно шрифты ставить.

parnyagan ()
Ответ на: комментарий от parnyagan

Может автор поста подскажет, что из всего этого «счастья» нужно, а что нет?

Я даже не знаю что подсказать – у меня не было никаких проблем с установкой шрифтов вообще и иосевки в частности – бери 4 нужных ttf (regular, italic, bold, bolditalic) необходимой базовой жирности и устанавливай. Если не уверен – устанавливай все.

Для себя я «компилирую» из исходников только 4 нужных мне ttf файла.

habamax ★★ ()
Ответ на: комментарий от parnyagan

Может я что то делаю не так? Потому что уже столько шрифтов перебрал и все в пустую

А ты можешь их проверять не в Konsole, а в обычной графической программе? Не знаю, что там в КДЕ из редакторов есть, Kate?

habamax ★★ ()
Ответ на: комментарий от habamax

А ты можешь их проверять не в Konsole

Kate вообще, по моему до лампочки, жирный там шрифт или нет, она все под одну гребенку отображает.
Вот Okularus есть
https://a.radikal.ru/a04/2004/82/7d236601bb58.png
А вот тот же файл в Vim
https://a.radikal.ru/a18/2004/84/aceeaf8b25b2.png
В Okularus разница между обычным и жирным вроде бы и есть, но столь незначительная… Это иосефка из того, что вы выложели выше.

parnyagan ()
Ответ на: комментарий от habamax

Все, народ, по-моему докопался до истины!
Поставил гномовский терминал и болд появился. Значит дело в консоле, не так ли?

parnyagan ()
Ответ на: комментарий от parnyagan

Ага, как бы не так…
Вот вечно я ищу себе преграды, а потом мужественно их преодолеваю :-\
Вот говорил же умный человек EXL, еще в начале темы: «Почитай - поможет!».
ТЫЦ
Так нет же… 2-ое суток плясал я вокруг, да около, но все-таки вспомнив решил вернуться. И точно.
В общем из указанной выше ссылки я перешел в тему с багами КДЕ
https://bugs.kde.org/show_bug.cgi?id=378523
где и нашел решение своей проблемы.
А именно: нужно удалить все вхождения Regular из 2-ух файлов.

~/.local/share/konsole/*.profile
~/.config/kdeglobals

Все, после этого жирный шрифт вернулся!!!
Соскучившись по нему, он мне от этого стал казаться еще жирнее :-D
Этот скриншот посвящается EXL
https://a.radikal.ru/a38/2004/e7/6cab84dd2ce8.png
;-)

parnyagan ()
Ответ на: комментарий от habamax

И да, Вам кстати тоже большая благодарочка! Шрифт очень глаз радует ;-)

parnyagan ()
Ограничение на отправку комментариев: только для зарегистрированных пользователей