LINUX.ORG.RU

Русские буквы в названиях файлов

 , ,


0

1

Всем моё почтение! Есть такая проблема: Имеется контейнер TrueCrypt. Создавался и использовался давно, под Виндой. Куча папок и файлов там названа по-русски. И использовать его нужно, как в Windows 7, 10, так и в Linux. Когда был Debian 10 с KDE - всё было нормально. Теперь перешел на Kubuntu - в названиях вместо русских букв вопросики. А названное русскими буквами в Kubuntu не понимает Винда. Еще проверил на KDE Neon - те же проблемы. Как бы на них сделать так же, как было в Debian?


Кодировку поменять. ЕМНИП, в «оффтопике» используется CP-1251 для кириллицы, а в «линуксах» стандартный «юникод». Плюс может быть так, что в «дебиане» нужные локали сгенерированы, а в «убунте» — нет.

Korchevatel ★★★★★ ()
Ответ на: комментарий от Korchevatel

Я сгенерировал локали. Теперь так: POSIX ru_RU.cp1251 ru_RU.iso88595 ru_RU.koi8r ru_RU.utf8 russian ru_UA.utf8 Была мысль еще utf16 испытать, но в dpkg-reconfigure locales её не вижу.

oleg70 ()
Ответ на: комментарий от anonymous

Если имеется в виду LANG=ru_RU.CP1251 TrueCrypt то результат - команда не найдена (только крокозябриками). Если, например, LANG=ru_RU.CP1251 mc то сам он весь будет в крокозябриках, но имена файлов все равно не показывает.

oleg70 ()

Теперь перешел на Kubuntu - в названиях вместо русских букв вопросики.

ээ. а можно подробнее. как ты открваешь и используешь сабж?

darkenshvein ★★★★★ ()

а не cp866 там на диске в windows?

AS ★★★★★ ()
Ответ на: комментарий от darkenshvein

Ну как, запускаю TrueCrypt, выбираю контейнер и монтирую. После чего он появляется, как /media/truecrypt1 И в любом файловом менеджере русские буквы в именах файлов не отображаются.

oleg70 ()

Это же блочный контейнер. Смотри какая ФС внутри. Ну, или по смонтированным смотри.

boowai ★★★★ ()
Ответ на: комментарий от oleg70

команда не найдена

Конечно не найдена. Как команда то правильно называется (ls /usr/bin)?

anonymous ()
Ответ на: комментарий от anonymous

iocharset=utf8,codepage=866

Формат такой. Если опции напрямую передаются на mount -o.

boowai ★★★★ ()
Ответ на: комментарий от anonymous

Уффффф! Я так чувствую, что тут много дельных советов. Я очень всем благодарен. Для развития их постепенно рассмотрю. Но сейчас одно сработало! После установки TrueCrypt mode в VeraCript контейнер открылся корректно. Названия отображаются правильно. Mount options прописывать не потребовалось. Т.е. сперва попробовал, но ничего не прокатило.

oleg70 ()
Ответ на: комментарий от darkenshvein

Сработало, если запускать truecrypt –fs-options=iocharset=utf8 /контейнер или прописать Mount options: iocharset=utf8 По ошибке думал, что имею дело с cp1251 Еще раз спасибо всем, кто старался помочь. Извините, коль тормозил.

oleg70 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.