LINUX.ORG.RU

Как сделать из Linux «телевизор» для воспроизведения мультиков?

 , ,


1

2

Возникла такая задача - есть ноут на Linux (поставлю любую сборку какую скажете), подключенный по HDMI к телевизору. На ноуте скачано много полезных мультиков, получивших моё одобрение. Мне нужно настроить Linux так, чтобы у него было поведение телевизора, а именно: чтобы смотреть мультики, нужно только включить ноутбук. Он должен загрузить систему, включить плеер с плейлистом мультиков на shuffle, и самое главное - заблокировать полностью систему, чтобы ни клавиатура, ни тачпад, на даже usb-мышка не работали. При необходимости изменения чего-то подключусь по ssh. Когда мультики надоели, точно так же выключили ноут и всё.

Подскажите, как мне реализовать такую блокировку? Может быть вообще уже есть какая-нибудь сборка Linux на подобии Kodi, которая уже сделана именно так, как я хочу? Спасибо.

Kodi. SDDM вообще умеет его запускать вместо оболочки. Не ставишь кеды, ставишь коди, его сеанс в автологин. Я, правда, без sddm делал, чтобы kodi сразу сам стартовал. Сервисом отдельным вместо sddm. Но вообще, сейчас бы через sddm бы сделал, наверное. Так проще немного.

turtle_bazon ★★★★ ()

Купи коробку с андроидом или приставку Т2. А есть еще лучше - iptv приставки, 64MB-RAM/4MB-ROM, там нечему ломаться, просто скорми плейлист.

anonymous ()
Ответ на: комментарий от anonymous

Щас проиграл БигБакБанни и Сенитель как раз на днище-коробке Т2 с флешки. Коробку подрубил к VGA входу моника, правда пришлось переходник докупить.

anonymous ()

Спасибо всем за советы, приятно видеть такое дружное коммьюнити.

Не проще к телевизору подключить внешний носитель с мультиками?

На моем телевизоре нет возможности настроить так, чтобы при включении телевизора сразу игралось всё, что есть на флешке. Максимум будет отображаться список файлов, и надо ткнуть на файл мультика чтобы начал показывать. А нужно чтобы вообще без кликов было - включил телевизор/ноут, и сразу играют мультики, как в телевизоре.

вместо xdm запускаешь xinit – /path/to/player (пишешь свой systemd сервис) клавиатуру и мышь отключаешь в /etc/X11/xorg.conf.d/ примерно так

В свое время устанавливал ArchLinux, сейчас установил с флешки, и понял, что столько свободного времени у меня уже нет :(

Libreelec + https://kodi.wiki/view/Parental_controls

Parental Control я так понял не лочит систему полностью, а просто не пускает в определенные разделы. Т.е. не совсем то, что нужно.

Самым частым ответом здесь на форуме всё же был LibreELEC, установил его и покопался поглубже. Получилась только первая часть, без блокировки:

  1. При установке LibreELEC 9.2.0 выбрал опцию включить SSH и SMB сервисы;
  2. После установки и запуска, с локального компа под виндой в сети открыл путь \\выданный_ip_libreelec\ в проводнике, открылись все папки. В папку Videos закачал несколько мультиков на пробу.
  3. В самой LibreELEC зашел в Movies, и при нажатии правой кнопкой мышки на папке с мультиками появляется меню, в котором можно выбрать Queque item, т.е. добавить в текущий плейлист.
  4. После этого я зашел в Options (там же слева), выставил shuffle и repeatAll, сохранил текущий плейлист в файл в системе, например cartoons.m3u
  5. Снова по SMB открыл расшареные папки, убедился что плейлист сохранился в файл \Userdata\playlists\video\cartoons.m3u, и затем добавил магию: создал файл autoexec.py в корне папки Userdata, с таким содержимым:
import xbmc
xbmc.executebuiltin("PlayMedia(/storage/.kodi/userdata/playlists/video/cartoons.m3u)")
  1. Перезапустил ноут, мультики стали показываться, причем в случайном порядке. Тут самое главное, чтобы ВСЕ файлы, указанные в плейлисте, были доступны и докачаны до конца. Если какой-то будет докачан не до конца, например через торрент, и именно этот файл рандомно выберется в качестве первого при запуске, то при запуске просто не будет ничего происходить - откроется обычная Kodi. Потратил много времени на эту хренотень, не понимал почему иногда включается, а иногда - нет.
  2. Осталось заблокировать клаву с мышкой. С мышкой справиться оказалось очень просто: Settings -> System -> Input -> Enable mouse and touch screen support -> выключить. Осталась только клавиатура! Я очень близок…

Зашел по ssh, вот список файлов в /etc, - получается что иксов в LibreELEC нет совсем?

$ cd /etc & ls
bash.bash_logout  hosts                nanorc                pki/        ssh/
bash.bashrc       inputrc              networks              profile     tigrc
DIR_COLORS        install-options.txt  nsswitch.conf         profile.d/  vimrc
docx2txt.config   msystem              package-versions.txt  protocols
fstab             mtab@                pkcs11/               services

Так что ваш совет

клавиатуру и мышь отключаешь в /etc/X11/xorg.conf.d/

не получается реализовать.

Есть идеи как заблокировать клавиатуру на дистрибутиве LibreELEC 9.2.0?

Madaro ()
Ответ на: комментарий от Madaro

https://forum.libreelec.tv/thread/13123-enable-disable-all-input-by-button-press/

Если какой-то будет докачан не до конца

Настрой так чтобы не до конца докачанные файлы хранились в другой папке

Jopich1 ()
Последнее исправление: Jopich1 (всего исправлений: 1)
Ответ на: комментарий от Jopich1

Настрой так чтобы не до конца докачанные файлы хранились в другой папке

Отличная идея, теперь настроил именно так.

Прочитал внимательно ту ветку и страницу вики https://kodi.wiki/view/Keymap Сделал свой keyboard.xml на основе системного из https://github.com/xbmc/xbmc/tree/master/system/keymaps, получилось вот так:

<?xml version="1.0" encoding="UTF-8"?>
<keymap>
  <global>
    <keyboard>
      <p>noop</p>
      <q>noop</q>
      <f>noop</f>
      <r>noop</r>
      <y>noop</y>
      <left>noop</left>
      <right>noop</right>
...

Сделал две копии этого файла - в /storage/.kodi/userdata/keyboard.xml (\Userdata\keyboard.xml в samba share) и на всякий случай в /storage/.kodi/userdata/keymaps/keyboard.xml (\Userdata\keymaps\keyboard.xml). Проверил по ssh что файлы на правильных местах. Перезагрузился. Клава работает как ни в чем ни бывало :( Такое впечатление, что мой файл не читается системой. Что я делаю не так?

p.s. увидел файл \userdata\guisettings.xml, там поставил на false строки связанные с controller или keyboard, перезагрузился, не помогло тоже.

    <setting id="input.asknewcontrollers" default="true">false</setting>
    <setting id="input.controllerpoweroff" default="true">false</setting>
    <setting id="input.enablemouse">false</setting>
    <setting id="input.libinputkeyboardlayout" default="true">us</setting>
    <setting id="input.rumblenotify" default="true">false</setting>
    <setting id="locale.activekeyboardlayout" default="true">English QWERTY</setting>
    <setting id="locale.audiolanguage" default="true">mediadefault</setting>
    <setting id="locale.charset" default="true">DEFAULT</setting>
    <setting id="locale.country" default="true">USA (12h)</setting>
    <setting id="locale.keyboardlayouts" default="true">English QWERTY</setting>
Madaro ()
Последнее исправление: Madaro (всего исправлений: 1)

В голову приходит автозапуск mpv в терминале, правда не уверен на счет shuffle плейлиста.

По поводу отключения клавы, что если заблеклистить модуль клавиатуры? Или это очень плохая идея?

aplay ★★★★★ ()
Последнее исправление: aplay (всего исправлений: 1)
Ответ на: комментарий от aplay

По поводу отключения клавы, что если заблеклистить модуль клавиатуры? Или это очень плохая идея?

да я бы с удовольствием, но как это сделать?

Madaro ()
Последнее исправление: Madaro (всего исправлений: 1)

китайская amlogic/rk приставка которую поддерживает *elec.
это будет тебе linux jeos for kodi, дальше луркай сам.
незнаю телеков в которые можно запилить *elec

etwrq ★★★★ ()