LINUX.ORG.RU

Не удалось активировать сетевое подключение в Kali Linux. Проблема с Wi-Fi

 , , ,


0

1

Все привет!!! Установил Kali Linux (GNU/linux 2019.2) (качал отсюда https://www.kali.org/) на VirtualBox. Сразу появились проблемы с сетью. В настройках сети VirtualBox я выставил: тип подключения- сетевой мост и выбрал имя своего адаптера D-Link WDA-140, типа адаптера- Intel PRO/1000 MT Desktop (82540EM) (стандарт для виртуальных машин), неразборчивый режим- Запретить и поставил галочку подключить кабель . Интернет в Kali Linux был, он подключение было проводное, а не адаптер (на основной системе я использую адаптер). Позже я напрямую прокинул адаптер в VirtualBox через настроки USB (при этом пропал интернет на основной системе, но это нормально). Linux стал видеть адаптер как wlan0, но переодически вылезает ошибка:«Не удалось активировать сетевое подключение». Пробовал метод решения этой проблемы из видео https://www.youtube.com/watch?v=xwQtyE91Fp8&t=65s . Всё заработало, однако в терминале отображаются аж 3 беспроводных сетевых интерфейса. И в настройках wifi тоже. Я решил перезагрузить машину и у меня опять ничего не работает (то есть при выключении и включении машины нужно заново выполнять команды по активации этого файла из видео). Так же у меня есть страница с этим вопросом на Ответы Мэйл.ру. Вот ссылка:https://otvet.mail.ru/question/215597527 читайте комментарии к лучшему ответу, там много скриншотов, описывающих мою проблему. Буду очень вам благодарен, если вы мне поможете решить эту проблему!

Убери из тегов debian, дебилушка!

anonymous ()
Ответ на: комментарий от darkenshvein

На Мэйлру есть картинки, дополняющие мою проблему так сказать. Здесь всё подробно описал

SGOVEL ()
Ответ на: комментарий от anonymous

Пробовал метод решения этой проблемы из видео https://www.youtube.com/watch?v=xwQtyE91Fp8&t=65s . Всё заработало, однако в терминале отображаются аж 3 беспроводных сетевых интерфейса. И в настройках wifi тоже. Я решил перезагрузить машину и у меня опять ничего не работает!

SGOVEL ()
Ответ на: комментарий от ya-betmen

Я прокинул wifi адаптер в ВМ через USB контроллер, в Kali в терминале команда ifconfig отображает мой адаптер как wlan0, но периодически в верхней части экраны всплывает ошибка подключения к сети.

SGOVEL ()
Ответ на: комментарий от quantum_cat

Перешёл, по твоей ссылке, там первый коммент с этой ссылкой https://ubuntuforums.org/showthread.php?t=1914575&page=2 , перешёл по ней и следовал инструкции 18 комментария на 2 странице, однако у меня ничего не получилось: архив дважды не распаковывается, команды не работают, плюс там есть пункт, где нужно заменить значения в файле os/linux/config.mk, но там нет тех строк в которых нужно поставить Y , я даже через Найти искал и ничего не получилось.

SGOVEL ()
Ответ на: комментарий от SGOVEL

Пробрось сеть в виртуалку через NAT. Далее выполни в терминале:

sudo apt update  
sudo apt upgrade
sudo apt install firmware-ralink

Где:
sudo - выполнить от суперпользователя,
apt update - обновить список пакетов,
apt upgrade - обновить систему,
apt install firmware-ralink - установить firmware для чипсетов ralink.
Далее прокидывай свой D-Link WDA-140б как ты это делал последний раз. Все должно заработать.
Если не получится, возьми другой дистрибутив.
Ubuntu например.

quantum_cat ★☆ ()
Последнее исправление: quantum_cat (всего исправлений: 2)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.