LINUX.ORG.RU

apache update

 


0

1

Доброго дня!

Первый раз работаю с apache, подскажите как обновить до последней версии? yum info httpd Loaded plugins: changelog, langpacks, product-id, search-disabled-repos Installed Packages Name : httpd Arch : x86_64 Version : 2.4.6 Release : 88.el7.centos Size : 9.4 M Repo : installed From repo : base Summary : Apache HTTP Server URL : http://httpd.apache.org/ License : ASL 2.0 Description : The Apache HTTP Server is a powerful, efficient, and extensible : web server.

подскажите как обновить до последней версии

Что вы под этим понимаете.

До последней версии в репозитории или до последней версии апач?

Если в реплзитории, то просто:

yum update

Если до последней версии апач в принципе, то ищите репозиторий, в котором она есть, подключайте и ставьте.

И используйте тег [code][/code] и кнопку «Предпросмотр».

anonymous ()
Ответ на: комментарий от Avengerist

запустил yum localinstall httpd-2.4.39-1.codeit.el7.x86_64.rpm инсталляция прошла без ошибок, но yum info httpd не показывает новую версию ?

Installed Packages Name : httpd Arch : x86_64 Version : 2.4.6 Release : 89.el7.centos Size : 9.4 M Repo : installed From repo : updates Summary : Apache HTTP Server URL : http://httpd.apache.org/ License : ASL 2.0 Description : The Apache HTTP Server is a powerful, efficient, and extensible : web server.

konstantinP ()
Ответ на: комментарий от konstantinP

Ошибка инсталляции rpm

yum localinstall httpd-2.4.39-1.codeit.el7.x86_64.rpm

--> Finished Dependency Resolution Error: Package: httpd-2.4.39-1.codeit.el7.x86_64 (/httpd-2.4.39-1.codeit.el7.x86_64) Requires: httpd-filesystem = 2.4.39-1.codeit.el7 Available: httpd24u-filesystem-2.4.37-1.ius.el7.noarch (ius) httpd-filesystem = 2.4.37-1.ius.el7 Available: httpd24u-filesystem-2.4.38-1.ius.el7.noarch (ius) httpd-filesystem = 2.4.38-1.ius.el7 Available: httpd24u-filesystem-2.4.39-1.ius.el7.noarch (ius) httpd-filesystem = 2.4.39-1.ius.el7 Error: Package: httpd-2.4.39-1.codeit.el7.x86_64 (/httpd-2.4.39-1.codeit.el7.x86_64) Requires: httpd-filesystem = 2.4.39-1.codeit.el7 Available: httpd24u-filesystem-2.4.37-1.ius.el7.noarch (ius) httpd-filesystem = 2.4.37-1.ius.el7 Available: httpd24u-filesystem-2.4.38-1.ius.el7.noarch (ius) httpd-filesystem = 2.4.38-1.ius.el7 Installing: httpd24u-filesystem-2.4.39-1.ius.el7.noarch (ius) httpd-filesystem = 2.4.39-1.ius.el7 Error: httpd conflicts with apr-1.4.8-3.el7_4.1.x86_64 Error: Package: httpd-2.4.39-1.codeit.el7.x86_64 (/httpd-2.4.39-1.codeit.el7.x86_64) Requires: httpd-tools = 2.4.39-1.codeit.el7 Installed: httpd-tools-2.4.6-89.el7.centos.x86_64 (@updates) httpd-tools = 2.4.6-89.el7.centos Available: httpd-tools-2.4.6-88.el7.centos.x86_64 (base) httpd-tools = 2.4.6-88.el7.centos Available: httpd24u-tools-2.4.37-1.ius.el7.x86_64 (ius) httpd-tools = 2.4.37-1.ius.el7 Available: httpd24u-tools-2.4.38-1.ius.el7.x86_64 (ius) httpd-tools = 2.4.38-1.ius.el7 Available: httpd24u-tools-2.4.39-1.ius.el7.x86_64 (ius) httpd-tools = 2.4.39-1.ius.el7 Error: Package: httpd-2.4.39-1.codeit.el7.x86_64 (/httpd-2.4.39-1.codeit.el7.x86_64) Requires: mod_http2 Error: Package: httpd-2.4.39-1.codeit.el7.x86_64 (/httpd-2.4.39-1.codeit.el7.x86_64) Requires: libbrotlicommon.so.1()(64bit) Error: Package: httpd-2.4.39-1.codeit.el7.x86_64 (/httpd-2.4.39-1.codeit.el7.x86_64) Requires: libbrotlienc.so.1()(64bit) You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

konstantinP ()