LINUX.ORG.RU

Ошибка при dpkg --configure -a

 ,


0

1

Здравствуйте!

ubuntu 18.04, KDE. Во время обновления слетела сеть, пришлось отменить. Заново обновление не запустилось. Система предложила выполнить dpkg --configure -a. Во время выполнения команды


dpkg: ошибка при обработке пакета grub-pc (--configure):
 пакет абсолютно неработоспособен; перед настройкой его
 следует переустановить

Подскажите пожалуйста, что нужно сделать.

Полный вывод dpkg --configure -a

root@alexrsk-desktop:~#  dpkg --configure -a
Настраивается пакет libapt-inst2.0:amd64 (1.6.8) …
Настраивается пакет deja-dup (37.1-2fakesync1ubuntu0.1) …
Настраивается пакет apt-transport-https (1.6.8) …
Обрабатываются триггеры для mime-support (3.60ubuntu1) …
Обрабатываются триггеры для ureadahead (0.100.0-20) …
ureadahead will be reprofiled on next reboot
Обрабатываются триггеры для desktop-file-utils (0.23-1ubuntu3.18.04.2) …
Настраивается пакет apt-utils (1.6.8) …
dpkg: ошибка при обработке пакета grub-pc (--configure):
 пакет абсолютно неработоспособен; перед настройкой его
 следует переустановить
Обрабатываются триггеры для libglib2.0-0:amd64 (2.56.3-0ubuntu0.18.04.1) …
Настраивается пакет opera-stable (58.0.3135.53) …
Обрабатываются триггеры для libc-bin (2.27-3ubuntu1) …
Обрабатываются триггеры для systemd (237-3ubuntu10.11) …
Обрабатываются триггеры для man-db (2.8.3-2ubuntu0.1) …
Обрабатываются триггеры для shared-mime-info (1.9-2) …
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Настраивается пакет avahi-autoipd (0.7-3.1ubuntu1.2) …
Обрабатываются триггеры для gnome-menus (3.13.3-11ubuntu1.1) …
Обрабатываются триггеры для dbus (1.12.2-1ubuntu1) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
Настраивается пакет libavahi-common-data:amd64 (0.7-3.1ubuntu1.2) …
Настраивается пакет libavahi-common3:amd64 (0.7-3.1ubuntu1.2) …
Настраивается пакет libavahi-core7:amd64 (0.7-3.1ubuntu1.2) …
Настраивается пакет avahi-daemon (0.7-3.1ubuntu1.2) …
Настраивается пакет libavahi-client3:amd64 (0.7-3.1ubuntu1.2) …
Настраивается пакет avahi-utils (0.7-3.1ubuntu1.2) …
Настраивается пакет python3-distupgrade (1:18.04.30) …
Настраивается пакет python3-update-manager (1:18.04.11.9) …
Настраивается пакет ubuntu-release-upgrader-core (1:18.04.30) …
Устанавливается новая версия файла настройки /etc/update-manager/release-upgrades …
Настраивается пакет ubuntu-release-upgrader-qt (1:18.04.30) …
Настраивается пакет ubuntu-release-upgrader-gtk (1:18.04.30) …
Настраивается пакет update-manager-core (1:18.04.11.9) …
Настраивается пакет update-notifier-common (3.192.1.5) …
Настраивается пакет update-notifier (3.192.1.5) …
Настраивается пакет update-manager (1:18.04.11.9) …
Обрабатываются триггеры для libc-bin (2.27-3ubuntu1) …
При обработке следующих пакетов произошли ошибки:
 grub-pc

Ответ на: комментарий от anonymous

Спасибо. Сделал так. Переустановился, но сказал, что остались неудовлетворенные зависимости.

Возможно, для исправления этих ошибок вы захотите воспользоваться «apt --fix-broken install».
Следующие пакеты имеют неудовлетворённые зависимости:
 grub-pc : Зависит: grub-common (= 2.02-2ubuntu8.10)
           Зависит: grub2-common (= 2.02-2ubuntu8.10)
           Зависит: grub-pc-bin (= 2.02-2ubuntu8.10)
Чтобы это удовлетворить (нашли, блин, удовлетворителя :-) ) сделал apt --fix-broken install. Команда отработала без ошибок, но там была интересная строчка
Настраивается пакет grub-pc (2.02-2ubuntu8.10) …
Выполняется установка для платформы i386-pc.
File descriptor 3 (pipe:[96610]) leaked on vgs invocation. Parent PID 14452: grub-install
File descriptor 3 (pipe:[96610]) leaked on vgs invocation. Parent PID 14452: grub-install
File descriptor 3 (pipe:[96610]) leaked on vgs invocation. Parent PID 14452: grub-install
Установка завершена. Ошибок нет.
Вопрос: А то, что у меня система x64, не помешает?

AlexRsk ()