LINUX.ORG.RU

не захватывается звук

 , ,


0

1

пытаюсь оцифровать видео с устройства видеозахвата, видео идёт нормально, а звук не идёт - mplayer, mencoder просто пишут no sound, vlc такое выдаёт:
[0x7fa12c004ae8] filesystem access error: cannot open file /home/mar/hw:4,0 (No such file or directory)
[0x7fa1240009b8] main input error: open of `file:///home/mar/hw%3A4%2C0' failed
[0x7fa12c01e728] filesystem access error: cannot open file /home/mar/hw:0,0 (No such file or directory)
[0x7fa124005f68] main input error: open of `file:///home/mar/hw%3A0%2C0' failed

звук подключал как на usb захватывалку, так и на звуковую карту, в микшере все захваты включены, громкость выставлена, пробовал на ubuntu 14.04 и 16.04 на разных компах


Ответ на: комментарий от MaR

всё включено

Что скажет Alsa-tools?:

$ arecord -d 10 -f cd -t wav atest.wav
...
$ aplay atest.wav

Что скажет SoX?:

$ rec test.wav
...
$ play test.wav
Deleted ()
Последнее исправление: Deleted (всего исправлений: 3)
Ответ на: комментарий от MaR

это говорит vlc, видимо там ищет звуковое устройство

Где это «там»? В домашней папке? И почему он именно «там» решил его искать? Кто его надоумил?

Deleted ()
Ответ на: комментарий от Deleted

в консоль говорит так, мне так же не понятно, почему и что он там ищет
arecord пишет звук, при этом mencoder, ffmpeg, mplayer и vlc звук не дают

MaR ()

ты провод не в то гнездо втыкаешь

anonymous ()
Ответ на: комментарий от MaR

мне так же не понятно, почему и что он там ищет

А кому это должно быть понятно? Кто это настраивал? Вася Пупкин?

Deleted ()
Ответ на: комментарий от Deleted

настраивал что?
раньше, на предыдущих версиях mencoder tv:// -tv device=/dev/video1...... и всё ок, а теперь mencoder на это говорит Audio: no sound, ffmpeg так же звук не захватывает, vlc вообще какую-то дичь выдаёт, пробовал на 3-х с 14.04 и 16.04 убунтами - всё одно и то же

MaR ()
Ответ на: комментарий от MaR

настраивал что?

Вот именно. Вот именно. Ты какую команду, друже, пользуешь?

PS: Кашпировские в отпуску.

Deleted ()
Ответ на: комментарий от MaR

давай тогда так. даю команду:

ffmpeg -f v4l2 -i /dev/video1 -f alsa -i hw:0 -c copy capture.mkv

вместо нуля в «hw:0» подставляй подряд остальные числа натурального ряда, пока не появится звук. если по окончании ряда звук всё-таки не появится, то проверь установки захвата своей карты в alsamixer'е. там же, кста, можешь и нужный номерок подглядеть для второй попытки. если же опять ничего, то, либо устройство кем-то нагло захвачено, например, pulseaudio, либо ты воткнул свой девайс не в тот джек — нужно втыкать в голубенький. если же ты перепробовал все варианты и всё ещё ничего не слышно, то, возможно, проблема аппаратная или, не дай бог, генетическая.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.