LINUX.ORG.RU

Вместо Grub2 черный экран но Linux запускается

 , , , ,


0

1

ОС: Linux Mint UEFI + GPT

Сейчас Grub2 прописан в dev/sdb

Устр-во       начало     Конец   Секторы Размер Тип
/dev/sda1       2048 164194303 164192256  78,3G Файловая система Linux
/dev/sda5  164194304 583624703 419430400   200G Файловая система Linux

# Mint на /dev/sdb2

Устр-во      начало     Конец  Секторы Размер Тип
/dev/sdb1      2048    780287   778240   380M EFI
/dev/sdb2    780288  60780543 60000256  28,6G Файловая система Linux
/dev/sdb3  60780544 100780031 39999488  19,1G Файловая система Linux

Grub2 я прописывал в разные сектора и менял местами диски в BIOS - результат один и тот же: секунды три черный экран, потом грузится Mint. Такое поведение наблюдается только на Mint, до этого был Debian и openSUSE. Если установить другой загрузчик, тот же rEFInd, то проблем никаких нет.

Как это вылечить?

★★★

Ответ на: комментарий от Vsevolod-linuxoid

Не помогает update-grub, но на изменение настроек реакция есть, на ту же время загрузки. Еще заметил, что в Grub Customizer напротив devicemap_file отображается восклицательный знак

devicemap_file : /boot/grub/device.map

CryNet ★★★ ()
Ответ на: комментарий от rumgot

Неправильно сформировал сообщение. Я то знаю, что GRUB грузится, но оно никогда у меня не отображалось. Только если нажать f8 при загрузке и это вроде норма по дефолту.

Qurao ()
Ответ на: комментарий от rumgot

Вот листинг /etc/default/grub

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="Ubuntu"
GRUB_TIMEOUT_STYLE="hidden"
GRUB_TIMEOUT="1"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE="saved"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_SAVEDEFAULT="false"
export GRUB_COLOR_NORMAL="light-gray/black"
export GRUB_COLOR_HIGHLIGHT="magenta/black"
CryNet ★★★ ()